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Overview

* From Data to “Decision Ready” Data

New Uses for and Users of Pl System Data

Enabling Analytics for Operational Intelligence
— Descriptive, Predictive and Multidimensional (Bl)

* Driving Continuous Improvement

« Summary and Wrap Up
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From Data to “Decision Ready” Data

Data “Decision Ready” Data

Accessible for
iInvestigation and analysis

Data integration
capabilities

i e Anywhere access and
= = socialization
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Scalable “Decision Ready” Reporting

Centrica Energy
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 Configured concise, o e =

scalable reports | I | —

. Genera tor | | o || 2011
based on Pl AF using s oo 0
PowerPivot for Excel. i e
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- Eliminated 199,000 == . i e
custom calculations in A

Excel. % 04— _— centr ica
O energy
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Rapid “Decision Ready” Analysis

Carnegie Mellon University — School of Architecture

Asset Management

« Utility usage and
costs for 1600 branch
offices.

* Rapid delivery of
analytical reporting.

 |ncreased the value of
the data.
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Energy Star Buildings

Rating by Address
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Integrated “Decision Ready” Assessment

PSE&G

Asset Risk Assessment

Data integration from;

» Operations
« Maintenance
« Service Demographics

» Geospatial Sources
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Opportune “Decision Ready” Prediction
San Diego Airport

[Airport Electricity Demand

J h ©403.63
Develop a model to predict — | ‘
energy use at San Diego N ” ﬂ ‘ L i
Airport. This model can be %%ﬁ%ﬂ »MMH
. . ! Bl
used for capacity planning, and ¥ b “-
abnormal Spike detection and 11711/2014 12:00:00 AM @, 8 6.96 days <[> & 11/17/2014 11:00:00 PM
notification. T ﬂ 2,
Nw 235511
L1
, b
- Actual Energy Use i ff‘ \L
Il Predicted Energy Use o= el éf b, %‘th
2/0100!2014 17:38 PM ©.10.99 hours <[> & 9/11/2014 12:16:50 AM
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New Uses for and Users of Pl System Data

ERP

Real-Time CMMS Retrospective &

Decision EMS Predictive CRM

Analysis oMS Analysis, . Market

¥ 2 ¢ ) 0
4b M Weather »"‘,&‘u % !: [ e Contracts
" | B GIS AR LQA m Warranty
fAh ves

- Finance
Reporting, Analytics,

BIl, Business
Processes...

Business
Drivers

Operational
Drivers

Process Monitoring,
Situational Awareness

Enterprise
Infrastructure
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Enabling Analytics for Operational Intelligence

Real-Time Decision Analysis Retrospective & Predictive Analysis

Pl Integrator for

Business Analytics
& Elements
: g Gﬁthr:aanrrot River i
| Egm \
Time and Event | FSim — ;
Trending & Awareness | g Multidimensional
5w Business Intelligence
Specialized Models e & Dashboards
Simulation & Optimization Establishes Common Ground
between .
_ APopekh OT and IT Contexts P 1 7, ¥ Sy
Te = i i e I
141.2”3{]{!’!} P % + S} Tlme, Event Tabular 172372014 120000 AN aa 10
.. and Asset Context Predictive
Descriptive Context Statistical Modelling
Performance

& Condition & Machine Learning
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Descriptive Analytics - Performance & Condition

. . . 2 2
« First Principles H=2+2 4 ;’_ —h+ ;"_
Relationships always exists R Pg. 29 g
between process Daniel Bernoulli
1700 - 1782 *
measurements ( ) APpp + kh

B 141.2uBy{In = — § + 5}

. . PV = nRT
« Time synchronized "

observations for meaningful

R+ DY xIn(1-SR)Y (1-S))

Benoit Clapeyron F =
reSUItS (1799—1864) (l—R)xlu{l-S(R—l—(va)l:) }

i

2-S(R+1+@®R+D)

« Enables real-time decision
making only when visible,
i.e. not performed in P=1IV=IR=—

James Watt
spreadsheets (1736.1819)
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Descriptive Analytics - Pl Asset Analytics

Cold fluid in Shell 5 Hot fluid out

w. W. T, 1. HeatDuty. Q=q, + q
. - o 4 " Qs = Wx Cpp, X(T- T)/1000/3600
» Configure calculations at scale ( Hi[@ , E e
B . “ 3. Cold fluid pressure drop. AP¢ = p;i- po
— g

Calculation Steps:

« Math, statistical, logical and B o e
) ) e 5. Temperature range cold fluid. At =1, — t;
Steam tab I e fu n Cti O n S Heat Exchanger Key Performance Indicator: 6. Capacity ratio. R =W x Cpn / W X Cpe (0or) (Ti- To) / (to- )
Overall heat transfer coefficient 7. Effectiveness. S = (to- t)) / (T, — t;)
8. LMTD
Q LMTD Counter current Flow = ((Ti-te) — (To-t)) / In ((Ti-te)/(Tort0)

LMTD Co current Flow = ((Ti=t;) — (Tot5)) / In ((Ti=t)/(To=1o))

- - - Seaee e e Corre ion factor for LMTD to account for Cross flow
« Supports simple predictive A concaea e I ——

=
- RULE: IF the heat transfer coefficient is decreasing, (1-R)xIn { S(R+1—(R+1" l) }
an aI ICS THEN the Heat Exchanger FOULING !!! S(R+¥1+®R+D™)
Cleaining is required! 9. Corrrected LMTD =F x LMTD

@ Bement Templates ul | Name [Gverat et Tranter Coethcient )

 Supports future data for o P e ,  — :

ty

B (G Custody Transfer Analysis Type: (% Expression ( Rollup (~ Event Frame Generation
. @ Fractonator
€ FuelGas
orecasting ol
€ Heat Exchanger Templat =
B G Heater [@ staivtic C
) Gas Fred Heater ] | Evetuae| Functia
e
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G e v
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. . . G Piserver T T . oy
[ & St & Tube Side Mass Flow'*'Cold Side Temperature Difference’'Tube Side Heat Capacity'*3600 Hoak DT B e
@ Reactor Q Map ® Asin
Refineries ! { At
€@ Regenerator R ( de Inlet Temperature'- Side Outlet Temperature’)/('Cold Side Outlet Temperat Map ® |am2
ste T t t L Avg
25,.,‘,... s ('Cold Side Outlet Temperature'-‘Cold Side Inlet Temperature')/('Hot Side Inlet Temperature'-'Cold Map ® BadVal
& T i | side Inlet Te 4 T 3 | | T
Re de Inl mperature’ - ‘Cold Temperature')-
0y Tk e wmo ¢ t Temperature® Side Inlet Temperature'))/Log(( Mot Side Inlet Temperature'- LMD ® ::m
gvzz‘:w |"co1d t Temperature')/(‘Hot Side Outlet Temperature'-'Cold Side Inlet Temperature')),1) | [ 1l c=n
B g Ut 3 ((R+1)%0.5°Log((1-5°R)/(1-5)))/((1-R)*Log((2-5* (R+1- (R+1)"0.5))/(2-5* (R+14(R+1)*0.5)))) Map ® g'w
@ " Event Frame Templates . 4 ! ompan
& (%, Model Tenpiates UiTDcorr FoLiTD Mag ® | concat
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Enabling Analytics for Operational Intelligence

Real-Time Decision Analysis Retrospective & Predictive Analysis

Pl Integrator for
Business Analytics

Time and Event i = .
Trending & Awareness oo e e Multidimensional

| o W — Business Intelligence
. T & Dashboards

Specialized Models
Simulation & Optimization

- APpp % kh
141.2;.&30{511;—:, 34 s}

Time, Event Tabular
and Asset Context

Predictive

ijirsfcc):rrr:]gﬂ(\:/ee Context Statistical Modelling
& Condition & Machine Learning
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Pl Integrator for Business Analytics - “Select Data”

* Intuitive way to
Create tabu|ar Select Data > Modify View > Publish Next
content in “PI © Source Assets = Asset Shape e

. ” Server CHERTLER6430S ‘
VIeWS Database Compressors & Compressor p @ Compressor-023

T, Shapes ound 29 Matches

Compressor-304
& Differential Pressure @ P
@ Compressor-340

. # Gas Flow £ @ Compressor-356

i Req u I res AF = S = (@) Compressor-432

. 1 Edit Filters (@ Compressor-567
Hierarchy o o

@ Unito1
@ Unito2

° Select AF Elements ‘ Compressor-023 gj::z;
and Attrlbutes M Asset Template & unioa

@ Unito4

Unito4
(*) Add Filter © n?
@ unitos

« Scale up leveraging |o: & unos

@ Unitos

name, hierarchy, or _ @ unos

@ Unito7

Category : @ Unito?

@ Unito7
D

[(Asset Name
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Pl Integrator for Business Analytics - “Modify View”

« Select any time
range and interval

 Add columns for

proper aggregating
Pl System data

 Add columns for
common time and
date functions

Select Data > Modify View > Publish

Compressor Analysis

= Add Column

7 Edit Row Filters

[T
= Edit Value Mode

Start Time

® Column Details

Name

Gas Flow |

Reset Name to Default

Data Content @

& Columns ORow Filters Rifﬁ'ﬁ ‘E: lues
Compressor LocalTime Differential Pressure Gas Flow
Unit01 2011-10-01 00:00:00 93.3822 100.6735 Model A
Unit01 2011-10-01 00:01:00 93.36484 100.6739 Model A
Unit01 2011-10-01 00:02:00 93.34747 100.6742 Model A
Unit01 2011-10-01 00:03:00 93.33011 100.6746 Model A
Unito1 2011-10-01 00:04:00 93.31274 100.675 Model A
Unit01 2011-10-01 00:05:00 93.29539 100.6754 Model A
Unit01 2011-10-01 00:06:00 93.27802 100.6758 Model A
Unit01 2011-10-01 00:07:00 93.26066 100.6761 Model A
Unit01 2011-10-01 00:08:00 93.24329 100.6765 Model A
Unit01 2011-10-01 00:09:00 93.22593 100.6769 Model A
unit01 2011-10-01 00:10:00 93.20856 100.6772 Model A
Unito1 2011-10-01 00:11:00 93.1912 100.6776 Model A
Unit01 2011-10-01 00:12:00 93.17384 100.678 Model A
Unit01 2011-10-01 00:13:00 93.15647 100.6784 Model A
Unit01 2011-10-01 00:14:00 93.13911 100.6787 Model A

tandard Deviation

Population Standard Deviation

© Copyright 2016 OSlsoft, LLC 14
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Pl Integrator for Business Analytics - “Publish”

i SeleCt targeted Select Data > Modify View > Publish
endeint “PI VieW”’ Target Configuration Summary

MS SQL’ File’ more | Pl view Shape and Matches
to Come e O Run Once + There are 29 Matching Instances.

® Run on a Schedule

Timeframe and Interval

« Your Start Time is Saturday, October 1,
First Run 2011 12:00:00 AM

* Publishonceoron [ I R

201 12:00-:00 AM

4 » = Your Time Interval gets an interpolated

a scheduled bases e e T

u Mo Tu We Th Fr  Sa

25 26 27 28 29 30 3
1 2 3 4 5 6 7 “

a8 9 o 1 12 13 14
% 1%®| 17 1|’ 192 20 21
22 23 24 25 26 27 28
23 30 1 2 3 4

Hour Minute Second

0o|v] oo[v| 0o|v|
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Enabling Analytics for Operational Intelligence

Real-Time Decision Analysis Retrospective & Predictive Analysis

Pl Integrator for
Business Analytics

asTran
(@ CarrotRiver i

Time and Event
Trending & Awareness

Multidimensional
Business Intelligence
& Dashboards

Specialized Models
Simulation & Optimization

APpp % kh i —
Q - Te 3
141.2,uB@{ZnE -3+ S} Time, Event Tabular

= 74N I

A BT F Ll o

172372014 12.00.00 AM o I

o and Asset Context Predictive
Dpeeﬁc():rl;:]g':]l(\:/ee Context Statistical Modelling
& Condition & Machine Learning
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Scenario: “Predict Airport Energy Use”

Develop a model to predict
energy use at San Diego
Airport. This model can be
used for capacity planning,
and abnormal spike
detection and notification.

- Actual Energy Use
- Predicted Energy Use

@ osisoit. REGIONAL SEMINAR

[Airport Electricity De

mand

|
I \
\s

300

11/11/2014 12: 0 AM @ a8 696d3ys<][>@ AT
Airport Electricity Demand

800 .20

ﬂ KILOWATTS

z
M
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Statistical Analytics - Example: Energy Prediction

Predicted Power = 0.2324 * Average( Actual Power, 1 day ago, +/- 5 min) +

0.1421 * Average( Actual Power, 2 days ago, +/- 5 min) +
.......... (terms for 3-13 days ago)......

0.0435 * Average( Actual Power, 14 days ago, +/- 5 min)

« Statistically derived R

[300

equation with coefficients | i
and time relative averages Y

?’_

- Configurable in PI AF with . H |

backfill to assess \ ‘ » |

« Schedule in PI AF to M M A
provide forecast - PI future e
data

@6 6% days I
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Statistical Analytics - Predictive Modelling & Machine Learning

+ Complex systems where first
principles equations interact or
don’t exist

0 bl T b ..

Linear Regression

« Empirical or “fitted” models |
generated from time, event and Neural Network Regression
asset data in tabular context e

Boosted Decision Tree Regression

* Predicts outcome,

e.g. equipment failure,
unmeasured or forecasted Two-Class Decision Forest 4 S,SaS
guantities

Multiclass Decision Jungle MATLAB

* Model continuously improves or
“learns” with additional data
Microsoft Azure

@OSIsoft, REGIONAL SEMINAR © Copyright 2016 osisoft Lic 19



Microsoft Azure ML Studio

Advanced Energy Prediction Model
« Self-service data
science

« Experimentation to o I R
find “beSt fit” ;Em z;:::f.-.:.::.j:-";’:"EEC;_C for o
prediction models

 Publish finalized v
models as accessible \
web service

]
] L
1] ]
= ® -
= — ]
=1

m

« Pay as you go
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Predictive Modelling Process

DayOfWeek | ~ | Hour | Avg Building Power |~ | Awg MAC Address Count | * | Avg Outdoor Temperature |~

Cloud

0 1131.59375 897 76.699997
. Thursday 1 1131.59375 897 76.695997

S ervices Thursday 2 1131.59375 897 76.699957
Thursday 3 1131.59575 897 76.699997

Thursday 4 1131.59575 297 76.699997

=% Azure SQL
Database

&

e.}l Azure ML
Studio

[ HE Ty B

On Premise =
Applications

Power Bl Designer Pl Integrator for BA
\ (internal Alpha)

AN

Weather

Facilities | Station

© Copyright 2016 OSlsoft, LLC
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“Basic” Energy Prediction Model Experiment

Basic Energy Prediction Model
* Read data from (G e )
Azure SQL table

« Select model input !
variables e

« Split data for
tralnlng and teStlng [&] Lir=ar Regresson W B oo o

 Train model using a \ /I \

selected algorithm B0 in i v

« Score (Test) model @ swerecs v

« Evaluate model : I

Q) osisoit. REGIONAL SEMINAR © Copyight 2016 OSlson, LLC 22



“Basic” Energy Prediction Model Evaluation Results

Energy Prediction Model » Score Model » Scored dataset

« Visual and Statistical
Anal.ySIS Of MOdeI Hour WeakDay Outdoor Building ‘ 4 Visualizations
S CO rl n g Temperature  Energy Labels

Scored Labels

s columns

[ 5

vas

# Gbl MM b b |
+ “Coefficient of A compae o g 7

il Tuesday 71235245 159017334

Determination” a.k.a. 2 o
R-Squared = 0.63

53440937 854272034 | 814.864(

592356

12 Tuesday 1301658 &

@

1 Monday &

2

23 Tuesday 1011763 35

; 3

Mean Relative Relative . 23 Sunday 50.802834  723.807644 | 7289291 -

Absolute Root Mean Absolute Squared Coefficient of )
Squarad Error a Determination 15 Friday 63235847 131651306 | 1178.826
Error Error Error I B o
l Monday 5487787 1139.48718 991.628:
4 Sunday 45216392 693.1708 &11.3661
| . _— . — I P PP P P PP P P P
Tuesday 50879795 870470337 | 927847 Scored Labels

0.610971
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“Advanced” Energy Prediction Model Experiment

« Copy “Basic” Model

 Add “Boosted
Decision Tree
Regression” algorithm

« Train both algorithms
with Training Dataset

« Score both models
with Scoring Dataset

« Evaluate algorithms

@ osisoit. REGIONAL SEMINAR

Advanced Energy Prediction Model

{ N\
E_) eader oA
L J
r D
o va
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“Advanced” Energy Prediction Model Evaluation Results

“Linear Regression” “Boosted Decision Tree
R-Squared = 0.63 Regression”
R-Squared = 0.83

Energy Prediction Model » Score Model » Scored dataset -ed Energy Prediction Model » Score Model » Scored dataset

s columns columns
! 5 .
Outdoor Building Scored [ 4 Visualizations Outdoor Buildin -
) . . .
Hour WeekDay Temperature  Energy Hour WeekDay Temperature  Energy SESESISEEE 4 Visualizations
Scored Labels
< Scat ot as Scored Labels
¢ bl W0k bk " I R A W
compare to| Building Energy |
a Saturday 53.440937 854 272034 | 814.864( g Saturday 854272034 | 8392426941
1 Tuesday 71235245 152017334 1 Tuesday 1489173706
. . .

2 Sunday 238416 . * 2 Sunday 828 458069 .

E Saturday 6500361 71377 1600 . 13 Saturday N3N | 976998108 1700

2 Saturday 47993443 8708272 1500 2 Saturday 8708272 | 766676392 100 .

: 1500

12 Tuesday 67.22258 1315.90967 § 1400 12 Tuesday 1315.90967 1472534424 2 1400

1 Monday 72.0597 1488.18787 5 1222 il Manday 1488 18767 | 1513.940063 £ 0

23 Tuesday 55014748 927.2902 é o 23 Tuesday 927.2902 859 444641 g w.zuo

23 Sunday 50802834 722897644 SR 23 Sunday 723897644 | 304616323 3 1;22

15 Friclay 63235847 131651306 o 15 Friday 131651306 | 1249.344116 o

i Monday 54.87787 113948718 g0 il Monday 1139.48718 | 1084.102173 200

4 Sunday 45216392 6931708 0%es " . 4 Sunday 6931708 | 694927612 700

: P P P P P PP PP PP P P
a Friday 443891 916.7905 5 &P P 5® PP PP P g Friday 443891 916.7905 869.079431 AP P P P P PP P P
4 Tuesday 50870795 870470337 Scored Labels 4 Tuesday 50879795 870470337 | 834319092 Scored Labels
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“Best” Energy Prediction Model

Best Energy Prediction Model in dra
« Consider Seasonal
Effect on Building
Energy Demand

* Added feature! “Week R eeem R - 4 Visualizations
Number” of the Year -~

compare to | Building Energy M

* Insert “R” Script to
“Week of Year” v ] (B ol (@

com o Y=
« R-Squared 0.96 /, / @I . ﬁ
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Energy Predictions in Pl System 2015

Basic Prediction vs. Actual
1500 #BUILDING ENERGY Average
1200f 74 [ ] H:!l Al . A 673.641

- AT A L N A N

L Y _|J |. ) iH,, |J LI'| "-Il-frr "|_ | L \\F"J l?"‘&,f‘r'r L T < Basic Predicted Energy

o — o R P e | o == - T | 782 71
400 Tt kiWh
1/23/2014 12:00:00 AM & 8 11.00 days<|[> & 2/3/2014 12:00:00 AM
Advanced Prediction vs. Actual
1500 #BUILDING ENERGY Average
1a00fl Uq-'-n - ﬁ Fﬂ:\ﬁ‘ A A 673.641

L "ﬂj -ILI.I - ij ] 'J Jr tt"“ "rr qﬂ" o Advanced Predicted Energy

R VO P N G A S O Y 71363
= oS Y S PSP B N5 Rt S0 B i G N v AL s
[ 1/23/2014 12:00:00 AM &8 11.00 days<|[> & 2/3/2014 12:00:00 AM
Best Prediction vs. Actual
1500 © BUILDING ENERGY Average
Wr‘A‘HEI M }"i ) fb[t 1 o73 641

r'{'p - I'f J[thh rrr qt‘ © Best Predicted Energy
f il i N e

L L I | L kWh
00 w L hh.—wﬁw—-l nF !_JJ Tl ! ﬂ ﬁJ L - 1
1/23/2014 12:00:00 AM & 8 11.00 days<|[> & 2/3/2014 12:00:00 AM
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R Squared
0.63

R Squared
0.83

R Squared
0.96
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Enabling Analytics for Operational Intelligence

Real-Time Decision Analysis Retrospective & Predictive Analysis
PI Integrator for |
Business Analytics

Time and Event BEr
Trending & Awareness [ g e Multidimensional

Business Intelligence

Specialized Models & Dashboards

Simulation & Optimization - ' - —
APpp + kh e i———— AN AR
Q= I o I PO OO A
Te 3 = s SR [
141_2”30{3?1 Tw 4 + S} T|me1 Event TabU|ar 112372074 12.00.00 AN Ta s
Descriptive and Asset Context Predictive =
P Context Statistical Modelling '
Performance

& Condition & Machine Learning
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Ad Hoc Multidimensional Analysis

Headquarters Power Use_ 2013 - Excel ?T H - O %
HOME | INSERT | PAGE LAYO | FORMULAS DATA | REVIEW | VIEW | ADD-INS POWERVIE | PI DATALIM | PIAF Build | POWERPIY | Curt Hertler - .

Total Power

2200

Power Use at
OSlsoft
Headquarters

6/24/2013 6:41:08.897 AM ¥ %, 3200 days A O 712672013 6:41:08.897 AM

200

11,4
Jan Feb Mar Apr May Jun Jul Awg Sep Oct

Off-Peak Bl Part-Peak IlPeak Weekday —Weekend

Building Energy Summary Power View Summary

B M o-——+ 100%
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B v Headquarters Power Use

3 - Demo - Excel
FILE HOME INSERT PAGE LAYOUT FORMULAS DATA REVIEW VIEW ADD-INS POWER VIEW TEXT PI DATALINK PI AF Builder POWERPIVOT
Font~ ™ =) = 7 -
. & =5 B E Y A oo |
AlText Size T g 2 S = -
Themes = Set ge Transpar Refresh Relationships | Fitto  Field Filters | Power Text Picture | Arrange
- QlBackground | [mage~ Pos % Window List Area View  Box 4
Clipboard Undo/Redo Themes Background Image Data View Insert Arrange

- =

OSlIsoft Headquarters Overview

Average Usage - Mon Average Usage - Weekday
200 e

150

100

50

Weekday: Tue

Average of Total Power: 202.9
Jan Feb Mar Apr May Jun Jul Aug Sep Oct

Monthly Cost by Rate Period Average Usage - 24 Hour Period

Jan Feb Mar Apr May Jun Jul Aug Sep Oct

300

Off-Peak I Part-Peak B Peak Weekday —Weekend

> | Building Energy Summary | Power View Summary | ScratchPad | Economics | (©) K]
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Multidimensional Analytics — Operational Intelligence

Actual Inlet Flow Rate, ft3/min

* Ad hoc, visual analysis of 1:3358% VeI I EREEEE 9":;

a table or related tables of 3 100 el

data = f

S 12000 Best Efficiency Point - 30368 9

« Columns aggregated for wo L L

selected rows, presenting A et Fow e, '

results in a Variety of ways Compressor Performance - Pressure vs. Flow
* Excellent tools for ™

personal analysis and

enterprise reporting and

dashboards
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Multidimensional Analytics — Time Contextualization

Flexible, repeatable access to high
fidelity operational data

Sampling Increment Comparison

Engine Speed, rpm

« Time relative aggregations and
statistics at any interval

» Juxtaposition of values -
published rows can contain
previous row’s value.

« Backfill First Principle facts as
best practice
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Driving Continuous Improvement
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Enterprise Performance Summary

Generation Substations Distribution
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Detailed Reporting and Analytics

Dashboard drilldown -~ 0= o b
to detailed reports .. - N
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Demographics e FIe
Feeder Loading
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Custom Visuals Gallery
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Summary and Wrap Up

« The Pl System enables all types of operational analytics by providing

time-related data supported by the essential foundation provided by Pl
Asset Framework.

* Look holistically when selecting an analytical method or methods. PI
Analytics is very capable of performing equation-base analytics for
performance and conditions assessment, as well as, certain types of
predictive analytics.

« The PI Integrator for BA establishes “Common Ground” between OT and
IT contextualization for enabling the Intelligence enterprise.
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Resources

* OSlsoft Learning Channel on YouTube - “Pl Integrator for Business Analytics”
* Pl Square Community — “Asset Based Pl Example Kit”
— https://pisquare.osisoft.com

* Azure Machine Learning
— https://studio.azureml.net

* Power Bl Desktop
— https://powerbi.microsoft.com/desktop

 Power Bl Desktop Visuals Gallery
— https://app.powerbi.com/visuals

e On-Line Courses
— https://www.edx.org
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Contact Information

Curt Hertler
curt@osisoft.com

Global Solutions Architect
OSlsoft, LLC
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Questions

Please wait for the
microphone before asking
your questions -

State your
name & company
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