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Introduction 
In this session we will use the latest features of PI ProcessBook and PI Coresight to show how impactful 

displays can be built in just minutes. Using the power of PI Asset Framework, displays can be built once 

and reused for similar assets. You can quickly compare current data with projections and view displays 

on the go from your mobile device. 

Objectives 
• Create and reuse symbols with AF Display Builder in PI ProcessBook 

• See how future data can be visualized in PI ProcessBook and PI Coresight 

• Publish and share PI ProcessBook displays through PI Coresight 

• Analyze data from ProcessBook displays in ad hoc PI Coresight displays 

• Reuse the same display for multiple assets by changing AF context 

• Organize displays within PI Coresight 

• View displays on the go from your mobile device (optional) 

• Visualize and compare event frames (optional) 

 

Setup 

• PI Data Archive 2015, PI Asset Framework Server 2015 , PI Coresight 2015 (PISRV1) 

• PI ProcessBook 2015 (PICLIENT#) 

 

Approach 

You have been hired as a consultant by TechCon Labs, LLC to help them take advantage of the new 

features of PI ProcessBook and PI Coresight. 

On your first day, you’re provided with weather data from weather stations in the following airports, all 

in the beautiful state of California:  

• Meadows Field Airport (BFL)  

• Los Angeles International Airport (LAX)  

• Oakland International Airport (OAK) 

• Palo Alto Airport (PAO)  

• Porterville Municipal Airport (PTV)  

• San Francisco International Airport (SFO)  

• San Jose International Airport (SJC) 
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Challenge 1: Build an ad hoc display in PI ProcessBook 
 

Your first task for TechCon Labs, LLC is to demonstrate how to quickly create displays in PI ProcessBook 

using the new AF Display Builder add-in.  

Open PI ProcessBook 2015 and go to File > Open and browse to C:\TechCon Displays. From this folder, 

open Airport Weather.pdi. 

With the display open, from the Tools menu, select Build to switch the display to build mode so that you 

can make changes to the display. Go to Draw > Value and use your mouse to draw a value symbol on the 

display. Click the arrow next to Tag Search and select AF2: 

 

In the Select AF Attribute dialog, use the drop-down menu at the top to select the CaliforniaWeather_## 

database that corresponds to your student id. Then expand California and Bakersfield to select 

Bakersfield Meadows Field Airport. Use the Attribute drop-down to choose Airport Name and select OK: 
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Select OK again to add the value symbol to the display. Place the symbol where you would like it and use 

the Symbol Formatting Toolbar to change the font and style if you wish: 

 

What we have just done is added an AF attribute to a display without the AF Builder add-in that was first 

released with PI ProcessBook 2014. To more quickly and easily add AF attributes, from the View menu 

select AF Browser and AF Property to open the AF Builder docking windows. Expand California and 

Bakersfield to select Meadows Field Airport: 

 

The AF Property window should then populate with the attributes of that element: 
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Drag and drop the Pressure attribute onto the display. See how easy that is! If you’d like the attribute 

path, timestamp, or units to be included, just double-click the value symbol. Now each time you drag 

and drop an attribute it will be added with these settings. The attributes tab of Tools > Display Builder 

Preferences provides a way to automatically have a text symbol added with the value symbol that 

contains only the attribute name. If you’d like to see the AF path, just a shortened version of it, go to 

Tools > Data Sets and edit the AF2 dataset. Uncheck Full Name to get a shorter version of the AF path. 

You can also use the AF Property window to drag and drag attributes onto trend symbols. Add a trend 

symbol and give it a try! 
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Challenge 2: Save and reuse symbols using AF Builder 
 

Now that you have taken the time to create a visual representation of the current weather conditions at 

Bakersfield, wouldn’t it be great if you could reuse that work for the other airports? Well you can!  

From the Edit menu, choose Select All. Then from the Arrange menu, choose Group to group all of your 

symbols into a single composite symbol. Right-click your symbol and choose Assign Symbol to Template.  

If this option is grayed out, try clicking off of the symbol and then click it again to select it. From the 

resulting dialog, choose the Airport Weather Station template. The composite symbol you made is now 

associated with all elements based on the Airport Weather Station template.  

From the AF Browser window, choose another airport element, such as San Francisco International 

Airport and drop it onto the display. The same composite symbol should be created except it should 

now refer to the San Francisco Airport: 

 

This symbol has been stored in your PI Asset Framework database so it can now easily be shared and 

recreated in seconds. 
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Challenge 3: Use future data to see projections 
 

If you haven’t already, add a trend to your display. Notice that some of the attributes have 

accompanying forecast attributes. Drag one of these attributes, such as Wind Speed, onto the display 

along with its forecast attribute. Edit the trend so that the time range goes into the future. PI 

ProcessBook 2015 supports future data so you can now see projections alongside your real-time data. 
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Challenge 4: Publish PI ProcessBook displays to PI Coresight 
 

PI ProcessBook displays can easily be published so that they can be viewed from anywhere in a browser 

using PI Coresight.  

To publish your display, go to File > Save As in PI ProcessBook and Select This PC. Scroll down and you 

should see a network location for Published Displays. Save your display to this network location as 

Airport Weather_ID.svg with your ID number, and that’s it!  

Open a browser and navigate to http://PISRV1/Coresight if you aren’t there already. This is the PI 

Coresight homepage where you can see a list of all displays you’ve created as well as all public displays. 

Here you should see the display you’ve just published. If you don’t see it, try searching for it based on 

the name you gave it using the search bar in the upper left: 

 

You can also filter the list of displays to only show the displays from \\PISRV1\Published Displays by 

clicking the Published Displays link under Folder Home: 

 

Folder Home lists all imports folders that PI Coresight is monitoring. PI Coresight will monitor these 

folders and automatically import and update any PDI or SVG files contained in them. 

Once you locate and open your display, click a dynamic symbol to open an ad hoc trend of that data 

item. There’s also an Ad Hoc Display button in the upper right corner that will convert your display into 

an ad hoc display. All of the data items from the display will be in a single table from which you can 

quickly convert and analyze them. 
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Challenge 5: Link displays in PI Coresight 
 

Back in PI ProcessBook, let’s create a button to link to another display. An overview display of all 

California airports has already been created for you, so all that’s left is to create a link so that we have a 

way to quickly get the overview display.  

Go to Draw > Button to add a button to your display. Enter “Overview” as the Text and for action there 

are a few options. You can browse to another display and this will create a link that will open the display 

in either PI ProcessBook or PI Coresight, depending on which application you are using. This link will 

work in PI Coresight as long as both displays are imported to PI Coresight properly.  

Another option is to enter the URL to a display that has already been imported to PI Coresight. You can 

simply copy and paste the URL from your browser (http://PISRV1/Coresight/#/PBDisplays/2) or you can 

refer to the display by name, in case the display ID changes at any point in the future. To reference a 

display by name, start with the same URL, http://PISRV1/Coresight/#, except append PBDisplayName 

instead of PBDisplays and then the name of your display. For example, 

http://PISRV1/Coresight/#/PBDisplayName/California Airport Overview. Try using this URL to link your 

display to the overview display. 

Notice that as you save your display in PI ProcessBook, the display in PI Coresight is automatically 

updated. Use your new button to get to the overview display. This display shows an overview of the 

current weather conditions at the airports.  

Try clicking one of the airport codes. This will take you to the airport weather display for that particular 

airport. If you take a closer look at the URL, you can see how this works:  

http://PISRV1/Coresight/#/PBDisplayName/Airport 

Weather?CurrentElement=\\PISRV1\CaliforniaWeather\California\San Francisco\San Francisco 

International Airport.  

The airport code is just a button in PI ProcessBook that contains the URL to the airport weather display. 

We’ve appended this URL with a query string parameter that PI Coresight has implemented that allows 

setting the AF context. While this display may look similar to the one you have created, it is a different 

version of the display. This version is an element relative display (ERD). If you would like to take a closer 

look at this display it’s available in ‘C:\TechCon Displays’ as ‘Airport Weather ERD Example.PDI’. 
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Challenge 6: Create an ad hoc PI Coresight display 
 

If you don’t want to publish your display to PI Coresight, but you still want to view the data it contains in 

PI Coresight for quick analysis, all it takes is a single click. With your display open in PI ProcessBook, just 

click the Explore in PICoresight button  from within PI ProcessBook. This will take all data items in the 

display and add them to a trend in PI Coresight.  

Now that you have your data items in PI Coresight, you can modify the display any way you like. You can 

drag the symbols off of the trend and into separate symbols. You can convert the trend into a table of a 

series of other symbols. You can search for and add other data items to the display. Go ahead and give 

these a try. 

You might also notice that upon opening this display, the search pane in PI Coresight shows that it found 

related assets and events: 

 

These are discovered automatically by PI Coresight based on the items in the display. Click Related 

Assets/Events to see how you can use them in your display. The top pane will show all elements based 

on the same template as any of the data items on your display. Since we created this display using 

attributes from an airport, PI Coresight has automatically populated this pane with other airports. Click 

or drag the ‘Swap asset’ button  onto the display to change either the entire display or specific 

symbols to refer to a different asset. 

The bottom pane shows event frames. These events must meet two criteria to show up here. They must 

reference the data items contained on your display and occur close to the current time range. Using 

these related events, you can visualize and explore the event frames related to your display. You can 

also set the time range of a trend or the entire display to the time range of a given event frame  and 

compare event frames  (note this feature is still in pre-release). 

While you work with this display, keep in mind that this is an ad hoc display that will not be saved 

automatically. If you’d like to save the display, click the arrow next to AdHoc at the top of the display 

and choose Copy: 

 

Once you’ve made a few changes to the display, go ahead and make a copy and then give the display a 

name. Feel free to create new displays and try out this functionality. Any new display you create will 
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only be visible to you unless you wish to make it public to all other users. To make a display public, click 

the arrow next to the display name and then check Public: 
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Challenge 7: Organize displays in PI Coresight 
 

Now that you’ve seen how easy it is to create displays in PI Coresight, you may wonder how to keep 

track of a large number of displays. PI Coresight allows you to label displays so that they can be sorted 

organized into one or more groups.  

To label a display, go to the PI Coresight homepage and click the gear under a display . This will bring 

up the display settings dialog that you can use to manage displays you have created. This is where you 

can add labels help organize your displays. Simply type any text you like into the Label box. To add 

multiple labels, just use a semicolon to separate them.  Once you’ve added a few labels, click Filter by 

Labels on the homepage: 

 

This will bring up a tag cloud of the labels that have been created on this server: 

 

The cloud is weighted so that labels that appear in more displays will be larger. Clicking a label from 

within the cloud will filter the list of displays to only those which have the selected label. Another way to 

filter it is by clicking the ‘Related displays’ button . This will filter the list of displays shown down to 

all displays that contain any of the labels from that display.  

In addition to labels, you can also save displays as favorites by clicking the star under a display . 

Using the navigation pane you can then filter displays to see only Favorites, displays that were created 

by you, or displays that you recently viewed: 
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Challenge 8: View displays on the go from your mobile device 
 

Each of the displays you’ve worked with today can be viewed from anywhere using a mobile device. If 

you have a smart phone or tablet, you can connect to the server by browsing to the URL provided by 

your instructor.  

Depending on the size of your device, you may be directed to either the standard homepage or a mobile 

version. The mobile version shows a list of recently accessed items and provides a way to search for 

displays and data items: 
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PI ProcessBook displays will look just the same on your device as they did in your browser: 

 

Your ad hoc displays will look slightly different, they be shown in a mobile view: 

 

Each data item from your ad hoc display will be shown in a list with its value. Tap an item to add it to the 

trend and then turn your device to maximize the trend.  

OSIsoft Virtual Learning Environment 
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The OSIsoft Virtual Environment provides you with virtual machines where you can complete the 

exercises contained in this workbook. After you launch the Virtual Learning Environment, connect to 

PICLIENT1 with the credentials: pischool\student01, student. 

The environment contains the following machines: 

PICLIENT1: a client machine that contains the client tools for you to perform the exercises in this lab. 

The PI Server is the PISRV1 machine. 

PISRV1: a windows server that runs the PI System and that contains all the software and configuration 

necessary to perform the exercises on this workbook. This is the machine you need to connect to. This 

machine cannot be accessed from the outside except by rdp, however, from inside the machine, you can 

access Coresight and other applications with the url: http://pisrv1/, (i.e. http://pisrv1/coresight). 

PIDC: a domain controller that provides network and authentication functions. 

The system will create these machines for you upon request and this process may take between 5 to 10 

minutes. During that time you can start reading the workbook to understand what you will be doing in 

the machine. 

After you launch the virtual learning environment your session will run for up to 8 hours, after which 

your session will be deleted. You can save your work by using a cloud storage solution like onedrive or 

box. From the virtual learning environment you can access any of these cloud solutions and upload the 

files you are interested in saving. 

System requirements: the Virtual Learning Environment is composed of virtual machines hosted on 

Microsoft Azure that you can access remotely. In order to access these virtual machines you need a 

Remote Desktop Protocol (RDP) Client and you will also need to be able to access the domain 

cloudapp.net where the machines are hosted. A typical connection string has the form 

cloudservicename.cloudapp.net:xxxxx, where the cloud service name is specific to a group of virtual 

machines and xxxxx is a port in the range 41952-65535. Therefore users connecting to Azure virtual 

machines must be allowed to connect to the domain *.cloudapp.net throughout the port range 41952-

65535. If you cannot connect, check your company firewall policies and ensure that you can connect to 

this domain on the required ports. 

 

 

 


