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Seeking Value in a Sea of Buzz and Jargon

Process Efficiency
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The Importance of Data (and Sensor Data) is Increasing

Device Explosion Social Networks Cheap Storage

. 100 gets you 3million
>55 billion (70+% of >2 Billion Erptims_«?nncfr’:e ?toraéé in

global population) users 30 years)

Ubiquitous Connection Inexpensive
Computing

Web traffic
2010 130 Exabyte (10 E18) 1980 10 MIPS/$
2015 1.6 ZettaByte (10 E21) 2005 10M MIPS/$
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OSlsoft has Listened to Your Needs

SWHERG CUSIOMAY «| o to be able .
“We’re looking to code and to look at data Summary of Needs:

get the data into supporting it across similar and N
tools like INCIEHNILENASYUSTY ifforent assets at Familiar tools

Spotfire" not an option” the same time” Scalability without code

Flexibility and trust
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Pl Integrators

Pl Integrator for Business Analytics
 SQL Server

Hadoop (HIVE & HDFS)

Oracle RDBMS

File

ODBC client

Pl Integrator for
Business Analytics

ntegrator for SAP HANA
SAP HANA
Smart Data Integration (SDI)

Pl Syste

Time, Event Tabular
and Asset Context
Context

Pl Integrator for Microsoft Azure
* SQL Data Warehouse

* Azure SQL

 Azure Data Lake
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The Traditional Pl System

Interfaces Pl Data Archive  PI Clients

Il

50K+ events f sec
90K tags per interface

30->300 tags
every 30 seconds

billions of values per day

200,000 or more data streams
kept forever
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An Alternative Data Use Model

Interfaces Pl Data Archive Pl Integrator for
-

Business Analytics

|

|

S0K+ events / sec
50K tags per interface

billions of values per day 25K events f sec
200,000 or more data streams billions of values
kept forever
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Getting Value...

Solving complex Dashboarding — visual Integration to new I.T.

problems for a fleet reporting — real time & projects and databases
mobile

Multivariate, other Drill drown, rollup The right way to bring

statistics & machine Anywhere anytime operational data to I.T.’s

learning resources
One time answers or

Big Data party...

Ty }lln : L Microsoft /
il o @ P SGlsener (ilimlon

_ ¥,

= — 8 P
: w ; ﬁ ety i | (]| e ORACLE'
- . $72316 BUSINESS INTELLIGENCE
\: x 2 TIBCo d

+
+ .
i) PowerBl iy tableau

Running models -
L
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Why? ... complex problem solving

All PI Customers have a great deal

Statistical Analytics

of data.. Often too much for

effective analysis in a spreadsheet.

This data can be complex with

Multidimensional
many variables. Multivariable Business Intelligence
& Dashboards

Predictive
Statistical Modelling
& Machine Learning

« Identifying patterns and analysis and machine learning can
discovering ‘prf)blems provide interesting and invaluable il
through statistical methods L e il
that require large and answers to complex, big W Bl an L BLF -
diverse datasets . T R = T
questions... .

Pl data is very large and complex.

This is about finding the answer to large, complex questions.
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Complex Analyses Increase the Need for Deeper Integration

Complexity

Disparate assets
Interacting with assets on an individual basis

Process Optimization

Real-time & historical
Vviews across any
asset

Monitoring

Real-time visibility

* Pl ProcessBook
* Pl Coresight
* P| Datalink

* Traditional HMI
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[
Interacting with common assets as a fleet
System Optimization

Benchmarking .
Large scale multi-
Fleet-wide variate analysis
performance
comparisons

m
* Machine learning

* Bl app (e.g. Tableau, (Azure ML, R)
Spotfire, Lumira) * Pl Integrator for

* Pl Integrator for Business Analytics
Business Analytics * Pl Integrator for SAP

* Pl Integrator for SAP VANV
HANA

10
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Complexity

Applying Data to Maintenance...

Disparate assets
Interacting with assets on an individual basis

Data aware
Usaged based

Monitoring Using run times

and not clock
hours to
schedule

Wait for failure
faster break & fix

Preventive
Maintenance

and inspections
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Interacting with common assets as a fleet
Predictive

Performance
Based on the

Compare current history of like
performance equipment and
metrics, including § circumstances —
vibration, build a model
temperature, & that predicts
other KPlIs to failure and

expected values triages
maintenance
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Results and ROI: Data Integration can Address Key Questions

Oil & Gas Pharmaceuticals Transmission & Dist

* What material is being =« When did the « Was wind gusty or « What product is » How are renewables
hauled? geology change? steady? being made? impacting the
* When was it raining? . : . >
o A e hellas I e . Whlch wgll was « Was the « When is the equipment?
road? being drilled? maintenance equipment empty? * Was there a voltage
. i ) i i ?
What‘ls;the grade of What .angle was the planned? o M s T violation®
the hill? drill bit? . . * What are the
« When did breaks and | duct —— b How long does this instrument when | h . her?
downtime occur? s %r?” uctlg!w‘re a:;e issue usually take to took that CEITEES ) WS
* How do driving 0 il el oSt fix? measurement?

behaviors vary by
shift?
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Why? Dashboarding

#yumies Qil (BOD): Actual v, Budget

- . Mui’giple data source views

* Automated daily reports

- Jr’*ﬂ[n_r- - Management overviews

Visual Analytics

e KPIs and metrics

¥ ¥ YT YT T T T T LWL WL LWL W W0 W 0D

Actual, 3&15, Budget

Date
#umies Gas (MCFD): Actual v. Budget

* Future Data (forecast)

%T‘f,wrﬂff\‘m‘“ {)/VJN Budget

Scheduled and Ad-Hoc Reporting

Date

* Visualizing diverse sets of
data sources to gain insights,
create reports, and improve
operations

Actual, 3&15, Budget

Don’t wait for tomorrow to explore performance today
your operational data is a click or swipe away.

Even from your mobile devices
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Result: Improved, Detailed Reporting and Analytics

Dashboard drilldowns
to detailed reports

S —

Production Refinery Regional
Summaries KPI Scorecards ........|||||m||I|||||||l|II||||||I|I|||||||||||||||||||||||||||||||||||I||m||||m e Produc?t
Inventories

Drilling Activity Reports Asset Performance Displays
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Why? I.T. Integration projects

Information systems have projects that provide enormous value —

and those can benefit from the real-time process awareness of Pl

Data Warehousing

Data. But Pl Data hasn’t been easy to integrate — until now.

% i/
ot 4 i ‘
- : JECT MANAGEMENT PROGESS G
T

E ~+—
‘31
a/a é?j

* Centralizing data from
different business systems

* More effectively analyzing
and reporting on business
and building LOB
applications

mp) Power B

®

Structured PI data in a format readily consumable by the latest I.T. tools.
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New Technology is bringing the IT and OT Worlds Together

¥
i)

| want to build predictive X g (

M

models from historical data

| want to spend less n

time on operational
reports

% '
| want to compare n oOT
my equipment

against our other sites Engmeg; > &

%:.€0

COO

“Plant Manager Infrastructure

| want to minimize

risks through data
driven decisions
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Oil and Gas
Drilling and production comparisons
~ Information distribution

Mining

Route optimization
Energy reduction
Across 300 haul trucks

Life Sciences
' Reactor comparisons
| Process scale-ups

I (1L, 3L, 10L,1kL, 10kL)

h Wﬂ | e T IR

Renewables ‘ Pl Integrator for Business Analytics et Food and Beverage =

Energy production reports is in use today! —
Wind farm comparisops {
Outlier analysis <}—/'\ v IT/ OT integration

\}_ | v’ Business intelligence and reporting

v' Data warehouse integration

L v Supporting cross-platform projects
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(Big) Data Projects: Sound Attractive ... But There are Challenges

100

S0%

64% of large enterprises plan to ., Clean &Prep
implement a big data project. 70%
85% will be unsuccessful. 50%

50%

40%
Analysis

Data cleansing and preparation tasks can take
50-80% of the development time and funds.

0%

20%

Succeed
10%

0%

Source: https://hbr.org/2014/04/the-sexiest-job-of-the-21st-century-is-tedious-and-that-needs-to-change/
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(Big) Data Projects: Time Spent in the Wrong Areas

What data scientists spend the most time doing

® Building training sets: 3%

Cleaning and organizing data: 60%

Collecting data sets; 19%

Mining data for patterns: 9%

Refining algorithms: 4%

Other: 5%
What's the least enjoyable part of data science?

Building training sets: 10%

Cleaning and organizing data: 57%

Collecting data sets: 21%

Mining data for patterns: 3%

Refining algorithms: 4%

Other: 5%

Source: http://www.forbes.com/sites/gilpress/2016/03/23/data-preparation-most-time-consuming-least-enjoyable-data-science-task-survey-says/#5481f6 03775
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http://www.forbes.com/sites/gilpress/2016/03/23/data-preparation-most-time-consuming-least-enjoyable-data-science-task-survey-says/#5481f6037f75

Cleaning & Preparing Sensor Data: It's Challenging

. Comm Failure
Speed I |

1
1
| |
1 1
.' c:o.cioo . Ao 00 80 Differen
1 1 1
: :
1
|

‘“inon;n«

Spike /
Out of Range

: Additional
™~ Measure

1
03:40 | 03:50
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Pl Integrators Let You Clean and Prepare Pl System Data

for your business intelligence tools,
data warehouses, and

6"’* data lakes

TIBC® Spotfire
Cleanse
Data quality m Power BI
@ Augment COCAAee
. WU nD
Aggregation Analyze
i .
Assets Shape A rableay
Events Model Maosoit
oae K% SQL Server
Transmit ,
Normalization ‘@hadggp

Clean & Prepare
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Pl Integrator for Business Analytics - “Select Data”

* Intuitive way to

create tabular Select Data > Modify View > Publish Noxt
H ¢ ) Source Assets i Asset Shape Matches
content in “PI
’ Server CHERTLER64305 T, Shapes Found 29 Matches
VI eWws Database Compressors @ Compressor Vs @ Compressor-023
N @ Compressor-304

& Differential Pressure
@ Compressor-340

# Gas Flow e @ Compressor-356

o Req U i res AF 4 @ Gastran taaatet = @ Compressor-432

4 Edit Filters (@ Compressor-567

Hierarchy © unto

[} Asset Name @ unitol
€ Unitoz

e Select AF Elements | compressor2s Epe

@ Unito3
and Attributes hsset Template [Compressor v e

Unit04
(*) Add Filter © n?
@ unitos

e Scale up leveraging : @ unios

@ Unitos

name, hierarchy, or _ © untos

€ Unito7

category © unior

@ Unito7

@ osisoft. 2016 REGIONAL SEMINARS © Copyright 2016 OSIsoft, LLC 22



Pl Integrator for Business Analytics - “Modify View”

Compressor Analysis

® Column Details

* SeIeCt any tlme Select Data > Modify View > Publish Name

range and interval —— T E— startTime emm ]
6 Columns 0 Row Filters Rzﬁliiﬁ:‘:lues heset Name 1o Defau

Data Content @

Compressor | LocalTime Differential Pressure Gas Flow |
° Ad d coO I umns fO r Unito1 2011-10-01 00:00:00 93.3822 100.6735 Model A
. Unito1 2011-10-01 00:01:00 9336484 1006739 Model A
roper a g g reg atl n g Unito1 2011-10-01 00:02:00 9334747 100.6742 Model A
Pl Syste m d a‘ta unito1 2011-10-01 00:03:00 93.33011 100.6746 Model A
unito1 2011-10-01 00:04:00 9331274 100.675 Model A
Unito1 2011-10-01 00:05:00 9329539 100.6754 Model A
° A d d CcO I umns f or Unit01 2011-10-01 00:06:00 93.27802 100.6758 Model A e
. Unito1 2011-10-01 00:07:00 93 26066 100.6761 Model A e G B
common t| me an d Unito1 2011-10-01 00:08:00 9324329 1006765 Model A
d at e fu N Ct| ONs Unito1 2011-10-01 00:09:00 9322593 100.6769 Model A
unito1 2011-10-01 00:10:00 93.20856 100.6772 Model A
unito1 2011-10-01 00:11:00 93.1912 100.6776 Model A
Unito1 2011-10-01 00:12:00 93.17384 100.678 Model A
Unito1 2011-10-01 00:13:00 93.15647 100.6784 Model A
Unito1 2011-10-01 00:14:00 93.13911 100.6787 Model A
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Pl Integrator for Business Analytics - “Publish”

* Select targeted
endpoint “Pl View”,
MS SQL, text file, E—
more to come.... O Run Once | e

Timeframe and Interval

Select Data > Modify View > Publish

Target Configuration Summary

® Run on a Schedule
« Your Start Time is Saturday, October 1,

. First Run 201 12:00-:00 AM
e Publish once or on E 3 Yo T = T oember,

+ Your Time Interval gets an interpolated
a scheduled bases o | (EE=E essrament vey bt
S0 Mo Tu We Th Fr  Sa

25 26 27 28 29 30 H
a8 9 o 1 12 13 14
% 1B 17 1|8 19 20 21
22 23 24 25 26 27 28

23 30 1 2 3 4

Hour Minute Second

0o|v] 0o[v| 00)v|
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Deschutes Brewery

« Located in Bend, OR « 2 brewhouses

« Founded in 1988 « 50+ vessels

« Pub opened in Portland, OR ¢ Bottling and kegging
in 2007
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Production Challenges

Filing } Fermentation ’ Free Rise } ooe Options

* Invest $750k into inline density meters
* Manually predict transition in
Too late spreadsheets

Up to 72h lost \.
° Constraints

. « CAPEX not an option
* One manual density measurement per
Transition

vessel every 8-10h

: : * Transition occurs between manual
Can this be predicted? i
density measurements
AEry—— * Automate & operationalize predictions
s+ 02 303208690015607 » Continuously improve accuracy of

10 20 30 40 50 50 70 predictions
Time

= | TOO SO0ON =———)

Apparent Degree of Fermentation
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Predictive Analytics in a Spreadsheet

A
1R
2 Fvaz
3 Fvaa
Fv33
Fv33
FV46
Fva0
Fva0
Fvaz
Fya3
Fv3s
FVa6
Fva
Fva0
Fva0
Fv3s
Fv33
Fvaz

Bring

8
Brand

frash Squeezed
Fresh Squeezed
Fresh Squeezed
Fresh Squeezed
Fresh Squeezed
Fresh Squeezed
fresh Squeezed
Fresh squeezed
Fresh squeezed
Fresh squeezed
Fresh Squeezed
Fresh Squeezed
Fresh Squeezed
Fresh Squeezed
Fresh Squeezed
Fresh Squeezed
Fresh Squeezed

" rrach Squeezed

4

FV Full
10/20/15 7:48 PM
9/29/15 7:31 AM
8/13/154:16 AM
10/11/15 3:05 AM
7/10/15 3:44 AM
8/27/15 3:01AM
7/15/15 2:05 AM
8/31/15 2:53 PM
10/7/15 2:55 AM
10/1/151:38 AM
7/23/153:29 PM
12/3/151:46 AM
11/15/15 1:52 AM
7/3/15 1:33 AM
10/28/1511:49 PM
7/27/151:55 PM
7/31/15 11:01 PM

8/5/1510:30 P01 *

Raw

E

FV Full °P °P Timestamp

16.50142
16.50996

16,5039

16.5057
16.51289
16.49278
16.52212
16.50258
16.50425
16.45718
16.50286
16.50147
16.30823
16.51333
16.53811

16.4514
16.50569

10/20/15 9:31 PM
9/2/15 9:17 AM
8/13/15 7:52 AM.

10/11/15 7:43 AM
7/10/158:34 AM
8/27/15 8:11 AM
7/15/15 7:30 AM
8/31/15 8:20 M
10/7/15 8:28 AM
10/1/15 7:54 AM

7/23/15 10:06 PM
12/3/15 8:24 AM

11/15/15 8:31 AM

7/3/15 8244 AM

10429/ =

op

F

154

158
156
156
156
158

144
122
155
142

146

Data In

G

1.720277778
1767777778
3.595555556
4.632777778
4.834722222
5.175555555
5.411944444
5.466223289
5.494722222
6.263611111
6.626944444

6.6375
6.650833333
7.079722222

Hours since FV Full ADF

0.066747
0.030888
0.042767
0.054872
0.055284
0.054132
0.042706
0.030454
0.127498
0.139247
0.060769
0.139471
0.141538
0.115866
~ 501844

Clean it Up

-
b
o
m

o
&
-
-

0 100 150 200 250 300 350
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Apparent Degree of

New Challenges

Fermentation

How can the data preparation be
automated?

How can the predictions be
operationalized?

How can the predictions become
more accurate over time?

Fit to a Line
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Beer Brand Portfolio Complicates Predictability

Variety within Batches for a Brand

Diversity in Beer Brands

Apparent Degree of
Fermentation

Time (hours)

Apparent Degree of
Fermentation

Time (hours)
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How to Operationalize Predictions

DATA SOURCES PREPARE INGEST ANALYZE PUBLISH CONSUME

Pl System

|
|
Azure SQL 1 Machine Learning | Azure 5Q|-
|
|

|
[
|
: ||
I | Data Warehouse
; Data Warehouse I
L ______ e e e e Je L___ ) Power BI
[ 1 I
: Predictions as Future Data (to Pl 2015) 1
|
[
|
[
|
[
|
1

1

|

I | |

< Azure Data Factory (Orchestration) >: Web/LOB Dashboards

I I

1

1

1

On Premise
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i Import Data v

Machine Learning Model

CR' Execute R Script WA

Proposal 2nd Times, acking im
Early Density Readings » Transition Time L ¢
Hypothesis B Select Columns in Dataset v

Transition Time influenced by
* Brand of Beer
* Fermentation dynamics

st
(Temperatures, pressures,..)
* Vessel’'s dimensions & volume ==
n//’/
L ./
a : e
P /
/,a/ \/A
pd
T

Time in Phase
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Azure ML Predicts Accurate Transition Time

Benchmark: Measure Predict: use 2 early densities Refine: base predictions on
accuracy against a standard to estimate transition time brand for greater accuracy
(based on historical data)

Big Rig Big Rig FV01 Big Rig
e g ~
= S 3
s =7 » °7
== S 2
o ° 5 ] 5 ]
< < . << .|
o | o 7 =
z 34 =]
da = 0.237370955879939 preda = 0714595
o ~ E:dzzmgggmgﬁmsm o predb = 0.121760685307954
o | = predc = 27.2514360785009
predc = 12.3338190545238 e ancoahary iy
a=0746295430977136 3= 0745296480077130 b= 0.0036677391007295
- 0=0.0936677891007295 = b =0.0936677891007295 5 € =30.3205890015667
= ] o ©=230.3205890015667 o €= 30.3205890015667 . . . . . ; .
T T T T T T T T T T T T T T
10 20 a0 40 50 60 70 10 20 a0 40 50 50 70 10 20 0 40 50 60 70
Time in Phase Time in Phase Time in Phase
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Future Opportunities

Fermentation Diacetyl Rest Maturation

Filling Free Rise Cooling

Reardy to
Transfer

Emptying

Empty

Incorporate predictions into
beer making process

Roll out predictions for
more beer brands

Test if predictions can cue a
batch that is deviating

Apply similar predictive
methods to other transitions

© Copyright 2016 OSlsoft, LLC 32
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Leveraging the Pl System and Cortana
Intelligence to Increase Process Efficiency

COMPANY and GOAL

Deschutes Brewery is the 7th largest craft brewery in
US, and wanted to maximize production with its
existing infrastructure to fund construction of a 2nd
brewery in Roanoke, VA

v
CHALLENGE SOLUTION RESULTS ]
Batch’s phase transition Use data science to achieve Ability to eliminate
happens between manual accurate predictive analytics production time losses and
density measurements } for determining a batch’s } increase production
occurring every 8-10 hours density measurements capacity
¢ Impact: Losing up to 72 hours in * Pl System * Accurate predictions of when a
production time « Pl Integrator for Microsoft Azure batch’s phase transitions from
o EA[L [Eee WEr e fermentation to free rise

* Azure Machine Learning
* Azure Data Factory
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You can see Tim & Brian do this talk

Go to OSlsoft.com

Select Events / Past Events / Event Presentations

Select EMEA 2016 Berlin

Look for “Reducing Beer Production Time with Predictions”

Tim Alexander — Assistant Brewmaster — Data Wrangler
Brian Faivre - Brewmaster
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Operational Reporting & Analysis Architecture

‘Tableau Spotfire MSFTBI

Visualization & ‘ ... All Bl tools that ’
Analytics support ODBC

“l want to analyze
operations data
stored in the PI

System using
modern Bl tools!”

Data Preparation and
Integration Layer

System of Record
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Enterprise Data Warehouse Architecture

“I need to fit

Vlsxallzla:.lon & L Tableau } L Spotfire l SAS M MSIFT M A CT.Stcfcl.n } operational data
N, Ny o Do o o 2 JApplications into my existing
Enterprise Data company IT

Warehouse / Data Oracle DW, SQL Server, Teradata Hadoo%giD information
Mart / Data Lake

Pl Integrator
Data Preparation and for Bufiness Custom or 3" Party Data Management
Integration Layer and ETL

System of Record Pl Server

architecture!”

ERP HR
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Pl Integrator for SAP HANA Architecture

SAP HANA HANA Studio
HANA SDA % @ =

Linux ' SAP Lumira, VORA, S4, etc.

SAP DP Agent SAP HANA IoT Connector by DLr;iaﬁon
Option 1 Linux / Windows (Al Pl JDBC OSlsoft Doa A  Option2
Java) (via SDA) schema

Pl Integrator Framework
Windows Web Ul Shape Designer Security REST Layer

Pl Server
Pl View

DEE:] Framework (AF)

Archive ;
Windows Microsoft SQL Full platform coverage for all

data integration scenarios!

@ OSlsoft. 2016 REG'ONAL SEM | NARS © Copyright 2016 OSlsoft, LLC 37



Soon... Pl Integrator for Azure SQL Datawarehouse

DATA SOURCES PREPARE INGEST ANALYZE PUBLISH CONSUME

Pl System

|
|
Azure SQL 1 Machine Learning | Azure 5Q|-
|
|

|
[
|
: ||
I | Data Warehouse
; Data Warehouse I
L ______ e e e e Je L___ ) Power BI
[ 1 I
: Predictions as Future Data (to Pl 2015) 1
|
[
|
[
|
[
|
1

1

|

I | |

< Azure Data Factory (Orchestration) >: Web/LOB Dashboards

I I

1

1

1

On Premise
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Getting Value...

Solving complex Dashboarding — visual Integration to new I.T.

problems for a fleet reporting — real time & projects and databases
mobile

Multivariate, other Drill drown, rollup The right way to bring

statistics & machine Anywhere anytime operational data to I.T.’s

learning resources
One time answers or

Big Data party...

Ty }lln : L Microsoft /
il o @ P SGlsener (ilimlon

_ ¥,

= — 8 P
: w ; ﬁ ety i | (]| e ORACLE'
- . $72316 BUSINESS INTELLIGENCE
\: x 2 TIBCo d

+
+ .
i) PowerBl iy tableau

Running models -
L
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Move the Needle with Pl Integrators

e Start the conversation!
* Could a colleague make a better
decision with data you see daily?

* What business intelligence tools .

could you leverage further?

Pl Integrator for Business Analytics
Pl Integrator for SAP HANA

L ] Pl Integrator for Microsoft Azure
* Visit YouTube or osisoft.com to see

which Pl Integrator works for you
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Contact Information

Martin Bryant
MBryant@osisoft.com

Field Service Engineer
OSlsoft, LLC
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Questions

Please wait for the microphone
before asking your questions

State your
name & company

Q) ossot. 2016 REGIONAL SEMINARS

Please remember to...

Complete the Survey
for this session

REGIONAL SEMINAR

30Tt
Safeco Fi

osli

ield - Seattle, WA - Septemb

Digttal e
ne iew Vision, New Display Editor, New Look and Feel —
. Moni nd Performance of Grid-Scale Energy Storage
Sys Technologies
4. Using P1 Integrators to Improve the our P Data- OSisoft
Pl Asset Framework Ties Together Enterprise OEE for Clearwater Paper

s
Clearwater Paper
6. Solving Business Initiatives with the PI System - OSisoft
7. Pl Analytics and Coresight for Business Process Improvement — Avist
eeq helps customers get even more value from their OSisoft Pl System —

o o o
8. S
st o o o
9. What's Really Going on with your Beer's Fermentation? ~ Deschules
Brewery a o =] a
[Qualiyofseminar ]}
Poor Excellent  NIA
ts o a (=] a
o o o o
o a =] a

Presentation topics meeting your needs or interest

© Copyright 2016 OSlsoft, LLC

42




Thank You (

@ OSl:-o'.



