Big Data Analytics
with the Pl System

Presented by LP Page-Morin, Sr. Systems Engineer
Lpagemorin@osisoft.com
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" high volume, velocity, and/or variety
information assets that demand
cost-effective, innovative forms

of information processing that enable

insight, decision making, and process automation ™
---bartner
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The Benefits of Big Data

6% more profitable
83% Improved process cycle times
49% had payback in one year or less
54% report ROIs >100%
27% year-over-year increase in revenue

1 2 % less operating expense
Sources: Harvard Business Review, Forbes, IDB 5 O/O m O re p rOd u Ctlve
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The Big Data Landscape
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Big Data Analytics

. e Analytics is required
Big Data to transform

Analytics  ieiigence ™

 More than storage

i cuuStome hcgg ﬁg&%r"kr}mﬂ,edgomm% iy:;e:tga — Vlsual AnalytICS
privacy ,w abilities

ranainel OCALION [l es o iwemereal-timg. : :
;.sss,ac.:ba.gmwﬁeﬁ&"'ﬁ igData~ — Machine learning

amoun : olutio ||'|f0r call _ number _ conversation
kP d uct opportunit

o e Analytics’ — Complex event
processing

age
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Is production related to drilling conditions ?

. REGIONAL SEMINARS 2015

When did the
geology change?

How fast the well
was being drilled?

What angle was the
drill bit?

Sudden changes In
production?
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Big data analytics and the Pl System

Statistical Analytical Visual
Analytics Insight Y Analytics

Time Series Relational Unstructured

VA O
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Real-time time series data isn’t perfect

Naturally incomplete
» data delays

Doesn’t look like SQL
e Asset Context

Not evenly spaced
* time is framed by events

Subject to errors in measurement
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Data Alignment

Different Archive Time Comm Failure

Start Times

Speed © 0 0 0000e0009%,°
- lorque 0000000000000 000
c Bearing Temp 0000000090000 4-0
2 i 000
= Oil Temp 0000000000 0000040000 00000°00000
= Manufacthyer Vestas 0000

Last Servic June 20, 2013 Spike / Out of Range Uneven Spacing

_Sl_‘grzicé Additional Measure © © 0 © 07 000/ %000
(Q\|
Q Bearing Temp BadSen(ooooo 09 ¢ © 0 S0 00
2  Oil Temp 0 0000 0000 o @ oo
2 Ware Factor ® o 000 ¢ 04000009,

Manufacturer Siemens

Last Service Date February 5, 2015
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Data Wrangling

100%
ot Prep
80%
T0%
B0%
50%

40%

Analysis

Data cleansing and preparation tasks can take
50-80% of the development time and cost

30%

20%

10%

0%

https://hbr.org/2014/04/the-sexiest-job-of-the-21st-century-is-tedious-and-that-needs-to-change/
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Traditional Data Delivery

= BUSINESS TOOLS
: DataLink
S = PI OLEDB V€| Excel
Enterprise
NN TIBC®
x [ BE Excellent for “small” datasets =>>
- ~_
* Hours, days, 1-2 months m@
(@ osi-oi

Does not scale to “large” datasets
e 6 months, 3 yrs...
e “High Density” data - Drilling
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Pl Integrator for Business Analytics

data
aggregation

CLEANSE

AUGMENT

data
quality

SHAPE

TRANSMIT

data
compatibility

model
normalization

 pusH

Business
Intelligence &
Visual Analytics

Data
Warehouse

Big Data
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Pl Integrator for Business Analytics: Bl edition

e Create PI Views

e Access decision ready
data via ODBC

» Best solutions to provide access to analytics tools
* Tibco Spotfire, Tableau, Microsoft Power Bl
« SAS, Cognos, Oracle
 Most Dashboarding tools
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Business Intelligence & Visual Analytics

Visualization &
Analytics

Data Preparation
and Integration
Layer

System of Record
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@ Dl Integrator x W

€« C' | [1 localhost:7777/Designer

Apps @ pl Integrator @ pl Integrator Admin

lingRealTim

Select Data > Modify View > Publish

@ Source Assets %, Asset Shape + Matches
Server DFFIAR v TShapes Found 2 Matches
Database PetroLux v @ rig s x @ Driln
§ Assets & Bit Weight . @ Dril2
b © Al # Block Height l x
(3 e Key Performance Indicators # DirPress "‘ e
4 (@) PetroLux Corporation $ FEnmER "‘ X
» @ Downstream # Hole Depth ZaR
» § Midsiream 4 Hook Load P
» @ Petrochemicals # Mud Weight In s %
4 @ Upstream 4 Pump Pressure S
) Conventional Gas 4 ROP S x
4 [ Conventianal Oil & Top Drive RPM s n
» @ Athabasca Field 4 Top Drive Torque s
» [ Cold Lake Field & Wel D s %
4 @ Fort McMurray Field . %
» @ Maintenance Vehicles & Well Name State SR
g 2 WelFad oot & Bit Position .
» Well Pad 002 -
Attributes | x| 1T
O select All
[= Chemical Use
[=] Fuel Gas

Number of Tanks
Number of Wells

[=] Oil Forecast
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Select Data > Modify View » Publish

= Add Column Y Edit Row Filters SEIE I S
e ' - 3/27/2013, 12:00:00 AM ‘ | 77712014, 12:00:00 AM

Rig LocalTime Day Hour WeekDay Bit Weight Block Height Diff Press Flow In Rate Hole Depth  HookLoad Mud Weightin  Pump Pressure  ROP Top Drive RPM  Top Drive Torque WellID  Well Nam
NameTimeStamp Day Hour Dayofthe Value Value Value Value Value Value Value Value Value Value Value Value Value

Weak

= Drill
(o]}
Drilll 2013-03-27 03:19:00 27 3 Wednesday 0.00 7878 143 50.00 n4z 4830 1090 123.04 000 0.00 0.00 Well- Well Drilli
Drill 2013-03-27 03:20:00 27 <] Wednesday 0.00 78.85 .01 50.00 1.42 4830 10.90 122.63 0.00 0.00 0.00 \?qu?lfgﬁﬂ Well1 Drilli
Drill 2013-03-27 03:21:00 27 3 Wednesday 0.00 78.83 m 50.00 .42 4840 10.90 12271 0.00 0.00 0.00 ‘?V?:Ifﬂﬁﬂ Well1 Drilli
Drilll 2013-03-27 03:22:00 27 3 Wednesday 0.00 78.80 156 50.00 1.42 48.10 10.90 123.31 0.00 (0.00 0.00 \::\.'q(E?IERETI Well1 Drill
Drilll 2013-03-27 03:23:00 27 3 Wednesday 0.00 78.81 074 50.00 n4a2 48.10 10.90 1224 0.00 0.00 0.00 \?\.‘239571 Well Drilln
Drill 2013-03-27 03:24:00 27 3 Wednesday 0.00 78.81 123 50.00 142 4830 10.90 122 .63 0.00 0.00 0.00 \;:\.‘:(6'7”(—,8571 Well Drilli
Drill 2013-03-27 03:25:00 27 3 Wednesday 0.00 78.80 0.55 50.00 n4z 4850 1090 12214 000 0.00 0.00 \3\‘!2?8571 Well Drilli
Drilll 2013-03-27 03:26:00 27 <] Wednesday 0.00 78.83 158 50.00 1.42 4840 10.90 123.38 0.00 0.00 0.00 \?qu?lfgﬁﬂ Well1 Drilli
Drill 2013-03-27 03:27:00 27 3 Wednesday 0.00 7878 1.96 50.00 .42 4830 10.90 123.24 0.00 0.00 0.00 ‘?V?:Ifﬂﬁﬂ Well1 Drilli
Drilll 2013-03-27 03:28:00 27 3 Wednesday 0.00 78.81 .77 50.00 1.42 48.60 10.90 123.53 0.00 (0.00 0.00 \?\.'?JIERET‘I Well1 Drill
Drilll 2013-04-02 22:40:00 2 22 Tuesday m.60 3264 33.16 595.00 10025.69 23140 10.20 2744.59 0.00 0.00 1562.00 \?\.‘239571 Well Drilln
Drill 2013-04-02 22:41:00 2 22 Tuesday 10.40 3246 35.36 595.00 10025.69 23250 10.20 274170 0.00 0.00 1601.00 5\.[2?8671 Well Drilli
Drill 2013-04-02 22:42:00 2 22 Tuesday 10.60 3257 3228 595.00 10025.69 23260 1020 2742 31 000 0.00 1605.00 \3\‘!2?8571 Well Drilli
Drill 2013-04-02 22:47:00 2 22 Tuesday 14.90 32.25 6.53 596.00 10026.21 22830 10.20 272155 0.00 0.00 1543.00 \::\'qe'TI:?RETI Well1 Drilli
Drilll 2013-04-02 22:49:00 2 22 Tuesday 0.00 36.25 6.78 595.00 10026.21 23720 10.20 2713.55 0.00 0.00 1581.00 ‘?V?:Ifﬂﬁﬂ Well1 Drilli
Drilll 2013-04-02 22:50:00 2 22 Tuesday 0.00 35.08 46.28 596.00 10026.21 236.60 10.20 2703.22 0.00 (0.00 1593.00 \?\.':(E?II(-)RETI Well1 Drill
Drilll 2013-04-02 22:51:00 2 22 Tuesday 0.00 34.28 6894 596.00 10026.21 24260 10.20 2714.47 0.00 0.00 1574.00 \?\.‘239571 Well Drilln
Drill 2013-04-02 22:52:00 2 22 Tuesday 0.00 3382 83s 595.00 10026.21 23930 10.20 2656.50 0.00 0.00 1574.00 \‘i‘"“eﬁfﬂﬁ?lI Well Drilli
Drilll 2013-04-02 22:53:00 2 22 Tuesday 0.00 33.05 35.55 595.00 10026.21 23750 1020 268076 000 0.00 1582.00 \3\‘!2?8571 Well Drilli
Drilll 2013-04-02 22:54:00 2 22 Tuesday 0.00 3267 99.61 595.00 10026.21 23840 10.20 274977 0.00 0.00 1587.00 \::\'qe'TI:?RETI Well1 Drilli
Drill 2013-04-09 21:26:00 9 21 Tuesday 0.00 96.00 77.60 590.00 16964.25 267.30 10.80 3587.81 0.00 0.00 1530.00 ‘?V?:Ifﬂﬁﬂ Well Drilli
Drilll 2013-04-09 21:27:00 9 21 Tuesday 0.00 95.86 106.55 590.00 16964.25 266.10 10.80 3619.76 0.00 0.00 1519.00 \7";':((?7”(-)257‘I Well¥ B *
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Select Data » Modify View > Publish

Target Configuration DFSGL Summary

DFSGL ¥ Shape and Matches

| Frview

e

arget--—-

= There are 2 Matching Instances.

Timeframe and Interval
File
HDFS * Your Start Time is 3/27/2013, 12:00:00 AM

« Your End Time is 7/7/2014, 12:00:00 AM
= Your Time Interval gets an interpolated measurement
every im

Does everything look good?

Save and Close
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OGDrillingHeatMap ~ ~ & ~ T xp - TIBCO Spotfire

OEENMES
Page
Data ¥ X | 1ROP per Top Drive RPM and Hole Depth Fitters 9 F X
Top Drive RPM + = Data table: Q
rili -Gl v = OGDrilingReal... ~ Type o search filf
OGDrilingRealTime- — 004 011 D23 036 D54 081 132 3336 . 4B .49 51 .68 .50 .59  60_.68.. 71 __.73._ 89
Q Colors OGDrillingRealTime-Crew-Shift A
ER— $ Max Crew
» 125 NUMBERS ® Average a8
=i = 5 ) o]
e Min
Bit Posifion | (An 4 values
CREW A
Bit Weight CREWB
CREW C
Block Height
i CREW D
Day
Day2
Diff Press Ll :
¥ L# ]
Flow In Rate + | (A1) 2 values
Hole Depth » Day
= Hight
Hook Load B
a
Hour 4 :
- Al =
Month i
Wiud Weight In 12106.28 OGDrilingRealTime-Crew-Shif. .. A
12542.79
Pump Pressure
ROP k
Top Dimve RPM
145096.02
Top Drve Torque | 4885 53
WeekOfYear 2 ;z
= (1) TME 1585017
d 16206 97
LocalTime

* £ CATEGORIES AVG(ROP) = + = 19




Pl Integrator for Business Analytics:
Data Warehouse and Big Data Edition
« Data Warehouse Edition
— EXxport to SQL server
— Export to text file
— Other DB coming soon: Oracle, Teradata

e Big Data Edition
— Export to Hadoop (HDFS)
— Hortonworks, MapR, Cloudera and others
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Data Warehouse Architecture

Visualization & ; Custom
Analytics ESpotflre }E s J[ e J Applications

Enterprise Data
Warehouse / Data SQL Server, Teradata, Oracle Hadoop
Mart / Data Lake

Data Preparation and Pl Integrator for BA Custom or 37 Party Data
_ Data Warehouse
Integration Layer Edition Management and ETL
e e i i F .......... IR IICICIL e
CRM Sales EAM
System of Record Pl Server
ERP HR
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Pl Integrator for SAP HANA

e Native Integration with HANA Smart
Data Access (SDA)

e Data is brought into memory on demand

* Focus on Bl, Reporting, and Predictive Analytics
BUSINESS PROCESSES INDUSTRIAL PROCESSES

EEY @@ osi-.
2]
Real-time Business Real-time Operational
Decision Support Decision Support
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Conclusion
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Pl Complements Big Data Solutions

Problem Big |Why?
System Data

Collect and store data from a The Pl System contextualizes your data, collects natively from a variety of

variety of real-time and sources and efficiently stores data at less that 10% of the size of big data

operational sources

Ask questions about a few to The Pl System is highly tuned for instantaneous answers about your data

hundreds of data points vs. waiting for minutes or hours for your answer to come from a big cluster

Ask questions about the entire Big data is excellent for asking questions about large data sets and finding

Pl archive / hidden patterns. Requires writing code and doing analysis in batches vs
real-time

Operationalizing and capturing The Pl System is the best place to capture knowledge from big data and

knowledge from analyses visual analytics and apply it in real time across all your assets and
operations

Deriving correlations and Big data is essential for large inspection queries that require complex
insights from the entire PI / descriptive analytics, pattern searching, and joining non-PI data
archive and external data
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Before you get started

- Ask internally, at your company, if there is a Big Data
Initiatives and which tools are already in used

- Leverage existing infrastructure

- Organizing the data is key:
- Proper AF structure required
- Link to Metadata (ID)
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What Systems Are Supported?

Advance d Visualization Big Data*

WAWAW “'"“

Apache Cloudera*
Tibco Microsoft ..and Many Hadoop*
Spotfire =]] More SAP HANA
Tableauy Data Warehouse
*Coming Soon, Stay Tuned!

w Teradata*
Microsoft
SQL
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Proven technology - Early Adopter Program

a Merck Devon Energy
vl Regeneron - Noble Energy

T NOV
"F EDE-RE
1 BASF

kg Cemex
XD Alcoa GRP 'z' China Southern Grid

SDG&E

[ol,oi Freeport McMoRan
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Bl Edition | Data Warehouse | Big Data SAP Hana

(Q4-2015) Edition Edition Edition
(Q4-2015) (2016) (Q4-2015)
Pl Views
- Client side X X X
ODBC
Native
Connections
- SQL Server X X
- Flat File X X
- SAP Hana X
- Oracle (2016) X
- Hadoop X

@ osisot. REGIONAL SEMINARS 2015 o Conpgnt2015 080t 1C 31



Contact Information

LP Page-Morin
|pagemorin@osisoft.com
Sr. Systems Engineer
OSlsoft
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Questions Please remember to...

Complete the Survey

Please wait for the . .
for this session

microphone before asking
your questions

Evaluation Form (Seminar Location - Date)

Name: Company:

Email:,

Quality and content of the presentations

{
o
14

O00O Q000
OO0 O 0000 §

Welcome

The Journey To Real-Time Operational Intelligence
The Pouser of Connection

Tank Level Management System

Using the Pl System to Aid in Troubleshooting Operational Aspects of Oil
and Gas Well Drilling and Complefion

Unleash your Infrastructure

State your
name & company

Information on the Spot

000 00000 |
000 00000 £

Wrap-up/Seminar Conclusion

Quality and organization of the seminar

Choice of date O @] o O
Time allowed for lunch/breaks O O O O
Choice of presentations @] O O O

matinR Sn $n AR —~ —~ — —~
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2ARLICH ENREN
Danke

Merci Gracias
Thank You
HDHhES

Cnacn6o Obrigado
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