Big Data Analytics with the
Pl System
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srioux@osisoft.com

@ OSlsoft. REGIONAL SEMINARS 2015 © Copyright 2015 OSlsoft, LLC


mailto:bmcmorrow@osisoft.com

" high volume, velocity, and/or variety
information assets that demand
cost-effective, innovative forms

of information processing that enable

insight, decision making, and process automation ™
---bartner
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The Benefits of Big Data

6% more profitable
83% improved process cycle times

49% had payback in one year or less

54% report ROIs >100%
27% year-over-year increase in revenue

o) .
12 /o less operating expense
o) .
Sources: Harvard Business Review, Forbes, IDB 5 /o mOre prOdUCtlve
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The Big Data Landscape
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Big Data Analytics

, * Analytics is required
Big Data to transform

A ‘ J[' information into
nay |CS intelligence

* More than storage

: cus}g(r:r;%rg;ggm',;k‘n.,f,:tdgm realtlme — Visual Analytics
one englne ||ke ® help e ]- » _ . .
e nB gData® Machine learning

‘%’rswéo glf: "mzjiud "Pp tt th acr[!‘slpa'dlytlcs - Com plex event
processing
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Is production related to drilling conditions ?

'!‘ ~ When did the

geology change?

AR

How fast the well
was being drilled?

What angle was the
drill bit?

Sudden changes in
production?
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Big data analytics and the Pl System

Statistical Analytical Visual
Analytics Insight 7 Analytics

Time Series Relational Unstructured

~
v {
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Real-time time series data isn’t perfect

* Naturally incomplete
* data delays

e Doesn’t look like SQL
 Asset Context

* Not evenly spaced
e time is framed by events

e Subject to errors in measurement
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Data Alignment

Turbine 1

Turbine 2

Different Archive Time Comm Failure

Start Times /
Speed 00\¢ © © 0 0 0000ge0009%, 0
Torque 000000\ 0 0000000000000 000
BearingTemp 0 ©0g© @0 o 0000000000000 4-0
' 000
Oil Temp 0000000000 QQOQ‘””‘”“‘ 000000000

Manufaci\Ner Vestas

Last Service\_ June 20,2013 Spike / Out of Range Uneven Spacing

Speed A yditional Measure © © 0 © 070 0 %90/ %00
Torque
Bearing Tem 0] 0]

. 9 y Bad Sensor ©00%90 0020 0 o 0060
Oil Temp 0 9000 0000 o © oo
Ware Factor ®© o © 90 ¢ 0 43000009,
Manufacturer Siemens
Last Service Date February 5, 2015
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Data Wrangling

100%
50% Prep
B0%
T0%
B0%
50%

40%
Analysis

Data cleansing and preparation tasks can take
50-80% of the development time and cost

30%

20%

10%

0%

https.//hbr.org/2014/04/the-sexiest-job-of-the-21st-century-is-tedjous-and-that-needs-to-change/
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Traditional Data Delivery

BUSINESS TOOLS

% PI DataLink
;>/\>A PI OLEDB €S Excel
Enterprise
SRS TIBC2
0 |
X X ﬂ"j Excellent for “small” datasets m

(‘ " * Hours, days, 1-2 months
(¢ OSl:oft.

Does not scale to “large” datasets
* 6 months, 3 yrs...
 “High Density” data - Drilling
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Pl Integrator for Business Analytics

data
aggregation

CLEANSE

AUGMENT

data
quality

SHAPE

TRANSMIT

data
compatibility

model
normalization

pusi

Business
Intelligence &
Visual Analytics

Data
Warehouse

Big Data
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Video placeholder (see video replay).
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Pl Integrator for Business Analytics: Bl edition

e Create Pl Views

* Access decision ready
data via ODBC

* Best solutions to provide access to analytics tools
* Tibco Spotfire, Tableau, Microsoft Power Bl
« SAS, Cognos, Oracle
* Most Dashboarding tools
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Business Intelligence & Visual Analytics

Visualization &
Analytics

Data Preparation
and Integration
Layer

System of Record
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@ Dl Integrator x W

€« C' | [1 localhost:7777/Designer

Apps @ pl Integrator @ pl Integrator Admin

lingRealTim

Select Data > Modify View > Publish

@ Source Assets %, Asset Shape + Matches
Server DFFIAR v TShapes Found 2 Matches
Database PatroLux v @ Rig 7L @ Diili
Bit Weight KR Drili2
[ Assets € : @
4 Block Height R
» (@ Assetlists N
4 Diff Press s R
(3 e Key Performance Indicators N
) & FlowInRate a1
4 (@) PetroLux Corporation
EaR
» @ Downstream &
s
» ) Midstrzam O ¥ewi o
» @ Petrochemicals 4 Mud Weight In s x
4 @ Upstream 4 Pump Pressure S
) Conventional Gas & ROP S x
4 8 Conventional Oil & Top Drive RPM S
» [ Atnabasca Field & Top Drive Torque ra
» (D Cold Lake Field & wel D P
4 @ Fort McMurray Field Well Name P
» (@ Maintenance Vehicles & Well Name State S
» Well Pad 001 .
@ 4 Bit Position a1
» (7 wel Pad 002 -
Attributes | x| |F
O select All
[= Chemical Use
[= Fuel Gas

Number of Tanks
Number of Wells

[=] Oil Forecast

@ OSlsoft. REGIONAL SEMINARS 2015 © Copyright 2015 OSlsoft, LLC



Select Data > Modify View » Publish

= Add Column Y Edit Row Filters SEIE I S
e ' - 3/27/2013, 12:00:00 AM ‘ | 77712014, 12:00:00 AM

Rig LocalTime Day Hour WeekDay Bit Weight Block Height Diff Press Flow In Rate Hole Depth  HookLoad Mud Weightin  Pump Pressure  ROP Top Drive RPM  Top Drive Torque WellID  Well Nam
NameTimeStamp Day Hour Dayofthe Value Value Value Value Value Value Value Value Value Value Value Value Value

Weak

= Drill
(o]}
Drilll 2013-03-27 03:19:00 27 3 Wednesday 0.00 7878 143 50.00 n4z2 4830 1090 123.04 000 0.00 0.00 Well- Well Drilli
Drill 2013-03-27 03:20:00 27 <] Wednesday 0.00 78.85 .01 50.00 1.42 4830 10.90 122.63 0.00 0.00 0.00 \?qu?lfgﬁﬂ Well1 Drilli
Drill 2013-03-27 03:21:00 27 3 Wednesday 0.00 78.83 m 50.00 .42 4840 10.90 12271 0.00 0.00 0.00 ‘?V?:Ifﬂﬁﬂ Well1 Drilli
Drilll 2013-03-27 03:22:00 27 3 Wednesday 0.00 78.80 156 50.00 1.42 48.10 10.90 123.31 0.00 (0.00 0.00 \::\.'q(E?IERETI Well1 Drill
Drilll 2013-03-27 03:23:00 27 3 Wednesday 0.00 78.81 074 50.00 naz 48.10 10.90 1224 0.00 0.00 0.00 \?\.‘239571 Well Drilln
Drill 2013-03-27 03:24:00 27 3 Wednesday 0.00 78.81 123 50.00 142 4830 10.90 122 .63 0.00 0.00 0.00 \;:\.‘:(6'7”(—,8571 Well Drilli
Drill 2013-03-27 03:25:00 27 3 Wednesday 0.00 78.80 0.55 50.00 n4z2 4850 1090 12214 000 0.00 0.00 \3\‘!2?8571 Well Drilli
Drilll 2013-03-27 03:26:00 27 <] Wednesday 0.00 78.83 158 50.00 1.42 4840 10.90 123.38 0.00 0.00 0.00 \?qu?lfgﬁﬂ Well1 Drilli
Drill 2013-03-27 03:27:00 27 3 Wednesday 0.00 7878 1.96 50.00 .42 4830 10.90 123.24 0.00 0.00 0.00 ‘?V?:Ifﬂﬁﬂ Well1 Drilli
Drilll 2013-03-27 03:28:00 27 3 Wednesday 0.00 78.81 .77 50.00 1.42 48.60 10.90 123.53 0.00 (0.00 0.00 \?\.'?JIERET‘I Well1 Drill
Drilll 2013-04-02 22:40:00 2 22 Tuesday m.60 3264 33.16 595.00 10025.69 23140 10.20 2744.59 0.00 0.00 1562.00 \?\.‘239571 Well Drilln
Drill 2013-04-02 22:41:00 2 22 Tuesday 10.40 3246 35.36 595.00 10025.69 23250 10.20 274170 0.00 0.00 1601.00 5\.[2?8671 Well Drilli
Drill 2013-04-02 22:42:00 2 22 Tuesday 10.60 3257 3228 595.00 10025.69 23260 1020 2742 31 000 0.00 1605.00 \3\‘!2?8571 Well Drilli
Drill 2013-04-02 22:47:00 2 22 Tuesday 14.90 32.25 6.53 596.00 10026.21 22830 10.20 272155 0.00 0.00 1543.00 \::\'qe'TI:?RETI Well1 Drilli
Drilll 2013-04-02 22:49:00 2 22 Tuesday 0.00 36.25 6.78 595.00 10026.21 23720 10.20 2713.55 0.00 0.00 1581.00 ‘?V?:Ifﬂﬁﬂ Well1 Drilli
Drilll 2013-04-02 22:50:00 2 22 Tuesday 0.00 35.08 46.28 596.00 10026.21 236.60 10.20 2703.22 0.00 (0.00 1593.00 \?\.':(E?II(-)RETI Well1 Drill
Drilll 2013-04-02 22:51:00 2 22 Tuesday 0.00 34.28 6894 596.00 10026.21 24260 10.20 2714.47 0.00 0.00 1574.00 \?\.‘239571 Well Drilln
Drill 2013-04-02 22:52:00 2 22 Tuesday 0.00 3382 83s 595.00 10026.21 23930 10.20 2656.50 0.00 0.00 1574.00 \‘i‘"“eﬁfﬂﬁ?lI Well Drilli
Drilll 2013-04-02 22:53:00 2 22 Tuesday 0.00 33.05 35.55 595.00 10026.21 23750 1020 268076 000 0.00 1582.00 \3\‘!2?8571 Well Drilli
Drilll 2013-04-02 22:54:00 2 22 Tuesday 0.00 3267 99.61 595.00 10026.21 23840 10.20 274977 0.00 0.00 1587.00 \::\'qe'TI:?RETI Well1 Drilli
Drill 2013-04-09 21:26:00 9 21 Tuesday 0.00 96.00 77.60 590.00 16964.25 267.30 10.80 3587.81 0.00 0.00 1530.00 ‘?V?:Ifﬂﬁﬂ Well Drilli
Drilll 2013-04-09 21:27:00 9 21 Tuesday 0.00 95.86 106.55 590.00 16964.25 266.10 10.80 3619.76 0.00 0.00 1519.00 \7";':((?7”(-)257‘I Well¥ B *
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Select Data » Modify View > Publish

Target Configuration DFSGL Summary

DFSGL ¥ Shape and Matches

arget--—-

= There are 2 Matching Instances.
Timeframe and Interval

* Your Start Time is 3/27/2013, 12:00:00 AM

« Your End Time is 7/7/2014, 12:00:00 AM

« Your Time Interval gets an interpolated measurement
every im

Does everything look good?

Save and Close
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OGPDrillingHeatMap ~

File Edit View | Tools Help
v i (% i4 -
Page
Data ¥ X | 1ROP per Top Drive RPM and Hole Depth Filters O
TopDrive RPM + 4 ~ Data table
OGDrilingReallime-C.. ~ = R : - o ey =~ = OGDrilingReal... ~ =2 Q
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N - s Crew
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S AT T SN TR 5 e Min
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CREWA
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Day
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Diff Press Shift
’ Q
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Hole Depth ’ 1 Day
£ 9 Night
Hook Load 8 7
3 5
Hour B 43
- - =
Month 16 i
Mud Weight In 12106.29 OGDrilingRealTime-Crew-Shif... A
12542.79
Pump Pressure 12890 .81
1322777
ROP 13534.14 k
13951.88
Top Drive RPM 429567
14596 02
Top Drive Torque 1488552
16224 27
WeekOfYear
» () TME
LocalTime
v =2 CATEGORIES Avg(ROP) v + ~ 19

External data | OGDrillingRealTim



Pl Integrator for Business Analytics:
Data Warehouse and Big Data Edition
 Data Warehouse Edition
— Export to SQL server
— Export to text file
— Other DB coming soon: Oracle, Teradata

* Big Data Edition
— Export to Hadoop (HDFS)
— Hortonworks, MapR, Cloudera and others
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Data Warehouse Architecture

Visualization &
Analytics

Enterprise Data
Warehouse / Data SQL Server, Teradata, Oracle Hadoo
Mart / Data Lake

Data Preparation and Pl Integrator for BA Custom or 3 Party Data
. Data Warehouse
Integration Layer Edition Management and ETL
e i i ; .......... IR IEICICIL
CRM Sales EAM
System of Record Pl Server
ERP HR
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Pl Integrator for SAP Hana

* Native Integration with HANA Smart
Data Access (SDA)

* Data is brought into memory on demand

* Focus on BIl, Reporting, and Predictive Analytics
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INDUSTRIAL
PROCESSES

BUSINESS
PROCESSES



Enabling the Internet of Things with SAP solutions

e

SAP Predictive SAP SAP SAP
Maintenance & ‘Connected Connected Augmented
Service Manufacturing Logistics Reality



IT/OT integration examples redeﬁn'iﬁg‘Oi_I,and Gas

e 0&G compa-mes are pursumg lT/OT
integration to reduce drilling-days per well
extend the life of existing production
assets, and |mprove overaII operatlonal
awareness = T R Lag ~

Business processes supborted mclude :

==E=]
B3 ES ESED




Conclusion
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Pl Complements Big Data Solutions

Problem Big |Why?
System Data

Collect and store data from a The Pl System contextualizes your data, collects natively from a variety of

variety of real-time and sources and efficiently stores data at less that 10% of the size of big data

operational sources

Ask questions about a few to The Pl System is highly tuned for instantaneous answers about your data

hundreds of data points vs. waiting for minutes or hours for your answer to come from a big cluster

Ask questions about the entire Big data is excellent for asking questions about large data sets and finding

Pl archive / hidden patterns. Requires writing code and doing analysis in batches vs
real-time

Operationalizing and capturing The Pl System is the best place to capture knowledge from big data and

knowledge from analyses visual analytics and apply it in real time across all your assets and
operations

Deriving correlations and Big data is essential for large inspection queries that require complex
insights from the entire PI / descriptive analytics, pattern searching, and joining non-PI data
archive and external data
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Before you get started

- Ask internally, at your company, if there is a Big Data
Initiatives and which tools are already in used

- Leverage existing infrastructure

- Organizing the data is key:
- Proper AF structure required
- Link to Metadata (ID)
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What Systems Are Supported?

Advanced Visualization Big Data*

WAWAW ‘w"“

Apache Cloudera*
Tibco Microsoft .. and Many L
Spotfire o More SAP HANA
Tableau Data Warehouse
*Coming Soon, Stay Tuned!

w Teradata*
Microsoft
SQL
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Proven technology - Early Adopter Program
a Merck ' Devon Energy

NOV
“ EDF-RE
- BASF
b A& & Cemex
XD Alcoa GRP 'K‘ China Southern Grid
SDG&E

IOI,oi Freeport McMoRan
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Bl Edition Data Warehouse Big Data SAP Hana

(Q4-2015) Edition Edition Edition
(Q4-2015) (2016) (Q4-2015)
Pl Views
- Client side X X X
ODBC
Native
Connections
- SQL Server X X
- Flat File X X
- SAP Hana X
- Oracle (2016) X
- Hadoop X
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Questions Please remember to...

Complete the Survey

Please wait for the microphone . .
for this session

before asking your questions

Evaluation Form (Seminar Location - Date)

Nam:
Email
‘Quality and content of the presentations Poor  Good Excellent N/A
Welcome. O o o O
The Journey To Real-Time Operational Intelligence (@] O O O
of Connection @) @) @) o
Tank Level Management System O O O O
Using the PI System to Aid in Troubleshooting Operational Aspects of Oil
and Gas Well Drilling and Completion o O O o
ta te yo l I r Unleash your Infrastructure O O (@) O
Information on the Spot O O O O
& Wrap-up/Seminar Conclusion @) (@) O O
I y Quality and organization of the seminar
Choice of date O O (@] O
Time allowed for lunch/breaks O (@] O @]
Choice of presentations @] O O O
llnuiad far tha nrasantatinne ~ — — —~
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ZEARSHL| T kL)
Danke

Merci Gracias
Thank You
HDHhES

Cnacn6o Obrigado
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