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Big Data Analytics
with the Pl System

Presented by Mark Knox, Senior Systems Engineer @ OSI-:.
mknox@osisoft.com
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| need to minimize

risks through Data
Driven Decisions

| want to spend less
time on operational
reports

outside
of Operations

| want to compare my
equipment with ALL
of our other sites

statistical models
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We need to be more
confident in the
decisions we make.
We need trusted data

existing enterprise

data warehouse
systems of record for K ,
our corporate reports

\

| want to combine

We are starting a
Big Data project,

and we need
operational data K

Bl Tools that
people use
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" high volume, velocity, and/or variety
information assets that demand
cost-effective, innovative forms

of information processing that enable

insight, decision making, and process automation ™
---bartner
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The Benefits of Big Data

6% more profitable
83% improved process cycle times

49% had payback in one year or less

54% report ROIs >100%
27% year-over-year increase in revenue

o) .
12 /o less operating expense
o) .
Sources: Harvard Business Review, Forbes, IDB 5 /o mOre prOdUCtlve
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The Big Data Landscape

From: http://www.bigdatalandscape.com/

Vertical
wasesd gllucian.

ZRKNEWTON OP(OWER
Sporactice fusion ':'.,,._ ' POLCP

RXAnte *\ SurvayHonkey

Data As A Service
apigee @ ropsy
PATASIFT|=* factual.

GNIP
Fico GNP

@ LexisNexis:
LORATE Placed.

Apps
Consumer Business Intelligence
amazon ebs"sy \utonom\'
m
GO\)SIC e

Walrmart

ine
»

Ad / Media Apps
vicom . T
rDé‘)tav"ff] @ FLuRRY
Mediau
Science

[ meramankirs

eremm T URNMN

NG#:DATA

- .

L R Metrics

MMIND

M, AppDyramics
O VITRIA EXIA

splunk >EETLSESS

Analvhcs And
Visualization

[[ITETE] Alpine
alteryx «» Atigeo

AYATA centrifuge
~
CIRRO M

~D Datameer [Q(msrruz

metalayer OPERA
Q Palantir @==reesicen
O platfora QlikView
!\saffron §SaS
Wsisense i toblecy
wsonn Asten I TIBCO'

TJ TRIFACTA § UFORA

“visual ly

~

Infrastructure
Analytics Operational
7 EEEIIE CoucHBase
AL .
iQctan
cloudera E¥asoL *'MarkLogic § mongoDB
R :
Hortonworks §P]!ce &
INFOBRIGHT (% kognitio oy
WAMER N NETEZZA VOIt
Pivotal &4 i
VERTION
As A Service Structured DB
. 'amazon g’ atet  [EEEEIEEE [« NN
webservices -

~

(@ osisot. REGIONAL SEMINARS 2015

© Copyright 2015 OSlsoft, LLC



http://www.bigdatalandscape.com/

Big Data Analytics

Big Data

Analytics
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Analytics is required
to transform
information into
intelligence

More than storage
— Visual analytics

— Machine learning

— Complex event
processing
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Context in the Physical World

. - J < ..
* What product is y ' |

being made?
* Whenis the
equipment empty?

e Where was the
instrument when |
took that
measurement?

@ OSlsoft. REGIONAL SEMINARS 2015 © Copyright 2015 OSlsoft, LLC 8




Context in the Phy5|cal World

—\

——

* How are
renewables
impacting
equipment?

———

it

« Was there a
voltage violation?

* What are the
changes in
weather?
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Context in the Physical World

 Was wind gusty or
steady?

e Was the
maintenance
planned?

* How long does this
issue usually take
to fix?
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Big Data Analytics and the Pl System

Statistical Analytical Visual
Analytics Insight 7 Analytics

Time Series Relational | Unstructured | Geospatial
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Real-Time Time-Series Data Isn’t Perfect

* Naturally incomplete
 Doesn’t look like relational data
* Not evenly spaced

e Subject to errors in measurement
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Data Alignment

Different Archive Time Comm Failure

Start Times /
Speed 00\o @ © 0 O 0000ge0009%,0
5 lorque 000000\ 0 0000000000000 000
£ BearingTemp 0 09000 § 0 000090000000 009430
o ' 000
= Oil Temp 0000000000 QQOQ‘””‘”“‘ 000000000
= Manufacther Vestas
Last Service June 20, 2013 Spike / Out of Range Uneven Spacing
N\
Speed A yditional Measure o ® 6 o ‘\% ®©e0jo ®000
N Torque
o Bearing Tem 0nO o]
£ . ng y Bad Sensor 09090 09 0 © ©00
©  Oil Temp 0 g0 00 00000 © oo
=  Ware Factor ® o © 90 g 0 4000009,
Manufacturer Siemens
Last Service Date February 5, 2015
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Data Wrangling

100%
50% Prep
B0%
T0%
B0%
50%

40%
Analysis

Data cleansing and preparation tasks can take
50-80% of the development time and cost

30%

20%

10%

0%

https.//hbr.org/2014/04/the-sexiest-job-of-the-21st-century-is-tedjous-and-that-needs-to-change/
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Traditional Data Delivery

BUSINESS TOOLS

‘ ’ Pl DataLink

>/\)\/\ V| Excel
Pl OLEDB Enterprise

o~
z\: \;1 TIBC2
X [l ) Excellent for “small” datasets -

* Hours, days, 1-2 months m@

(‘ OSl:=ofi.

Does not scale to “large” datasets
* 6 months, 3 years, etc.
* “High density” data
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Pl Integrator for Business Analytics

data
aggregation

CLEANSE

data
quality

model
normalization

AUGMENT SHAPE

TRANSMIT

data
compatibility

Business
Intelligence &
Visual Analytics

Data
Warehouse

Big Data

© Copyright 2015 OSlsoft, LLC 17
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Video placeholder
(see http://osisoft.com > Resources > View by Event for
video replay).
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Pl Integrator for Business Analytics
Business Intelligence Edition

e Create Pl Views

* Access decision-ready data via ODBC
* Best solution to provide access to analytics
* Tibco Spotfire, Tableau, Microsoft Power Bl
« SAS, Cognos, Oracle
* Most dashboarding tools
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QOil Well Drilling - Exampl

'I! » Optimize Well

Drilling Times

AR

* Operate Drill Rigs
efficiently (ROP)

* Avoid damaging
Stick Slip events
and costly
maintenance
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File Edit View
-8 @ |

Page

Data

OGDrilngRealTime C

Bl Weight
Biock Height

Day

Diff Press

Flow In Rale
Hode Depth
Hook Load
Hour

Month

Mud Weaght In
Pumgp Pressure
ROP

Top Dove RPM
Top Dive Torque
WeekOfY ear

Tme

LocalTime
CATEGORES

Crew

( OSlsoft.

Tools

Haole Depih

Help

Top Drve RPM

Awy(R

=

o

Data labie
OGOnEngReal

Colors

Faters oD ¥ X

Q
OGDrillingRealTime Crew-Shift A

Crew

All) 4 values
CREW A
CREW S
CREWC
CREWD

Shin

Night

OGDrilingRealTime Crew-Shil... A

External dets | OGDnllingReal Time-Crew-Shift
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OGDrillingHeatMap_by_Drill_Crew_Shiftdxp - TIBCO Spotfire

Data X 1 ROP per Crew and Well ID Filters O F X
Crew Data table
OGOnilingRealTima-C .« OGDrilingReal ype t search stters Q
CREW A CREW B CREW C CREWD
- Colors: OGOrillingRealTime-Crew-Shift A
¥ e ‘ 1
® Max Shift
Day2 Vel @ Average Py mp e a
Sty Min
Dl Prese 23708671 | (AE) 2 values
Day
Flow In Rate Nght
Haie Depth
Hook Load Weil-
23708672
Hour
Well ID
Month »
ne to search in it Q
Mud Weight In i (AW} 6 values
' Wl None
Pump Pressure Well
2 9 23700927 Wel- 23708671
ROP 3 Vel 23708672
= WieR-23708927
Top Orve RPM Wel- 23709012
Top Drrve T Wl 23709014
VieekOfYear 23.-.-:;&'4 OGDnlkngRealTme-Crew-Shif, . A
« (U) T;E
LocalTime
~ &2 CATEGORIES
Well-
Crew 23709014

1 8iter changed

1 Siter changed

h Vv

OGDtilEngRealTime Crew.Shifl OGOnlmgRealTime-Crew-Shift

AWQROP) +» + ~«

Vel 1D (5 of 6 values fillerad [ x]

Wedl 1D (5 of B values fillered ]

teral data  OGDrillingRealTime- Crew-Shift
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File Data Worksheet Dashboard Story Analysis Map Format Server Window Help
M oB @l o 5L o A o % £ T
Analytics # Pages
[%0GDrillingRealTime-Crew-Shif..

il Columns | Top Drive RPM

Dimensions
Abc Crew Filters
# Day gz 18K
# Day2 -
abe Drilll  Shift
E% Local Time
# Month
Abc Shift Marks ;
Abc Week Day
#  Week Of Year
Abc WeekDay2
Abc Well ID d & G ?%
Color Size Label

Abc Well Name —

Well Name State

= Rows ' Hole Depth

| x+ Automatic v |

Abc Measure Names ’Detail Tooltip‘ ‘Shape

Measures & 7R0P
Bit Position

Bit Weight

Block Height

Diff Press

Flow In Rate

Hole Depth

Hook Load

Hour

Mud Weight In

Pump Pressure

ROP

Top Drive RPM

Top Drive Torque
Latitude (generated)
Longitude (generated)

(] Data Source | Sheet 1 t

2464149 marks 1 row by 1 column
e g

OO HHHFEHFFFHHFHFHFHHHF




Workflow of Pl Integrator for Business Analytics
Business Intelligence Edition

* Define an Asset Shape
* Enhance the Dataset

* Time slicers

* Various data & time filters

* Define overall time range & interval
* Publish to Target Destination
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Workflow of Pl Integrator for Business Analytics
Business Intelligence Edition

* Define an Asset Shape
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+ Matches
Found 1 Match

@ Source Assets T, Asset Shape

Server DEPIAE T Shapes

Database PetroLux Drill1 e
& Bit Position 7

@ Assets

W LUNvVE IuUINIdE Das
» & Conventional Oil
4 @ Drilling Operations

| » @ Drin

[z —

Attributes | :

& Deselect All

4 Bit Position

& Bit Weight

& Block Height

& Crew

& Diff Press

v

& Drill Time

4 Flow In Rate

& Hole Depth

4 Hook Load

& Mud Weight In

& Pump Pressure

& Bit Weight

& Block Height
& Crew

& Diff Press

& Drill Time

& Flow In Rate
& Hole Depth

& Hook Load

& Mud Weight In
& Pump Pressure
& rOP

@ shiit

& Top Drive RPM
& Top Drive Torque
& well ID

Well Name

& Well Name State

@ Drillt

W N

N,

N
X X X X X X X X X X X X X X X X X X X

ad

\,

J

\,

NN

ad

NN N,

NENVENEN

N,

N,

& ROP

& shift

& Top Drive RPM

4 Top Drive Torque

& Well ID
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Edit Filters

) Asset Name

Drill1

¥ Asset Template ‘ Rig

) Asset Category | Drilling Rigs

() Add Filter

Save

(@ osisoft. REGIONAL SEMINARS 2015
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@ Source Assets
Server

Database

@ Assets

b Q) Asset Lists

DFFIAF

Petrolux

.3 @ Key Performance Indicators

4 @ PetroLux Corporation

Attributes |

0O Select Al

4 Bit Position

 Bit Weight

P Block Height

& Crew

 Diff Press

» & Drill Time

4 Flow In Rate

& Hole Depth

4 Hook Load

& Mud Weight In

& Pump Pressure

REGIONAL SEMINARS 2015

T, Asset Shape

T Shapes

@ Rrig
# Bit Position
& Bit Weight
& Block Height
& Crew
& Diff Press
& Drill Time
& Flow In Rate
& Hole Depth
& Hook Load
4 Mud Weight In
& Pump Pressure
& roP
& shit
& Top Drive RPM
& Top Drive Torque
& VellD
Well Name

& Well Name State

LY

™,

™,

b S S SN SN SN A 2 2 S N S SN SN SN SN SN S S

™,

™,

™,

",

»,

N,

N,

N,

N,

N,

Y

Y

LY

™,

™,

™,

P —
Found 12 Matches

+ Matches

Drillt
Drillt0o
Drilit1
Drillt2
Drill2
Drill3
Drill4
Drills
Drille
Drill7
Drillg
Drill9

LR
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Workflow of Pl Integrator for Business Analytics
Business Intelligence Edition

* Enhance the Dataset
* Time slicers
* Various data & time filters
* Define overall time range & interval
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Select Data > Modify View > Publish

4 Add Column Y Edit Row Fitters = Edit Value Mode SE L2 Sz
e e 2 3/27/2013,12:00:00 AM | | /712014, 12:00:00 AM

Rig LocalTime Day Hour WeekDay Bit Weight Block Height Diff Press Flow In Rate Hole Depth  HookLoad Mud Weightin  Pump Pressure  ROP Top Drive RPM  Top Drive Torque WellID  Well Nam
Name¢TimeStamp Day Hour Dayofthe Value Value Value Value Value Value Value Value Value Value Value Value Value

Weal

= Drild
1RO\
Drill 2013-03-27 03:19:00 27 3 Wednesday 0.00 7878 143 50.00 142 4830 10.90 123.04 0.00 0.00 0.00 Well- Well1 Drillil
Dril [2013-03-27 03:20:00 27 3 Wednesday 0.00 78.85 1.01 50.00 142 48.30 10.90 122.63 0.00 0.00 0.00 3‘.’2??671 Welll Dril
Drild 2013-03-27 03:21:00 27 3 Wednesday 0.00 7883 11 50.00 142 4840 10.90 12271 0.00 000 0.00 ‘3\‘1’%&?\?5671 Well1 Drilliy
Drilll 2013-03-27 03:22:00 27 3 Wednesday 0.00 78.80 156 50.00 142 4810 10.90 123.31 0.00 000 0.00 3‘;‘2?9571 Well Dril
Drild 2013-03-27 03:23:00 27 3 Wednesday 0.00 7881 074 50.00 142 4810 10.90 122 41 0.00 000 0.00 ‘3\}?\?9671 Well1 Drilliy
Drilll 2013-03-27 03:24:00 27 3 Wednesday 0.00 7881 123 50.00 142 4830 10.90 12263 0.00 000 0.00 SV?:"EEF!?‘I Welll Dril
Drilll 2013-03-27 03:25:00 27 3 Wednesday 0.00 78.80 0.55 50.00 142 48.50 10.90 12214 0.00 0.00 0.00 3\.‘?‘?9671 Welll Drilli
Dril 2013-03-27 03:26:00 27 3 Wednesday 0.00 7883 158 50.00 142 4840 10.90 12338 0.00 000 0.00 SVEEEETI Welll Drill
Drilll 2013-03-27 03:27:00 27 3 Wednesday 0.00 7878 1.96 50.00 142 48.30 10.90 12324 0.00 0.00 0.00 \?’\.‘Elf_)ﬁﬁﬂ Welll Drilli
Dril [2013-03-27 03:28:00 27 3 Wednesday 0.00 7881 1.77 50.00 142 4860 10.90 12353 0.00 0.00 0.00 3\"?\?9571 Well1 Drill
Drilll 2013-04-02 22:40:00 2 22 Tuesday 11.60 32.64 33.16 595.00 1002569 23140 10.20 274459 0.00 0.00 1562.00 \7’\.‘2??671 Welll Drilli
Dril 2013-04-02 22:41:00 2 22 Tuesday 10.40 32.46 35.36 595.00 10025.69 23250 1020 274170 0.00 000 1601.00 ‘3\"?\?9571 Well1 Drill
Drilll 2013-04-02 22:42:00 2 22 Tuesday 10.60 32.57 32.28 595.00 1002569 23260 10.20 274231 0.00 000 1605.00 5‘;‘2?96?1 Well1 Drilli
Drild 2013-04-02 22:47:00 2 22 Tuesday 14.90 3225 6.53 596.00 10026.21 22830 1020 272155 0.00 000 1543.00 ‘3\"?\?9671 Welll Drill
Drilll 2013-04-02 22:49:00 2 22 Tuesday 0.00 36.25 6.78 595.00 10026.21 237.20 10.20 271355 0.00 o000 1581.00 \7'\'?\:?9671 Well1 Drilli
Drilll 2013-04-02 22:50:00 2 22 Tuesday 0.00 35.08 46.28 596.00 10026.21 236.60 10.20 2703.22 0.00 0.00 1593.00 3\"’2?9671 Welll Dril
Dril 2013-04-02 22:51:00 2 22 Tuesday 0.00 34.28 63.94 596.00 10026.21 24260 10.20 2714.47 0.00 000 1574.00 5\"2\?9671 Well1 Drillil
Drilll 2013-04-02 22:52:00 2 22 Tuesday 0.00 3382 839 595.00 10026.21 23930 10.20 2656.50 0.00 0.00 1574.00 3\"’2?95?1 Welll Dril
Dril 2013-04-02 22:53:00 2 22 Tuesday 0.00 33.05 35.55 595.00 10026.21 237.50 10.20 2680.76 0.00 0.00 1582.00 ‘3\}?\?5671 Well1 Drillii
Drillt [2013-04-02 22:54:00 2 22 Tuesday 0.00 3267 99.61 595.00 10026.21 23840 10.20 274977 0.00 0.00 1587.00 3‘.’2??671 Welll Dril
Dril 2013-04-09 21:26:00 8 il Tuesday 0.00 96.00 77.60 590.00 16964.25 267.30 10.80 358781 0.00 000 1530.00 ‘3\‘1’%&?\?5671 Well1 Drillii
Drilll 2013-04-09 21:27:00 9 21 Tuesday 0.00 95.86 106.55 590.00 16964.25 266.10 10.80 3619.76 0.00 0.00 1519.00 afg‘?ﬁﬁ?‘l Wely Brati *
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Add Column

Data Column Time Column

Select Time Column Options

Min rITeStamp 1
Second (4C Year
Milliseconds (252 Month
UTC Milliseconds (252 Day
UTC Seconds (40 * Day of the Week
Ticks (63581743060359000C » Hour
Time Zone Offset (220 Week of the Year
® Local
L GMT

Display 7 time columns
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Oil Well Drilling Example

A OSIDFPIBlInte

Select Data > Modify View > Publish

o Add Column Y Edit Row Fitters = Edit Value Mode SEE [EE T
Beprs = @) | |

Rig LocalTime Year Day WeekDay Hour WeekOfYear Bit Position Bi

Drill1 2015-10-20 14:10:32 2015 20 Tuesday 14 43 null null -

Drill1 2015-10-20 14:11:32 2015 ‘20 Tuesday 14 {43 null “null

Drill1 2015-10-20 14:12:32 2015 ' éTuesday 14 43 null énun

Drill1 2015-10-20 141332 2015 ‘Tuesday 14 43 null “null

Drillt 2015-10-20 14:14:32 2015 520 éTuesday 14 43 null énull

Drill4 2015-10-20 14:15:32 2015 E gTuesday 14 : null §nuu

Drillh 2015-10-20 14:16:32 2015 .Tuesday 14 null nui

Drillt 2015-10-20 14:17:32 2015 Tuesday 14 null Enull

Drill1 2015-10-20 14:18:32 2015 Tuesday 14 null cmull

Drill1 2015-10-20 14:19:32 2015 Tuesday 514 null énull

Drill1 2015-10-20 14:20:32 2015 Tuesday 14 null ‘null

Drillt 2015-10-20 14:21:32 2015 éTuesday 14 43 null '

Drillt 2015-10-20 14:22:32 2015 :Tuesday 14 43 null

Drill4 2015-10-20 14:23:32 2015 éTuesday 14 43 null énull

Drill1 2015-10-20 14:24:32 2015 %Tuesday 14 | null %null

Drillt 2015-10-20 14:25:32 2015 ETuesday 14 null nui

Drili1 2015-10-20 14:26°32 2015 Tuesday 14 null “null

Drillt 2015-10-20 14:27.32 2015 .Tuesday §14 null ;null

Drill1 2015-10-20 14:28:32 2015 Tuesday 14 null ‘null

Drill1 2015-10-20 14:29:32 2015 Tuesday 14 null nui

Drillt 2015-10-20 14:30°32 2015 éTuesday 14 ! null Enun

Drillt 2015-10-20 14:31:32 2015 20 éTuesday 14 43 null énull

: R PR - - “i_ _ _— - . E— ) v

© Copyright 2015 OSlsoft, LLC
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Row Filters

Add New Row Filter

| Numeric I Include rows based on whether the contents of a column
contain certain numeric values,

Include rows based on whether the contents of a column

match a string pattern.

String

Include rows based on whether the contents of a column
contain certain digital values.

Digital

Fvent Frame Include rows where certain Event Frames are active.

Null Values Include rows where the contents of a column contain a

value.

Close

@ OSlsoft. RE G | O NAL S EMI NARS 2 01 5 © Copyright 2015 OSlsoft, LLC



Row Filters

Add New Row Filter

Include rows based on whether the contents of a column 0 A
Numeric
contain certain numeric values. Add Numerlc ROW Fllter
Include rows based on whether the contents of a column
match a string pattern.
Include rows based an whether the contents of a column Include Rows where of the following conditions are true
contain certain digital values.
Include rows where certain Event Frames are active. | Bit Position L] | | greater than or equal to v ||0 | x
Include rows where the contents of a column contain a
value.
| ROP v |[greater than or equalto |0 | X
| Hole Depth v ||greaterthan orequalto ¥ ||0 | x
|T0p Drive RPM ¥ ||greaterthan orequalto ¥ ||0 | x

=+ Add Another Filter Criteria

Cancel Save Numeric Row Filter

(@ OSlsoft. RE G | O NAL S EMI NARS 2 01 5 © Copyright 2015 OSlsoft, LLC




Row Filters

Add New Row Filter

Include rows based on whether the contents of a column

Mumeric
contain certain numeric values,
String Include rows based on whether the contents of a column
match a string pattern.
Digital Include rows based on whether the contents of a column

contain certain digital values.

Fvent Frame Include rows where certain Event Frames are active.

Null Values Include rows where the contents of a column contain a

value.

Close
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Row Filters

Add New Row Filter

[T Include rows based on whether the contents of a column
contain certain numeric values.

String Include rows based on whether the contents of a column
match a string pattern.

Include rows based on whether the contents of a column
contain certain digital values.

Event Frame Include rows where certain Event Frames are active.

Null Values Include rows where the contents of a column contain a
value.

Close

(@ osisoft. REGIONAL SEMINARS 2015

Add String Row Filter

Include Rows where of the following conditions are true

‘Well Name State » H not equalto v ‘

== Add Another Filter Criteria

Done

Cancel

Save 5String Row Filter

© Copyright 2015 OSlsoft, LLC



Row Filters

Add New Row Filter

Include rows based on whether the contents of a column

Mumeric
contain certain numeric values,
String Include rows based on whether the contents of a column
match a string pattern.
Digital Include rows based on whether the contents of a column

contain certain digital values.

Fvent Frame Include rows where certain Event Frames are active.

Null Values Include rows where the contents of a column contain a

value.

Close
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Row Filters

Add New Row Filter

Include rows based on whether the contents of a column

contain certain numeric values.

Include rows based on whether the contents of a column
match a string pattern.

Include rows based on whether the contents of a column
contain certain digital values.

Include rows where certain Event Frames are active.

Null Values Include rows where the contents of a column contain a
D — value.

Add Null Value Row Filter

Close

Include Rows where f'ali- v | of the following conditions are true

| Bit Position v ||is not Null v |

== Add Another Filter Criteria

Cancel Save Null Value Row Filter

(@ osisoft. REGIONAL SEMINARS 2015
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Row Filters

Numeric Filter 1 S X
Include rows where all of the following are true

Bit Position is >= 0

ROPis>=0

Hole Depth is >= 0

Top Drive RPM is >=0
String Filter 1 S xR
Include rows where all of the following are true

Well Name State is I= Done

Add New Row Filter

Numeric

String

Digital

Event Frame

Null Value Filter 1 R -

Include rows where all of the following are true

Null Values

Include rows based on whether the contents of a
column contain certain numeric values.

Include rows based on whether the contents of a
column match a string pattern.

Include rows based on whether the contents of a
column contain certain digital values.

Include rows where certain Event Frames are
active,

Include rows where the contents of a column
contain a value.

Close

© Copyright 2015 OSlsoft, LLC
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Workflow of Pl Integrator for Business Analytics
Business Intelligence Edition

* Publish to Target Destination

@ osisoit. REGIONAL SEMINARS 2015 © Copyright 2015 OSlsoft, LLC 40



Select Data > Modify View > Publish

Target Configuration Summary

Pl View Y Shape and Matches

« There are 12 Matching Instances.
® Run Once

Timeframe and Interval
Run on a Schedule

= Your Start Time is 3/18/2013, 12:00:00 AM

= Your End Time is 7/4/2014, 12:00:00 AM

« Your Time Interval gets an interpolated measurement
every 1seconds

@ OSlsoft. REGIONAL SEMINARS 2015 © Copyright 2015 OSlsoft, LLC



Select Data > Modify View > Publish

Target Configuration Summary
Pl View v Shape and Matches
= There are 12 Matching Instances.
Run Once

Timeframe and Interval
® Run on a Schedule

= Your Start Time is 3/18/2013, 12:00:00 AM
First Run « Your End Time is 7/4/2014, 12:00:00 AM
2 « Your Time Interval gets an interpolated measurement
every 1seconds

Recur every| 5 v || minutes «
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What Systems Are Supported?

Advanced Visualization Big Data*

WAWAW ‘w"“

Apache Cloudera*
Tibco Microsoft .. and Many L
Spotfire o More SAP HANA
Tableau Data Warehouse
*Coming Soon, Stay Tuned!

w Teradata*
Microsoft
SQL
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Business Intelligence Edition Architecture

+ableau TIBCA Spotfire

Visualization
& Analytics

Data Preparation and
Integration Layer

System of Record
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Data Warehouse Edition Architecture

Visualization &
Analytics

Enterprise Data
Warehouse / Data SQL Server, Teradata, Oracle Hadoo
Mart / Data Lake

rd
Data Warehouse Custom or 3" Party Data
Edition Management and ETL

Data Preparation and "=
Integration Layer L

System of Record Pl Server
ERP HR
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Pl Integrator for SAP HANA

Native Integration with HANA Smart Data Access (SDA)
Data is brought into memory on demand

Focus on BlI, reporting, and predictive analytics
A.k.a. SAP loT Adapter by OSlsoft

BUSINESS PROCESSES INDUSTRIAL PROCESSES

w (@ osi-o.
&
Real-time Business Real-time Operational
Decision Support Decision Support
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>

SAP HANA Edition Architecture

Visualization, Analytics, & ‘ Tableau H Spotfire ‘ Lumira  SAP BW m SAP Solutions
Business Process Applications & Applications

Enterprise Analytics and
Applications Platform SAP HANA

SAP HANA Enterprise Information Management and Data Provisioning Agent

Data Preparation SAP 10T Adapter
and Integration by OSisoft SAP & Partner Suite of Data
Layer Pl Integrator for Management Tools
Business Analytics
R R LR EE SELE R
Systems of Pl Server CRM Sales EAM
Record y ERP HR

@ OSlsoft. REGIONAL SEMINARS 2015 © Copyright 2015 OSlsoft, LLC 48



The Pl System Complements Big Data Solutions

Problem Big |Why?
System Data

Collect and store data from a
variety of real-time and
operational sources

The PI System contextualizes your data, collects natively from a variety of
sources and efficiently stores data at less that 10% of the size of big data

Ask questions about a few to
hundreds of data points

The PI System is highly tuned for instantaneous answers about your data
vs. waiting for minutes or hours for your answer to come from a big cluster

Ask questions about the entire

Pl archive /

Big data is excellent for asking questions about large data sets and finding
hidden patterns. Requires writing code and doing analysis in batches vs
real-time

Operationalizing and capturing

knowledge from analyses /

The Pl System is the best place to capture knowledge from big data and
visual analytics and apply it in real time across all your assets and
operations

Deriving correlations and

insights from the entire PI /
archive and external data

Big data is essential for large inspection queries that require complex
descriptive analytics, pattern searching, and joining non-Pl data
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Key Takeaways

- Ask internally, at your company, if there is a Big Data
Initiatives and which tools are already in used

- Leverage existing infrastructure

- Organizing the data is key
- Proper Pl Asset Framework structure
- Link to metadata
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Proven Technology — Early Adopter Program

a Merck ’ Devon Energy

I o)V,
"‘ EDF-RE
L BASF

T CEMEX
XD Alcoa GRP 'K‘ China Southern Grid

SDG&E

Freeport-McMoRan
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Freeport McMoRan Copper and Gold

 CIO wanted Big Data Project
» Fuel Savings — Route Optimization ($14M potential), Idle Times ($4M)
* Need Granular Data - 1s and 5s data, 300+ Trucks
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Freeport McMoRan — What they did

* Collect Truck Data at high fidelity

* Used Established AF Model for Trucks

* Use Pl Integrator for Business Analytics

* Established Big Data Lake (Hortonworks)

* Hired Integrator (WWT) to learn Data Science
* |dentified Target Use Cases
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Freeport McMoRan - Results

* I|nitial Project started October 2014

* $4M in Fuel Savings (out of $14M possible) on Truck Route
Optimization

* $1M in Fuel Savings (out of $4M possible) on Idle Time

* Paid for all costs associated with establlshlng big data
practice

Action

— Including 5 data scientists

Prep Analysis
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Pl Integrator for Business Analytics Editions

nteligence | Warehouse | SAPHANA
Edition Edition

Pl Views (client-side ODBC) Released! Released!

Native Connections

- Microsoft SQL Server Released!

- Flat file Released!

- SAP HANA Q4 2015
- Oracle RDBMS 11 & 12 Q2 2016

- Hadoop HDFS & HIVE Q2 2016
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Contact Information

Mark Knox
mknox@osisoft.com
Senior Systems Engineer
OSlsoft
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Questions Please remember to...

Complete the Survey

Please wait for the microphone . .
for this session

before asking your questions

Evaluation Form (Seminar Location - Date)

Nam:
Email
‘Quality and content of the presentations Poor  Good Excellent N/A
Welcome. O o o O
The Journey To Real-Time Operational Intelligence (@] O O O
of Connection @) @) @) o
Tank Level Management System O O O O
Using the PI System to Aid in Troubleshooting Operational Aspects of Oil
and Gas Well Drilling and Completion o O O o
ta te yo l I r Unleash your Infrastructure O O (@) O
Information on the Spot O O O O
& Wrap-up/Seminar Conclusion @) (@) O O
I y Quality and organization of the seminar
Choice of date O O (@] O
Time allowed for lunch/breaks O (@] O @]
Choice of presentations @] O O O
llnuiad far tha nrasantatinne ~ — — —~
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ZEARSHL| T kL)
Danke

Merci Gracias
Thank You
HDHhES

Cnacn6o Obrigado
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