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Operating Forecast

Wind farm generation prediction based on weather forecast.

o Predicted Generation

Predicted
Generation
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Electrical Spike Detection

Actual facility demand exceeds statistical significant range of prediction

Airport Electricity Demand
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Emerging Technologies

* Experimentation and Predictive Modelling
— Microsoft Azure Machine Learning (ML)

* Shaping and Publishing PI System Data
— Internal Alpha Pl Integrator for Azure SQL

* Data Analysis and Assessment
— Power Bl Designer Preview

* QOperationalization
— Pl System 2015 Future Data
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Scenario: “Predict Building Energy Use”

Develop a model to predict : “ﬂ )
energy use at our 1 |
Headquarters Building. N M N |
This model can be used for #WW‘MWW WMW
capacity planning, and ﬂm WW ‘q F—
abnormal spike detection m | ”
and notification. ~ s
rf i
- Actual Energy Use i | \L
- Predicted Energy Use A e .WW b, N
N
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Hypothesis: Variables Affecting Building Energy

. Building Power , kW
Facilities o0 ———T e Power 2015
84017
- Power, kW TR T YT kw
* Hour of Day
 Weekday 400
1/1/2015 12:00:00 AM &, 8, 119.00 days <|[> & 4/30/2015 12:00:00 AM
. Outdoor Temperature, Deg F
Weather Statlon 90 ®Temperature_2015
70 il 1 L1 IA' l| l 63.600 -
« Qutdoor : i i I | oot
Temperature ;%W
1/1/2015 12:00:00 AM & S 119.00 days <> & 4/30/2015 12:00:00 Al
IT Network MAC Count, Mo of Users
120

« Network MAC
Address Count
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Predictive Modelling Process

DayOfWeek |~ | Hour + | Avg Building Power | | Avg MAC Address Count | * | Avg Outdoor Temperature |«

C | O u d Thursday

0 1131.59375 897 76.699097

. Thursday 1 1131.59375 897 76699997

S ervices Thursday 2 1131.59375 297 76.655957
Thursday 3 113159375 897 76695957

Thursday 4 1131.59375 597 76.695097

== Azure SQL /s Azure ML
Database Studio

\_
4 s

On Premise
Applications

AN

Elemen

. U

Power Bl Designer Pl Integrator for Azure

\ (internal Alpha) | j
|

Facilities

Weather
Station
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Pl Integrator for Azure SQL (internal Alpha

« Currently in OSlsoft —
development [F e e

and span two lines

=+ Create New Event View

Descriptive text can go here
and span twa lines.

= Duplicate View

Descriptive text can go here
and span two lines.

4+ Remove View

Descriptive text can go here|
and span two lines.

Name ~  Last Status ~ | Type ~ Run Mode ~  Start Time ~ End Time ~ LastRunTime > RowsWritten ¥ =

° Create “PI VieWS” MattMondayTest2 asset 2014-01-01T08:00:... | 2014-04-01T07:00-... | 0001-01-01TO0:00:.. 0 -
MattMondayTest asset 0001-01-01T00:00-.. | 0001-01-01T00:00:.. | 0001-01-01T00:00:.. O
Gopal_Test_0421 asset 2014-01-01T08:00:.. | 2014-01-02T08:00... | 0001-01-01TO0:00=.. O

» Filtered selection of
AF Elements by Select Data  Modify View » Publish eace |[SS

D) Source Assets T Asset Shape +" Matches

name, hierarchy, or

PISRV1 v 5 Shapes 5 Main Campus
e = Campus Weather
Categ 0 ry Database TechCon v 4 @ campus Weather s ’: Headquarters
© Outdoor Temperature S x | 1T Network
2 @ Hesdquariers N P— ,x
B T ¢ =
» (@ Marketing - 4 @ IT Network S x
— — @ MAC Address Count a3
Attributes I te IE'
[ Select &l

© MAC Address Count -

@ Network Traffic
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Pl Integrator for Azure SQL (internal Alpha

— Student000_Model_Training @ Column Details

« Select time range
and interval

Select Data  Modify View % Publish Name

Outdoor Temperature

Y Edit Row Filters Reset Name to Default
No Row Filters
nt @

4 Add Column @ Edit Timeframe
8 Columns 11/2014 12:00:00 AM

Main Campus Campus Weather Headquarters IT Network LocalTime Outdoor
« Add columns f
CO u n S O r MName Name Name Name TimeStamp Temperature
= Main Campus (10)

aggregating - Campus Westhor (1

-] Headquarters (10)

Pl System data = T

Main Campus Campus Weather  Headquarters IT Network 2014-01-01 00:00:00 42.9

Main Campus

 Add columns for

Main C

common time and

Campus Weather Headquarters IT Network 2014-01-01 01:00:00 42.99836

Student000_Model_Training

Select Data » Modify View » Publish

| Target Configuration Users and Groups Summary
: Maliky Choose 3 Target: v
date functions J
& RUn Once Bob Modify v » There are 1 Matching Instances.
J Run on a Schedule Timeframe and Interval

Your Start Time is 1/1/2014 12:00:00 AM
“Your End Time is 4/30/2014 12:00:00 AM

11 H ]
) Your Time Interval gets an interpolated
measurement every Th

License Usage

@® Add User or Group © Remove User or Group + Publishing this View will increase your Unique
Stream usage by 7277 Streams.

 Publish table to
Azure SQL

Not Published Yet
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Power Bl Designer Preview

Avera f Building Energy b
* Provides Power o
Bl Add-in S
Functionality
Independent of :
Excel Hour and Day of Week
° Free dOWnload ;U(;OLJC- of Building Energy by Rounded Temperature ,:;:(’fgeffgu Iding Energy by MAC Address Count
from Microsoft
1,500 1o
1,000 1000
=00 500 900 950 1,000 1,050 1,100 1,150
40 45 50 55 60 65 70 75 a0 85 : g g .
Outdoor Temperature MAC Address Count
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Microsoft Azure ML Studio

Advanced Energy Prediction Model
« Self-service data
science

« Experimentation to I
flnd “beSt ﬁt” Eﬂm “Fczpcﬂ-F:_ o A
prediction models

* Publish finalized v
models as accessible \
web service

]
] L
1] ]
= ® -
= — ]
=1

m

« Pay asyou go
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“Basic” Energy Prediction Model Experiment

Basic Energy Prediction Model
* Read data from . A

") o A
Azure SQL table
« Select model input ‘ — )
Varlables i.mu:u i----:-l-—-—* o
- Split data for — T ’
training and testing [ tres Regrassor v B v
« Train model using a ’\ /. \
selected algorithm B T voce ’
K\' -
« Score (Test) model ) Score e v
« Evaluate model : I
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“Basic” Energy Prediction Model Evaluation Results

« Visual and Statistical
Analysis of Model
Scoring

o “Coefficient of
Determination” a.k.a.
R-Squared = 0.63

Mean Root Mean Relative Relative Cosfiicient of
Absolute Absolute Squared
Squared Error

Determination
Error Error

0.610971

Error

@) osisott. USERS CONFERENCE 2015

Energy Prediction Model » Score Maodel » Scored dataset

s columns
5
ow Wesny D Salins
vas
T R R ™
8 Saturday 53.440937 854.272034
il Tuesday 71235245 159017334
2 Sunday
12 Saturday 6500361
2 Saturday 47.9934
12 Tuesday 67.22258
" Monday 72.0597
23 Tuesday 55.014748
23 Sunday 50.802834
15 Friclay 63.235847
il Monday 54.87787
4 Sunday 45216392 5931708
8 Friclay 44380 16.7905
Tuesday 50.879795 870470337

Scored [
Labels

4 Visualizations

Scored Labels

Scatte

compare to | Building Energy M

Building Energy

Scored Labels
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“Advanced” Energy Prediction Model Experiment

Advanced Energy Prediction Model
« Copy “Basic” Model - A

 Add “Boosted

Decision Tree r - /
B . o A

RegreSSion” algorithm . z;::if:f.-.'\'::::vj\- "'.'_-"EECEC for

« Train both algorithms
with Training Dataset v

« Score both models
with Scoring Dataset

« Evaluate algorithms [@ va @soewes v
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“Advanced” Energy Prediction Model Evaluation Results

“Boosted Decision Tree “Linear Regression”
Regression” R-Squared = 0.63
R-Squared = 0.83

-ed Energy Prediction Model » Score Model » Scored dataset Energy Prediction Medel » Score Model » Scored dataset

columns s columns
5 [ 5
Outdoor Building 2 . o Outdoor Building Scored [ 4 Visualizations
Hour WeekDay Temperature  Energy Scored Labels 4 Visualizations Hour WeekDay Temperature  Energy Labels
s d Label Scored Labels
s cored Labels vas _
sCatterriot
£ bl 00 . | b bbbl 0 b k|
compare to | Building Energy ' &
8 Saturday 854272034 | 839.426941 8 Saturday 53.440937 854.272034 | 814.864(
n Tuesday 1489173706 ul Tuesday 71235245 1590.17334
2 Sunday 828.458089 L. 2 sunday 50.38065 7238416 LI
1700
13 Saturday FEYar 976.998108 1700 13 Saturday TN3717 . .
600 ’ 1600 . N
2 Saturday 8708272 | 766676392 ° : 2 ) 1500 P
1500
12 Tuesday 1315.90967 | 1472.534424 - 2 Tuesday ? 1400
il Monday 148818787 | 1513.940063 8 1309 il Monday 5 1300
& ) @ 1200 .
23 Tuesday 927.2902 858.444641 2 1200 23 Tuesday 927.2902 =
5 ! =2 1100
23 Sunday 723.897644 | 804616333 R 23 sunday 50802834  723.897644 a .
1000
15 Friday 131651306 | 1249344116 o 15 Friday 63235847 131651306 900
.
1 Manday 113948718 | 1084102173 0 I Monday s487787 113048718 | 091838 wo-
4 Sunday 6931708 | 634927612 700 4 Sunday 45215302 6931708 | 6113661 0% % -
4 I A P o = P P
g Friday 44.3891 9167905 | 869.979431 B PP PP P E P P P 8 Friday 44,3501 9167905 746,347 & &P P F PP P E P
4 Tuesday 50879795 870470337 | 834319092 Scored Labels 4 Tuesday 50.879795 870470337 | 927.847" Scored Labels
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“Best” Energy Prediction Model

Best Energy Prediction Model in dratt

« Consider Seasonal
Effect on Building
Energy Demand

® Added feature7 “Week R eeem R - 4 Visualizations

Number” of the Year T

compare te | Building Energy T W

* Insert “R” Script to
“Week of Year” o] [ o] (e

column \ /%( e
. R-Squared 0.96 P T
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Energy Predictions in Pl System 2015

Basic Prediction vs. Actual
1500 ¢BUILDING ENERGY A
1200 15 M (il H_-rl-l Al A A 673.641 e R Sq u a red
P T O O I e S 0.63
L o JJ |. 4 r'r 15, |J LLI "-Ij-frr H'Tr lL | L \'fj t“"‘uf‘r'r |. il oBasic Predicted Energy .
iy o s P o o o = e | 782 71
400 = KWh
1/23/2014 12:00:00 AM & S 11.00 days <[> & 2/3/2014 12:00-00 AM
Advanced Prediction vs. Actual
1500 #BUILDING ENERGY Average
1')nanPI:.L Iﬂ'H ﬂ Al A 673.641 R Sq ua red
= L
L "ﬂj ILI.I ‘{rl[b%" I'rf-' ] 'J:Fﬂ:ﬁ‘ Jr ttl“ "rr '#1' oAdvanced Predicted Ener O 83
ay .
T Y PRI AP N 2 A N O 1363
B o Sy N P~ S R NI R R R A e s T
| 1/23/2014 12:00:00 AM & & 11.00 days<|[> & 2/3/2014 12:00:00 AM

Best Prediction vs. Actual

1500 ® BUILDING ENERGY Average

. f ; e R Squared
I I‘Fr:#j f;;ﬁuil nﬂf F!Ptﬂ;il» r‘faﬁﬂ ﬂj{r qi;i 0 Best Predicted Energy g 96
69280
S N R Y Y b ,,H._.JI ot %a S KWWh )
[ 1/23/2014 12:00:00 AM & 8 11.00 days<|[> & 2/3/2014 12:00:00 AM
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“Basic Energy Prediction Model” Web Service

Basic Energy Prediction Model [Scoring Exp.]

« Create Scoring
Experiment
= Trained Model
= Configure Web S
service input and i——— /
output parameters ﬁ /

* Publish Web Service | /
= Sample access code /
= Testing dialog e /
= Excel spreadsheet Ip—
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Operationalization with Pl System 2015

* Programmatic
— Develop application to call the Azure ML web service
— Example script generated by Azure ML Studio

* PowerShell Scripting

— Temperature forecast from Weather Underground

— Pl Interface for Universal File and Stream Loading (Pl UFL)
* Azure Data Factory

— Azure orchestration engine
— Pl Interface for Relational Database (RDBMS)
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PowerShell Scripting

N\
wunderground\‘ - 4 ‘\—.\
web service Azure ML =
. web service
OutsideTemperature Forecast RestAPI call for a BldgEnergy_kwh = f{
given location OutsideTemperature,
FLERE ] 2ty http://api.wunderground.com/api/ah3ebcahaldf734a/hourly/a/ HourOfDay,
_Forecast CA/Oakland.json Pl_PredictWithAzureML DayOfWweek,
WeekNumber

)

F)

\\ -
b f,.;- ¢
PredictedValues.CSV _‘1( )

|
H —
e -
PI_PredictWithAzure ML
v / PI— UFL PI System 2015
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Azure Data Factory

DayOfWeek  ~ | Hour ~ | Avg Building Power | | Avg MAC Address Count |~ | Avg Outdoor Temperature |~ Azu re
: | I Thursday 1131.58375 897 76.699997

Thursday 1131.58375 897 76.6989597

1131.58375 897 76.6989597 Data Fa Cto ry
1131.59375 897 76.695997
1131.59375 897 76.609997

DayOfWeek | ~| Hour |+ Avg Building Power |~ | Avg MAC Address Count |~ | Avg Outdoor Temperature| ~

Thursday
Thursday

Services

PR

Thursday 0 1131.59375 897 76.653997
Thursday 1 113159375 897 76.695997
Thursday 2 1131.59375 897 76.699997
Thursday 3 113159375 897 76.695997
Thursday 4 113159375 897 76.695997

Azure ML

1 |
\ “" Database Web Service

. Pl Interface for \
On Premise L — , Relational Database

Applications

Pl Integrator for Azure PI System 2015

\ (internal Alpha) j
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Curt Hertler

curt@osisoft.com

Partner Solutions Architect
OSlsoft, LLC
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Questions

Please wait for the microphone
before asking your questions

State your
name & company
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