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Your Big Data to Big
Data tools using the
family of Pl Integrators

Presented by Martin Bryant
Field Service Engineer
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Pl Integrators

Pl Integrator for Business Analytics

Pl Integrator for . SQL Server

Integrator for SAP HANA
SAP HANA

Smart Data Integration (SDI)

Business Analytics « Hadoop (HIVE & HDFS)
8 e Oracle RDBMS
T File

Time, Event Tabular
and Asset Context

Context Pl Integrator for Microsoft Azure

* SQL Data Warehouse
* Azure SQL
* Azure Data Lake
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The Traditional Pl System

Interfaces Pl Data Archive Pl Clients

iy

50K+ events / sec
50K tags per interface

30->300 tags
every 30 seconds

billions of values per day

200,000 or more data streams
kept forever
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An Alternative Data Use Model

Interfaces Pl Data Archive Pl Integrator for
: = Business Analytics

A
=

IS}

S0K+ events / sec
S0K tags per interface

billions of values per day 25K events / sec
200.000 or more data streams billions of values
kept forever
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The world of Big Data tools...

b Visual Analytics \w} Data Warehouse / Data Lake © Streaming Analytics — 2017
€z Excel @S otfire’ - ="a &
TIBCO Software a e ="
SAP BusmessObl“t’ mns EQ gaot Server loT Hub Machine Learning

@ ORACLE’
BUSINESS INTELLIGENCE ORACLG

esri s 18 4 poﬁ’g

~+j+++_olb|eou

% LG ’ Stream Analytics
PowerBl " ey 0,,? w E §€k0fk0 w
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Getting Value...

Solving complex Dashboarding — visual Integration to new I.T.

problems for a fleet reporting —real time & projects and databases
mobile

Multivariate, other Drill drown, rollup The right way to bring

statistics & machine Anywhere anytime operational data to I.T.’s

learning resources Big Data party...

One time answers or

. s i M“,”' % Ve Micrzsoft Y(‘,T._ .
Running models THH s ¢ SQLServer {sigElalalEls
‘ ~y ! o= R R ORACLE AL
: \w TIBCS s s ‘ BUSINESS INTELLIGENCE
\ B} PowerBl ¢ tableau
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Why? ... complex problem solving

All Pl Customers have a great deal

Statistical Analytics

of data.. Often too much for

This data can be complex with

many variables. Multivariable

- Identifying patterns and analysis and machine learning can
discovering problems provide interesting and invaluable
through statistical methods
that require large and answers to complex, big

diverse datasets )
questions...

Pl data is very large and complex.

This is about finding the answer to large, complex questions.

effective analysis in a spreadsheet.

Multidimensional
Business Intelligence
& Dashboards

Puactce m Ated

ATATIM 170000 AM ; ANy

Predictive
Statistical Modelling
& Machine Learning
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Complex Analyses Increase the Need for Deeper Integration

Interacting with common assets as a fleet

Complexity

Disparate assets
Interacting with assets on an individual basis

Process Optimization

Real-time & historical

Monitoring
Vviews across any

Real-time visibility

L, ——

* Pl ProcessBook
* Pl Coresight
* P| Datalink

* Traditional HMI

g{ oslsoft. REGIONAL SUMMIT 2017

Benchmarking

Fleet-wide
performance
comparisons

m

* Bl app (e.g. Tableau,
Spotfire, Lumira)

* Pl Integrator for
Business Analytics

* Pl Integrator for SAP

HANA

System Optimization

Large scale

multi-variate analysis

* Machine learning
(Azure ML, R)

* Pl Integrator for
Business Analytics

* Pl Integrator for SAP

HANA

© Copyright 2017 OSlsoft, LLC
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Applying Data to Maintenance...

. I
Disparate assets Interacting with common assets as a fleet

I i ith ts on an individual basis . .
nteracting with assets Individu I Predictive

Performance
Data aware Based on the

Usaged based Compare current history of like

Monitoring Using run times performance equipment and

and not clock
hours to
schedule

metrics, including f§ circumstances —
vibration, build a model
temperature, & that predicts
other KPIs to failure and

Preventive expected values triages
Maintenance maintenance

Wait for failure
faster break & fix

Complexity

and inspections
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Why? Dashboarding

S Oil (BOD): Actual v. Budget

« Automated daily reports
« Multiple data source views

. . I = « /- Management overviews
Visual Analytics R = e T _
3 I e  KPIs and metrics
rrrrresEirrEEEi s e Rollups by business unit
Bauhies Gas (MCFD): Actual v, Budget
=" T * Future Data (forecast
W Twr"Y”* N_/v ( )
‘E- . e —
« Visualizing diverse sets of e .
data sources to gain 3 Scheduled and Ad-Hoc Reportlng

insights, create reports, and
improve operations

Date

Don’t wait for tomorrow to explore performance today
your operational data is a click or swipe away.

Even from your mobile devices
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Result: Improved, Detailed Reporting and Analytics

Dashboard drilldowns
to detailed reports

Pl Coresight Displays

Regrmn S |rwerdooe

_HEl oadld =

Production Refinery Regional
Summaries KPI Scorecards onatat . Product
Inventories

Drilling Activity Reports Asset Performance Displays
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Why? L. T. Integration projects

Information systems have projects that provide enormous value —

and those can benefit from the real-time process awareness of Pl

Data Warehousing

Data. But Pl Data hasn’t been easy to integrate — until now.

| v ——
nadesp
|

* Centralizing data from
different business systems

* More effectively analyzing
and reporting on business
and building LOB
applications

Structured Pl data in a format readily consumable by the latest I.T. tools.
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New Technology is bringing the IT and OT Worlds Together

¥

| want to build predictive \ = < -

models from historical data m

| want to spend less -

time on operational
reports

e Plant Manager _s#infrastructure

#h o SE . T 2

| want to compare
my equipment
against our other sites

| want to minimize

risks through data
driven decisions
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Oil and Gas
Drilling and production comparisons
~ Information distribution

Mining

~ Route optimization
Energy reduction
Across 300 haul trucks

Life Sciences
' Reactor comparisons

! Process scale-ups

| (1L, 3L, 10L, 1KL, 10kL)

'-q\wﬁ‘\k | R mld__A!!

Renewables Pl Integrator for Business Analytics ©i=" % Food and Beverage —
Energy production reports is in use today! ___‘__ T e—— i
Wind farm comparisgns » 222" process anal ytics -""
Outlier analysis \ v IT/ OT integration S '
- » ’.. .\‘:_;-‘_
\\ v" Business intelligence and reporting R ;.'-.» -5
v’ Data warehouse integration AATSRL R LR RNF 2 8 1:‘—\':.":';'._",;

, o | S | _ _ LA VR L R L LA R

- . 2 tuat mae ¥ Supporting cross-platform projects - : e I
-

o= .,_.-——/
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Data janitor-work

collection

+ standardization of data
format

« de-duplication

checksumming

correcting timestamps

etc...

“Data scientists spend up to BO percent
of their time wrestling with the data rather
than generating new business insights.”

~NEW YORK TIMES

Source: https://hbr.org/2014/04/the-sexiest-job-of-the-21st-century-is-tedious-and-that-needs-to-change/



https://hbr.org/2014/04/the-sexiest-job-of-the-21st-century-is-tedious-and-that-needs-to-change/

Pl AF can provide context and structure

Operational Context High Value Insights Require
Data Context

Time-series data Asset

* Temperature .
S e E | > Which asset performs best?

* Flow

> Which conditions are optimal?
Asset details L{l—m)

: &Z’EZ IEI > What are the indicators of failure?

* Manufacturer

l_j ~ What leads to unsafe conditions?
Process g

*  Well drilling

* Site H l—-> What causes quality issues?
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Cleaning & Preparing Sensor Data: It’s Challenging

. Comm Failure

Speed I

‘.T“ oooe|.

Splke / 03:20 1 25 50 10.2 60

Out of Range—g330 | X X

03:40 9.9

|
: Additional
L™~ Measure

03:50 9.9 25 45 10.1 60
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Three steps from Pl System (AF) data to Big Data tools.. .

Select based on template (schema), intelligent filters, and time

Prepare clean, filter, & synchronize the data for tabular tools

PU b I iS h and update the data on a schedule

A configured tool (no code) for Pl System (AF) data and Pl Event Frames
Pl is still the source, rebuild your big data cache on your rules at any time.
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Pl Integrator for Business Analytics - “Select Data”

* Intuitive way to create

tabular content in “PI
VIeWS” Select Data > Modify View 2 Publish n

) Source Assets ‘ e
b Req u I res AF Server HERTLERS4305 n S e m_'ﬁd.29 Malr.hlis
Databe z QIressor D Compressor-023
ase

H Iel‘aI’Chy TS Q - © Compresser-304

D Assels & Compressor340
Compressor-356

4 © GasTian ‘-:3

° - @ Compressor4312

SeIeCt A_F Elements 7‘ Edit Filters {'{) Compressor567
and Attributes © unon

[iAsset Name © untot
© umo2

‘ Compressor-023 & Unto2
) Ig:a_SrT?IeeSCt Event j M Asset Template _W % :];:E
@ Add Filter :3 :n(;
« Scale up leveraging s © unes
name, hierarchy, or _ & i

@ umdy
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Pl Integrator for Business Analytics - “Modify View”

« Select time range
and Interval Select Data > Modily View 2 Publish At
Y vou sow s 1= 1 Ve Mode Start Time _GM______J

{ ey Heset Name to Default
Saturday ﬂ('ﬁr-’v'x’;

« Add columns for ' <l s

]

@ Column Details

o Atd Cotuma

. | Compressor | _LocaiTime | Dwferential Pressure Gas Flow
“rD[ !er aggrega‘“ng Unitg1 2011-10-01 0000 00 933822 100 6735 Mooel A INERL
& h . t (Unito1 2011-10-01 00:01.00 93.36484 1006739 Mode! A
Sync ronization Unit 2011-10-01 00:02:00 93.34747 1006742 Model A
Of Pl System data {unio 2011-10.01 00:0300 5333011 100 6746 Mot A
Unito1 2011-10.01 00:04 00 9331274 100 675 Moel A
Minimum
{Unito 2011-10-01 00,0500 9329539 100 6754 Model A LTRSS
H unito 2011-10-01 00.06:00 93.27802 1006758 Mosel A NSRS
* Filter / clean data e e
Unita1 2011.10-01 00:07:00 93 26065 1006769 ESRNN oy osation Stanerd Deviation
for null or bad |t 2011100100800 9324129 1006765 Moseia [
Porcont Good
H . {Unito1 2011-10-01 00:09:00 93 22553 1006769 Mode! A
values, missing , = e
Unito1 2011-10-01 00.10.00 93,2085 1006772 Mocel A
data’ Out Of range Unito1 2011-10-01 00:11:00 93 1912 1006776 Moot A
d b d {Unita1 20111001 001200 a3 17384 100678 Moget A
ata Oor based on |Unito1 2011-10-01 0013.00 9315647 1006784 Mooel A

process Condltlons Unito1 2011-10-01 00.14.:00 9313911 1006787 Motsel A
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Pl Integrator for Business Analytics - “Publish”

* Select targeted = comwemsambas Lowam |
endpoint from CSV Select Data > Modity View > Publish E
ASCII files to the Tt Confaraion —_—

Azure cloud V| [

+ There ate 29 Matching Instances.
Timetrame a0 Interval

Run Once

& Run on a Schedule

 Publish once or + Your Stan Tive s Satmday, Octuber L

201 12:00:00 AM
schedule updates P
R Su N T 3 we 7"7H Fr 5 = e
* Manage your e
Integrator jobs e s o ou B o

Q) ostoit. REGIONAL SUMMIT 2017
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Deschutes Brewery

« Located in Bend, OR « 2 brewhouses
« Founded in 1988 « 50+ vessels
« Pub opened in Portland, OR ¢ Bottling and kegging

in 2007
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Production Challenges Options?

il } - tati ’ Free R } Invest $750K Continue
H E N . . .
liing ermentation ree xise (OI’ more) in predlctlng
inline density transitions
Too late meters or with
c
S = and manual
E 2 4 TOO SO0ON  =—p \ N readings
5 hours
c’ ™
8 °7 Can this be predicted?
= N__¢ More Challenges
8 s -oTaszssasusTridn  Transition occurs between manual
Q S- ¢ = 30.3205690015667 density measurements
< T T T T T T T . L.
L 2 T I « Beer brands vary in transition

Time
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Predictive Analytics in a Spreadsheet

_ New Challenges

Bring Raw Data In » How can the data preparation be
T e T automated?

i ; * How can the predictions be
operationalized?

» How can the predictions become
more accurate over time?

o e

Clean it Up

|

4

::::::

Fit to a Line

whSommced VL 1008w

. 1
: s

o il
v : Q0o e
Fo g © - &
o (el l‘ﬁ
B £ g 7
=9 S E oy

G O 46

Q_LL e

o -

g -

Time (hours)
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E‘_; Import Data

Hypothesis: Use early density readings | , .
to predict Free Rise Transition Time

inﬂuenced by % €R' Execute R Script ~
 Brand of Beer < \ying transiirmatiins
* Fermentation dynamics (Temperatures, ,
pressures,..) | ] t
* Vessel's dimensions & volume AR
Time in Phase v
"',”. Select Columns in Dataset
o
/
- - - ‘/l/"/’ '/"
Microsoft Data Scientists & Exscuin 50t "
Lo/ Intelligence @ Cognitive Services, Bot Framework. Cortana
® Dashboards and Visualizations @ PowerBI / *
Eg] Machine learning and Analytics @ Machine learning, Stream Analytics, HDInsight /’/ \\
Ml BigDataStore kil Datalakesatow [\
IU\. Information Management rU'\. Data Factory, Data Catalog, Event Hubs : .

(R’ Execute R Script S A

Cortana Intelligence Suite
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How to Operationalize Predictions

DATA SOURCES PREPARE INGEST ANALYZE PUBLISH CONSUME

*

Cortana

P — \r.Tj

|
|
| Machine Learnin | Azure SQL
Azure SQL : g i
|

" I
4 |
|
. “
I | Data Warehouse
; Data Warehouse I
L ______ e e e e e D L___ ) Power BI
1 1 I
: Predictions as Future Data (to Pl 2015) 1
|
[
|
[
|
[
|
1

Pl System

1
|
I | |
< Azure Data Factory (Orchestration) >: Web/LOB Dashboards
I I

On Premise
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Azure ML Predicts Accurate Transition Time

Benchmark: Measure Predict: use 2 early densities Refine: base predictions on

accuracy against a standard to estimate transition time brand for greater accuracy

(based on historical data)

Big Rig By Rig Vo1 Big Rig
w o« 4 | L 2- v | mn
a ) ¥ )
<. y < . <
) ) — —|  sreda = 0.237370355676029 |
e
Time in Phase Time in Phase Time in Phase
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You can see Tim & Brian do this talk

Go to OSlsoft.com

Select Events / Past Events / Event Presentations
Select EMEA 2016 Berlin
Look for “Reducing Beer Production Time with Predictions”

Tim Alexander — Assistant Brewmaster — Data Wrangler
Brian Faivre - Brewmaster

Q) osiot. REGIONAL SUMMIT 2017 © Copyright 2017 OSisoft, LLe 29




Enterprise Data Warehouse Architecture

“I need to fit
Visualization & | | i i iii i il Custom operational data
Analytics icati into my existing
Enterprise Data Microsoft Fompa nY IT
Warehouse / Data Oracle DW Teradata information

SQL Server
Mart / Data Lake e e Rl

Data Preparation and
Integration Layer

System of Record

({ osisoft. REGIONAL SUMMIT 2017 © Copyright 2017 OSlsoft, LLc 30



Pl Integrator for SAP HANA Architecture

SAP HANA HANA Studio
HANA SDA % @ .

Linux SAP Lumira, VORA, S4, etc.

_ SAP DP Agent SAP HANA IoT Connector by E&rglfctaﬂon _
Option 1 Linux / Windows Pl JDBC OSlsoft intoa HANA  OPtion 2

(All Java) (via SDA) schema

_ PI Integrator Framework
Windows Web Ul Shape Designer Security REST Layer

Pl Server

Pl View

Data Framework (AF)
AELNE Microsoft SQL

Windows

z(,) osisoft. REGIONAL SUMMIT 2017 © Copyright 2017 OSlsoft, LLC 3|



Pl Integrator for
Microsoft Azure

Pl Connectors| Interfaces
|OSlIsoft Open Message Format (OMF) *4Q

b s

Pl Server(s)

Data Quality

.\ Augment
\ | Aggregation

Shape

Model

ejeq Apeay eueno)

Transmit

Normalization

________________________

INL_\INVIN/ L. JUILIVIIVIL D v L

Cortana Intelligence

Arure

SOL Data Warehouse

Azure

Ay
Data Lake store
Stream Aneyt e
Bt U
Data > Intelligence am— Actior

Insight [ Predictiony ay Futuwe Datow (to-PI 2015)

W LUPYHYIIL ZULT UDISUIL, LLY  — —



Bridging the Pl System and Microsoft Azure

Released SQL Database
Nov 2016 SQL Data Warehouse
Data Lake Store

Pl Integrator for
Microsoft Azure Summer 2017

Event Hub
loT Hub
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Getting Value...

Solving complex Dashboarding — visual Integration to new I.T.

problems for a fleet reporting —real time & projects and databases
mobile

Multivariate, other Drill drown, rollup The right way to bring

statistics & machine Anywhere anytime operational data to I.T.’s

learning resources Big Data party...

One time answers or

. s i M“,”' % Ve Micrzsoft Y(‘,T._ .
Running models THH s ¢ SQLServer {sigElalalEls
‘ ~y ! o= R R ORACLE AL
: \w TIBCS s s ‘ BUSINESS INTELLIGENCE
\ B} PowerBl ¢ tableau
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Contact Information

Martin Bryant
MBryant@osisoft.com
Field Service Engineer
OSlsoft, LLC

@ osisoft. REGIONAL SUMMIT 2017 © Copyright 2017 OSisoft, LLC 35


mailto:email@osisoft.com

Thank You
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