Feeding the Machine Learning Monster

Rick Smith
Process Information Manager
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International Paper

* World’s Largest Pulp and Paper Company
* Founded 1898
* 55,000 Employees
« $21.7 Billion Net Sales (2017)

* OSIsoft Installed Base
« 37 Facilities (62 Pl Servers)

e US, Brazil, Canada, France, India, Poland, Russia

1.9+ Million Active PI Tags
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Machine Learning Proof of Concept

« 2015 — Projects Prove Insight & Money in the Data
« 2016 — Began Enterprise Agreement

« 2017 — Mill of the Future -> Advanced Analytics Pilot
» Test 4-5 Tools at 3 Mills (Limited Areas) -> Picked One

« 2018 — Mill of the Future -> Advanced Analytics Extended Pilot
* 5 Mills (All Areas) -> Prove We Can Do it Again & Fine Tune Processes
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Feeding the Machine Learning Engine

N‘l’lm‘l‘M@M’ll Machine
Learning

International Paper Needs to Extract 5-10,000 Pl Tags of 1-Minute Data to Train
the Machine Learning Engine.

Initial Estimates Predicted 100+
Days to Extract the Data

Pl System tools identified larges
delays and AF fixed the biggest

Various techniques reduced the
extraction time by 80-90%

offenders.
 Enterprise Initiative Across 30+ + PIOLEDB
Facilities _
» Asset Analytics
* Pl Integrator for Business
Analytics
0Slsoft.
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Machine

Extracting Knowledge from Data

* First Principles

* Engineers Use Process Knowledge to Decide Important Data to Retrieve

» Correlation Using Statistical Packages
« Statistics Tells Us What is Important from Lots of Data in an Area

« Machine Learning

* Collection of Techniques Where Computers Learn Patterns from Data
 History: 1-3 Years of 1-Minute Data for 5,000-10,000 PI Tags
* Real-Time: 1-Minute Snapshots for 1,000-5,000 PI Tags

[ 5-10K; 1-3 Years |

Machine
Learning

P

System [ 1-5K; Every Minute |
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What Questions Do We Want to Ask?

* Old School...Reporting on Past
* How Did Facility Perform Last Month?
« How Did Facility Do Yesterday?

* Going Forward... Learn from Past

« What Operational Changes Should | Make
Today?

» What Should | Do Differently Now?
* What Should | Do Differently in the Future?

| Databases |
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What Data Do We Have?

| Databases |

a3
o

0Slsoft.

PlWorld san rrancisco 2018

» Business/Process Data Silos
* Process — 0.25s-1min
* Quality — Reel Lab Tests & Hourly Labs
* Profile — 120-1000 Boxes/Sensor @ 20s-60s

« Maintenance — Equipment Specs, Maintenance
Records, etc.

« MES - Orders, Recipes, Specifications
 ERP — Feeds from Above Plus Everything Else

* We Spend 80-90% of Our Time Merging,
Cleaning Data for Analysis

* Need Good Data at the Right Frequency
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Data Collection Before 2015

13001
13001.5P
13001.5T
13001.VP
Microsoft*
@@ osi-.. 1= Excel
=

Vendor
— Add-In
e Lo » Trend Graphs
4532 * Correlations

* Histograms
+ Daily/Shift Reports
* Trial Reports

SCAN_D6013.Avg
SCAN_06013.Tgt
SCAN_D6013.BOX.001
REEL_DG013.Avg

‘ Databases ‘ ‘ Extract / Transform / Load
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Process Audits -> Long Data Retrievals

* Retrieve 1-Year of 1-Hour Values for 50-200 Variables

 P| DataLink Issues (2015 or Eatrlier)
Data Retrieval Takes 3-12 Hours

“Too Many Events” Error

Pl Server Timeouts

Editing Calculations Causes Datalink Refresh
» Copy/Paste Datalink Results to Separate Sheet for Calculations

Pl DataLink (2016 and Later)
« Performance Improved, But Still Need Alternate Solution
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MI-Assist Addresses Process Audit Issues

File Home Insert Page Layout Farmulas Data Review =" Developer PI Datalink PI Builder MI-Assist CEMR Q Tell me what you want to do...

Z7 New Form + =t Specs (Var) i Compress ~ S| Asset - # Update Ranges  H=g Column Stats Bz Dump - Canfigure
N

=h Export Data - =h Specs (PU) . | Interpret - ey Event Frame - Y Row Filter i Recalculate = | LT Script ¥ Reinitialize
Test  Event Downtime Periodic Event _ Clean
Data Data (ID) £ Test History Data Data i Archive Count | <€ WIP Options - 2| MV iew ~ ,_,r'-: Summarize 2 Version

File O5I50ft PI PI AF Clean Calculate Server Info

« MI-Assist Excel Add-in -> Pl OLEDB Provider

« User Requests -> Pl SQL Queries -> Populate Excel
Chunk Requests to Avoid Timeouts and “Too Many Events” Error
No Formulas to Eliminate without Copy/Paste Requirement
Pick-up Data Retrieval After Data Already Retrieved
Data Retrieval Takes 15-45 Minutes
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Ad-Hoc Data Analysis After 2015 (MI-Assist)

13001

13001.5P
13001.57
13001.vP

@ OSl:=oft.,

Minitab».

Microsoft*

MI-Assist

80-90%
Performance
1as4 Improvement
1278 * Trend Graphs

2134
4532

* Correlations
* Histograms

22::-32313?;5 « Daily/Shift Reports
_| . [—, .

SCAN_06013.BOX.001 * Trial Reports

REEL 06013.Avg

‘ Databases Extract / Transform / Load
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Seconds/Tag-Year...Minutes/Tag-Year

Tag-Year /tagyir/ noun
The Amount of Time to Read One (1) Year of Data for One (1) Pl Tag

Pl Tags Read 1-Year Read Time Seconds/Tag-Year | 10K Tags / 1-Year

3-Hour 216.0 25 Days
100 12-Hour 432.0 50 Days
50 15-Min 18.0 2.0 Days
200 45-Min 13.5 1.6 Days
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Machine Learning -> Let’s Collect Big Data

* First Machine Learning Data Request is:

« 12-36 Months of 1-Minute Interpolated Values for 10K PI Tags
+ 3*365* 1440 * 10,000 = 16 Billion Rows (PI Tag, TS, Value, UOM)

« Extrapolated Test Read -> 100+ Days (860+ Sec/Tag-Year)

* Time to Engineer a Solution and Evaluate Options
Use Vendor’s Retrieval Mechanism

Pl DataLink

Pl OLEDB Provider (Tag-Based Retrievals)

Pl OLEDB Enterprise (Asset-Based Retrievals)
Reprocess the Data Archives

Use AF to Lower Frequency of Dense PI Tags
Pl Integrator for Business Analytics

[ 10,000 Columns >

SMOoy UOTIIIN 9'T

NoO~ONE
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Mill-X Archive Writes/Day (1/1/18-1/3/18)

Why Does it Matter?
» Read 1-Year (Archive 60s) -> 0.9 min
* Read 1-Year (Archive 30s) -> 2.8 min
» Read 1-Year (Archive 10s) -> 6.0 min
* Read 1-Year (Archive 2s) -> 18 min

45,562 Pl Tags; ~70 Million Archive Writes/Day

335 PI Tags < 2s Archive Rate -> 0.7% of Pl Tags and 36.8% of Archive Writes
647 Pl Tags < 4s Archive Rate -> 1.4% of Pl Tags and 50.6% of Archive Writes
1134 PI Tags < 10s Archive Rate -> 2.3% of Pl Tags and 58.9% of Archive Writes

| E F G |
Mumber Tags f 45,562'
Total Events " 68,337,018°
Average Events/Tag r 1,500
35 >28800 f 1.20%
10s  >8640 f 2.32%
pointty| ~ | pointsource *| 01-Jan-2018 ~| 02-}
0] B 0

! OSlsoft.
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Seconds

1400
1200
1000
800
200
400
200
0

1-Year Historical Read

10 15 20

Archive Event per Minute

¥ = 35309 + 74.445

25 30 35
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Timing Study #1 — "Dense” Pl Tags

Tag

36 sec/Tag-Yr

122 sec/Tag-Yr

137 sec/Tag-Yr

137 sec/Tag-Yr

94 sec/Tag-Yr

Timing_Row
Source Type
Value T',rﬁe
Eng l..lnit;l

Descriptic Timestamp

J100]

ARAANNY

SCREEN AMPS

SCREEN AMPS

SCREEN AMPS

Pump Motor

31:011282
102.67 AMPS
31:01044

o

~—

50-60 Archive Events

per Minute

90 0,
2/4/2018 6:23:03 PM

Sh

2052018 2:23:05 AN

0Slsoft.
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Repeat Timing Study #1 — AF Element

RM-PM1-PoorlyCompressedTags

General I Child Elements | Attributes |Ports | Analyses | Motification Rules IVersionl

» Tag-Based -> Single Tag for Time Range

Filter 1
| » Asset-Based -> Query All Tags for Time
&t |8 % £ Name < Unit Q... | Settings...
] E ¥ PM1 15/16 Vacuum Pump Motar Eampere \WRM_sab4pip1131:0I11294 R an g e
&F PM1MIDDLE PRIMARY SCREEN ... |ampere |\\RM_sab4pip131:0111292 .
il ¢F PM1NORTH PRIMARY SCREEN A... | ampere |V\RM_sab4pip1\31:0111231 ¢ AF Retrleval 2'5X FaSter
«¥ PM150UTH PRIMARY SCREEN A... |ampere | \\RM_sab4pip1131:0111293
m «¥ Spool Starter Freq Amps ampere | \'\RM_sab4pip1\31:0II044
:AFCunflg .S:Lnueland_Dev;DB:Tesltlng-Ftl::h: Srmth;ELT:IéL-FtM-PMl-F'nDrI'.'Cum préssedTags
|ELName %
|5tart Date 03-01-2017 00:00:00 v2017.12.07 -> PIAF RunTime: 04:34; Pl RunTime:10:42 {Office)
.End Date 12-01-2017 00:00:00 w2017.12.07 -> PIAF RunTime: 03:09; Pl RunTime:08:26 (VPN)
|Frequency 1m w2017.12,08-> PIAF RunTime: 01:20; Pl RunTime:02:15 (Office)
|Eng Units
PM1 15/16 Vacuum PM1 MIDDLE PRIMARY  PM1 NORTH PRIMARY  PM1 SOUTH PRIMARY Spool Starter
[ Description Time Pump Motor SCREEM AMPS SCREEN AMPS SCREEM AMPS Freq Amps
0Slsoft.
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TS #1 - Reduce 1s Archives Writes to 1m

31:011292

MName Expression Va V¢ Output Aitribute
Varisblel| "Spool Starter’ Spool Starter|Spool Starter-Write
Varisblez| "PM1 15/16 Vac Pump’ PM1 15/16 Vac PumplPh1 15/16 Vac Pump-Write
Varizble3| "PM1 Middle Prim Screen’ PM1 Middle Prim Screen|PM1 Middle Prim Screen-Write
a0
2/4/2015 5:23:08 PM Variable4| "PM1 North Prim Screen’ PM1 Morth Prim Screen|PM1 Morth Prim Screen-Write
1-Min Arc Write Varisble5| 'PM1 South Prim Screen’ Pi1 South Prirn Screen|PML South Prim Scresn-Write
- 107,
- 105
102 Add a new variable
- 100
- 93 Scheduling: () Event-Triggered @ Periodic
30/ lo. . . . Period: 00h 01m 00s
214/2018 6:23:08 PM 8h

) OSlsoft.
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HEEEEEEEEEEE. AT YYA R AR S
TS #1 - Reduce 1s Archives Writes to 1m

31:011292

1-2 Sec Arc Write 10357 AMPS
31:01044

‘ll‘""

2/4/2018 6:23:03 PM 2h 2/5/2018 2:23:08 Al

3-Month Read
Description Raw 1-Min
Spool Starter Amps 0.15 0.100
PM1 N Prim Scrn Amps 0.51 0.079

VTR P PM1 Mid Prim Scrn Amps 0.57 0.079
T - . @ PM1 S Prim Scrn Amps 0.57 0.094
| l 1 ] ' 1 " ‘ PM1 15/16 Vac Pmp Amps | 0.39 | 0.080
a2l ! | 85% Decrease in Read Time

7 oSlsoft.
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Timing Study #1 Conclusions

Archive Write Count Correlates to Data Retrieval Time
AF Element Retrievals Better Than Single Pl Tag Reads

Reducing Data

... Let’'s Try Something Bigger...

0Slsoft.
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Density Reduces Data Retrieval Time
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Timing Study #2 — 50 Pl Tags (Audit Simulation)

Start Date 12-01-2016 00:00:00
End Date 12-01-2017 00:00:00

(1-Yr. Read)

Source Type

| Value Ty 5&

Eng Units.

Descriptic Timestamp

Minutes per Pl Tag /

15:20 (50 PI Tags)
0.41 0.25 0.23 0.24 3.29 2.31 1.29 1.00 0.58 0.58

321010022 322LC322 32211C323 32211C324 321FI1C009 321FIC012 321 FICO55 321FIC013 322FIC312 322FIC309

/99
¢
(-

Pl Pl Pl Pl Pl Pl Pl Pl Pl Pl
SNAP SNAP SNAP SMNAP SNAP SMNAP SNAP SNAP SMNAP SMNAP
RPM FT FT FT GPM GPM GPM GPM GPM GPM

#1 LINE W #2 LINE W #2 LINE W #2 LINE W#1 LINEW #1 LINE W ENW - A LII#1 LINE W. L2 WSHR1 #2 LINE W

_'AF ElementName

| Frequency ) im

0Slsoft.

RR-Buckmanl
Start Date 12-01-2016 00:00:00
. End Date 12-01-2017 00:00:00

04:52 (50 AF Attributes)

3x Improvement!

Eng Units )
Description Time Tagll Tag02 Tag0d3 Tagld4 Tagls Tag06 Tag07 Tagl® Tagld TaglO Tagll Tagl2 Tagl3
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Timing Study #3 - Gauge Profile Tags (AF)

600 PI Tags

Wet End

600 PI Tags

Wet End

600 PI Tags

Wet End

2 Hours

) OSlsoft.
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Timing Study #3 - Gauge Profile Tags (AF)

 Retrieve 1-Minute Profile Summary

« Ten (10) Sensors (40 Values) -
» 2-3 Profile Scans/Minute

« 8-Hr -> 5 Seconds
» 14-Days -> 40 Seconds
« 25 sec/Tag-Year

 Retrieve 1-Minute Full Profile
» Ten (10) Sensors (6,040 Values)
* 8-Hr -> 02:00
« 1-Day -> 06:30
« 15 sec/Tag-Year

OSlsoft.
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Timing Study #4 — Reprocess Archives

« Select 100 PI Tags

 Read 3-Months of 1-Minute Data
* 65 Minutes

* Reprocess the Archives

« Read 3-Months of 1-Minute Data
« 28 Minutes... 50% Reduction

OSlsoft.
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Good Progress... what Else Can We Do?

Create AF Elements for Data Retrieval J
Create 1-Minute Machine Learning PI Tags w/ AF
Reprocess the Data Archives

Create a Data Mart at Required Frequency
a. Pl Integrator for Business Analytics

5. Fix Pl Tag Compression to Stop Storing Sensor Noise
a. Forward in Time Only

P w e

OSlsoft.
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Create Data Mart View
Pl Integrator for Business Analytics

Select Data > Modify View > Publish

[ Source Assets

Server Loveland_Dev

Database

Testing-Rick Smith

I@ Assets
Elements =

]

‘FixWInderTags
w1
w2
-W3

-Gauge
- ( Reel
- @ Ash
... (§ BasisWeight
- (J Brightness
- (§ Caliper
- (§ ConditionedWei
- ( Formation
- (§ Moisture
- (§ Moisture-VIB
g Opacity

m

0Slsoft.
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T, Search Shape
T Asset Shape
4 [@DReel

& GradeCode

=] GradeDescription

=] ScannerName

4 @ EL-PaperMachineGaugeProfile

& Scan-Average
& Scan-EndBox
& Scan-StartBox
& Scan-Target

& Scan-Valid

NN NN N N N N N,
X X %X X X X X X X X

+ Matches

» @ Reel
» @ Reel
» @ Reel
» @ Resl
» @ Resl
» @ Resl
» @ Resl
» @ Real
» @ Real

» @ Reel

Found 10 Matches g\
/V

0

Datq Mart 1

Data ‘.___

Warehouse !—-
< /Ja a Mart 2

L y . A

- '—— -
l » Data Mart 3

-

L —

Select Data > Modify View 2 Publish

Target Configuration

Summary

PlView

|

Shape and Matches

) Run Once
® Run on a Schedule

First Run

+ There are 10 Matching Instances
Timeframe and Interval

- Your Start Time is *-5m
« Your End Timeis *

» Your Time Interval gets an interpolated
| measurement Every 1 minute

#0OSlIsoftuC
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View Data... Send to Data Mart

Select Data > Modify View > Publish
= Add Column Y Edit Row Filters $= Edit Value Mode Stxtiime End Timo
N columns O Row Fiiters I;:::;y:-:‘vli‘tlicli“‘.e’aiues ~5m =
|
Reel TimeStamp GradeCode GradeDescrif |ScannerNami | EL-PaperMac Scan-Average Scan-EndBox Scan-StartBo Scan-Ta
Reel 2/6/2018 9:18:23.801... 006080200... 0 Reel BasisWeight 576 14 92
Reel 2/6/2018 9:19:23.801... 006080200... 0 Reel BasisWeight 576 14 92
Reel 2/6/2018 9:20:23.801... 006080200... O Reel BasisWeight 576 14 92
Reel 2/6/2018 9:21:23.801... 006080200... 0 Reel BasisWeight 576 14 92
Reel 2/6/2018 9:22:23.801... 006080200... 0 Reel BasisWeight 576 14 92
Reel 2/6/2018 9:23:23.801... 006080200... 0 Reel BasisWeight 576 14 92
Reel 2/6/2018 9:18:23.801... 006080200... 0 Reel Brightness 576 14 92
Reel 2/6/2018 9:19:23.801... 006080200... 0 Reel Brightness —= — =
Reel 2/6/2018 9:20:23.801... 006080200... 0 Reel Brightness M aybe Faster...
Reel 2/6/2018 9:21:23.801... 006080200... O Reel Bﬁghtness Runs on Another Computer...
Reel 2/6/2018 9:22:23.801... 006080200... 0 Reel Brightness
Daal 210042 Q-22-92 204 nnenenann n Daoal Brinhtnace 576 14 Q92 !
OSlsoft.
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Fix Pl Tag Compression

* Long-Term Problem
« Many of Stakeholders

» Applications Need Data at Different Data Frequencies
* People Do Not Understand Noise

 Polled Interfaces Switching to OPC (Exception-Based)
 Big Data and Data Retrieval Raises Awareness of the Issue
» Gathering Stakeholders to Work Problem

OSlsoft.
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Stakeholders and Pl Tag Compression

* No Compression Camp (aka Store Everything) f

* Instrument Electrician / Process Control j"_ﬁ

* Reliability Engineers - :
« Compression is OK, But Not Too Much |

* Process Engineers

» Subject Matter Experts
« Advanced Analytic Engines

« Summarize the Data For Me for High Performance Retrieval
* Subject Matter Experts
« Data Warehouse

"B

OSlsoft.
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Selecting the Best Option...For Now...

1. Create AF Elements for Data Retrieval
R) 2. Reprocess the Data Archives

RJ 3. Create 1-Minute Machine Learning Pl Tags w/ AF
a. Relatively Easy (aka Fast) to do

b. Selective... Pick and Choose When to Apply

c. Does Not Affect Existing Applications and/or Data Consumers

4. Create a Data Mart at Required Frequency
a. Pl Integrator for Business Analytics

5. Fix Pl Tag Compression to Stop Storing Sensor Noise
a. Longer Term Solution

OSlsoft.
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Rick’'s Take-Aways

* Dense Pl Tags WILL Slow Down Long-Term Data Pulls

« Dense Data Pl Tags May Be Caused By...
« OPC Interfaces Changed from Polling to Exception
» Asset Analytics Triggering on Events (Consider Periodic)

* Create Lower Frequency Pl Tags for Dense Data...

» Pl Tag Compression Can Reduce Data Density, but at a Cost
* Pl System Tools Can Find the Problems...

* Pl System Tools Can Fix the Problems...

« Systems Need Janitors Just Like They Need Architects

OSlsoft.
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Feeding the Machine Learning Engine

Rick Smith
Richard.Smithjr@ipaper.com
Process Information Manager
International Paper
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Questions

Please wait for the
microphone before asking
your qguestions =

State your :
name & company

§'ﬂ 0Slsoft.
PI WOI’|C| SAN FRANCISCO 2018

Please remember to...

Complete the Online Survey
for this session

Download the Conference App for
OSilsoft Users Conference 2017

_ Ao iore
* View the latest agenda and create your own

* Meet and connect with other attendees

search OSISOFT in the app store
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Mercli iﬁﬂl iﬁﬂt
Danke

Cnacmbo Gracias
i Thank You
ZAFSEL|C} HOhES
Grazie Obrigado

Systems Need Janitors as Much as They Need Architects
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