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. ENERGY
Genesis Energy ONLINE

« Both a Generator and a Retailer of electricity
» Retail side ~ 500,000 customers

Genesis Energy

Energy Online
* Generation side ~ 1600 MW

One thermal site (coal, gas — combined and open cycle)
Seven hydro stations (North and South island)

One wind site (plus a partnering one)




Genesis Journey

2017 — workshop to identify what data we have and how we
can be more effective with it/assist with decision making —
identified the potential.

» _ \/ S
igégcti?;ough 2018 - recognised in-house data science } aél w'))) rapldmlnef

2018 — data warehouse project — PI Integrator was a key

.|||

End of 2018 — investigate predictive analytic options
(external software vs internal capacity)

snowy hydro
2019 — decided to commit to in-house platform and focused$ Bc HYd Yo _-mley:%
resource on it
Power smart

What resources we’ve relied on
» Open source software
* PI Integrator, Microsoft Azure Datawarehouse

@ OSl:oft.

 Data scientists, data architects/engineers, generation
engineers




How did Pl System fit in?

— PI Server Asset Framework (AF) and Pl Integrator

» Data warehouse’ project — combining all high use
generation related data into one location

« Pl Historian was key dataset

existing method could give us 10 minute data

managed by IT consultant os' ‘F

have to request what tag, what type of S D t L
.

calculation; average, total, point in time etc and
there is a cost per request

« Pl System has a product that can now do this process
which we can then manage internally with much less
constraint — PI Integrator

« Integrator requires Pl Server Asset Framework so this
was another necessary step to for us



Pl Server Asset Framework

» Pl Server Asset Framework was necessary for the
integrator — we hadn’t used it before

« Duplicated existing Maintenance Management System
(Maximo) hierarchy for the Asset Framework hierarchy

« Dimension Software aligned PI tags into structure

» Pl Server Asset Framework also has a lot of potential
that we are not using at this stage

Elements

{3 Elements
[l [ STATIONS
[=~ {§ HUNTLY
= [ HLYO1: UNIT 1
- [ A: UNIT TRANSMISSION AND DISTRIBUTION
- (@ B: POWER STATION ELECTRICAL SYSTEM
-+ (@ C: INSTRUMENTATION AND CONTROL EQUIPMENT SYSTEMS
(G E: FUEL SUPPLY AND ASH AND DUST DISPOSAL SYSTEM
[ G: WATER SUPPLY AND DISCHARGE SYSTEM
(G H:BOILER SYSTEM
[ L: STEAM WATER AND GAS CYCLES SYSTEM
M: MAIN MACHINES SYSTEM
(F MA: STEAM TURBINE PLANT INCLUDING CONDENSER
(G MK: GENERATOR PLANT
(G MP: COMMON INSTALLATIONS FOR MAIN MACHINES
(5 MV: LUB. OIL SUPPLY - MAIN MACHINE
(5 MX: CONTROL FLUID SUPPLY
[#-- § MY: CONTROL REGULATING AND PROTECTION EQUIPMENT
- (@ P: COOLING WATER PLANT
- (@ Q: UNITISED STATIOM AUX SYSTEMS (EG AIRCHILLED H20 ETC)
-~ [ S:ANCILLARY SYSTEMS
G U: STRUCTURES
G 7: MAINTENANCE LABORATORY AND OFFICE EQUIPMENT
[ HLY02: UNIT 2
[ HLYO4: UNIT 4
- [ HLYOS: UNIT 5
- (@ HLY06: UNIT 6
- (@ HLYCS: COMMON SERVICES
=~ (3 REN: RENEWABLE ENERGY
- (@ RENC: RENEWABLE ENERGY COMMON
- (@ TEK : TEKAPO POWER SCHEME
- (@ TPS : TONGARIRO POWER SCHEME
- (WAL WAIRARAPA GENERATION FACILITIES
- [ WPS : WAIKAREMOANA POWER. SCHEME
(3, Element Searches

HLYO1: UNIT 1

General Child Elements  Attributes  Ports  Analyses  Version
Exduded attributes are hidden.

Filter
Il b |I|Q|E| Name | Value
¥ Actual frequency window 0 MY
¥ ACTUAL MW DEVIATION DETECTED ALARM False
¥ Auniliary MW correction (unit auxiliary MW + station audliary MW porti... |0 MW
<7 DISPATCH ON AUTO MODE False
< Dispatched nett MW setpoint age load setpoint 0 My
¥ Genco disptach FIR (from transpawer) oMW
¥ Genco disptach SIR (from transpawer) 0 My
= (=1 KKS CODE HLYO1
&% MW due to frequency control 0 My
¥ MW SETPOINT DEVIATION DETECTED ALARM False
O Unit gross MW setpoint input 50 MW
O Unit gross MW setpoint output oMW
= & Unit MVAR output 0 MVAR
& Unit MW Nett 0
= & Unit MW output oMW
& Unit Mw 5P oMW




Pl Integrator

Utilises AF hierarchy

Pull in necessary tags

Define interval and data context (eg average, min, max)
Writes data to Generation data warehouse

Data can be scheduled or single load

For us writes to Azure Datawarehouse but there are
other options (Amazon, Microsoft, Oracle, flat file)




Select Data > Modify View > Publish

) Source Assets

w () Search Shape

TR GEPIAF

A

Database Genesis Azsets

D Assets

4 [3) STATIONS
k2 HUNTLY
4 [2) REN: RENEWABLE EMERGY
» () RENC: RENEWABLE ENERGY COMMON
» [ TEK : TEKAPO POWER SCHEME
» [ TPS: TONGARIRO POWER SCHEME
» [2) WAL WAIRARAPA GENERATION FACILITIES
4 [2)WPS : WAIKAREMOANA POWER SCHEME
» [ KTW : KAITAWA POWER STATION
» [3) PRI: PIRIPALA POWER STATION
4 [2) TUI: TUAI POWER STATION
2 TUIZFQ : HYDROLOGY
» [ TUIOT : UNIT 1
F (D TUI0Z : UMIT 2
» [ TUIO3 : UNIT3

» [2) TUIS : TUAI STATION SERVICES

Attributes | Eilter

)

O Select Al

# 15 MINUTE WARNING OF FREQUENCY CONTROL
# DRAINAGE SUMP PURMP 2 WATER LEVEL HIGH -START
 FLOOD PROTECTION DC P/S

 Frequency control MW bias

F FREQUENCY CONTROL ON

& Genco counter #1

 Genco counter #2

# Genco kaitawa FIR

# Genco kaitawa kY

# Genco kaitawa MVAR

 Genco kaitawa MW

 Genco kaitawa rdn

 Genco kaitawa rup

# Genco kaitawa SIR

g eceCceCceCCCCTSTCCCSTC

]

L Asszet Shape

4 [)WPS : WAIKAREMOANA POWER SCHEME
4 [2)KTW : KAITAWA POWER STATION
# KTW Cocling Water Temperatura
#F KTW Cocling Water Temperatura 24 hour average
 ETW Cocling Water Temperature 7 day average
4 [2) PRI: PIRIPAUA POWER STATION
# Tuai Ambient Air Temperature 24 hour maving average
#F Tuai Ambient Air Temperature 7 day maving average
#F Tuai Rainfall 24 hour average
o Tuai Rainfall today
4 [ TUI: TUAI POWER STATION
4 [ TUZFQ : HYDROLOGY
& Kataws Lake Level
o Tuai Surge Chamber Level
# Whakamarino Lake Level
4 [ TUIDT : UNIT1
#F Turbine flow
& Unit MVA
# Unit MVAR output
#F Unit MW output
#F Unit toral current
#F Unit voltage
# Unit winter kennedy pressure
#F Unit winter kennedy turbine flow
4 [ TUID1/B : ELECTRICAL SYSTEMS
4 [2) TUID1/BAT - TRANSFORMER
# T1 oil H2 level
& T1 oil h20 level
# T1 top cil temperature
 T1 winding temperature
a a TUIO1/L - WATER STORAGE INTAKE AND PEMSTOCKS
4 E TUIO1/LPC : PENSTOCK SYSTEM
# Penstock pressure
4 [ TUID1/ME : TURBINE PLANT
a a TUIOT/MEA - TURBIME AND ASSOCIATED EQUIPMENT
4 E TUID1/MEASD : BEARING ASSEMBLIES
#F Bearings oil tamp

# Turbine bearing temp

rE e
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#,n
#,n
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#,n
#,n
F R
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#,n
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#,n
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;x
#,n
#,n
F R
;R
#,n
#,n
F R
;xR
#,n
#,n
F R
F R
#,n
#,n
F R
s -

»' Matches
Found 1 Match

3 @ WPS : WAIKAREMOANA POWER SCHEME



Select Data > Modify View > Publish

4+ Add Column Y Edit Row Filters = Edit Value Mode Start Time End Time
e = e 1/01,16 12:00:00 AM & | : kS
TimeStamp TUIDA_Unit_MVW TUIOT_Unit_MVA  TUIDT_Unit_WMVAr TUI _Unit_Current  TUIOM_Unit_Voltage  TUI0T_Unit_WinterKennedyPressure TUIO1_Unit_WinterkKennedy TurbineFlow TUI01_Unit_TurbineFlow TUID1_Penstock_Pressure TUI01_WicketGates_Position TUID_TurbineBearing_Temperature
1012016 12:00:00 AM 5.007 -5.024 10.986 124737 9.803 10.181 19.563 32.500 41.880
1012016 12:30:00 AM &.018 -7.934 10.986 126.265 9.851 10.181 18.547 32.600 41.686
10172016 1:00:00 AM 7.956 -5.128 10.986 126.083 9.826 10.182 19.550 32800 41.883
1012016 1:30:00 AM 7.987 -5.33 10.986 126.675 9.544 10.182 19.556 32.600 41.679
10172016 2:00:00 AM 7993 -5.588 10.986 127.897 9.364 10.183 19.541 32700 41875
1012016 2:30:00 AM 7.994 -5.734 10.986 125.499 9.866 10183 19.547 32.600 41.827
1012016 3:00:00 AM 7.986 -5.543 10.986 126.949 9.815 10.184 18.552 32.600 41.817
1012016 3:30:00 AM §.062 -5.8611 10.986 127.722 9.8583 10134 19.552 32.5800 41.908
1012016 4:00:00 AM T.aT4 -5.56 10.986 127115 9.681 10185 18.559 32.500 41.698
10172016 4:30:00 AM 7988 -6.582 10.986 127.626 9.897 10.185 19.554 32.400 41.8589
1012016 5:00:00 AM 7.964 -5.736 10.986 126.103 9.809 10186 19.557 32.300 41.879
10172016 5:30:00 AM 7.938 -6.638 10.986 129.189 9345 10.186 19.557 32.500 41.570
1012016 6:00:00 AM 7.937 -11.946 10.886 128.995 9.859 10187 198.551 32.600 41.860
1012016 6:30:00 AM 5.001 -10.778 10.954 126931 9.827 10187 18.554 32.900 41.851
10172016 7:00:00 AM 7842 -11.735 10,919 126.924 9.947 10.185 19.566 33200 41.851
1012016 7-30:00 AM 5.028 -11.01 10915 127.891 9.935 10.188 19.566 33.433 41.857
10172016 5:00:00 AM 8.12 -10.633 10812 128.515 9394 10.189 19.542 34200 41.863
1012016 8:30:00 AM .01 -10.267 10.909 120.424 9.869 10.189 19.552 32.400 41.869
1012016 9:00:00 AM 7.996 -7.659 11.001 126.049 9.547 10.180 18.556 31.8900 41.874
1012016 9:30:00 AM 5.008 -7.575 11.015 125.099 9.547 10.180 19.575 32.000 41.896
1012016 10:00:00 AM 5.035 -5.585 11132 125.630 9.854 10181 19.556 32100 41.817
1012016 10:30:00 AM 7975 -5.73 11.131 125.405 9.914 10191 19.576 32.100 41938
1012016 11:00:00 AM 7.927 -5.208 11.129 125.643 9878 10182 19548 32.059 41.960
1012016 11:30:00 AM 8.039 -6.487 11.050 125771 9.309 10.192 19.557 32300 41981
1012016 12:00:00 PM (7.979 -8.558 11.060 129.486 9.869 10193 18.547 32.400 42002
1012016 12:30:00 PM | 8.053 -5.128 11.052 128.008 9.920 10193 18.554 31.900 42024
10172016 1:00:00 PM 7972 -5.538 11.142 128.222 9.925 10.194 19.552 32.100 42.045
1012016 1:30:00 PM 5.005 -5.553 11.135 129.890 9.8587 10194 19.555 32100 42.067
10172016 2:00:00 PM 8 -5.072 11.128 126.282 9.895 10.194 19.547 32.000 42085
1012016 2:30:00 PM 7.997 -5.046 11121 126.076 9.813 10195 19.571 32.000 42108
1012016 3:00:00 PM 7.958 -2.82T 11.233 125.763 9.564 10.185 18.547 31.700 4213
1012016 3:30:00 PM 7.979 -2.922 11.234 129.059 9.878 10.196 19.561 32100 42152
1012016 4:00000 PM 7.954 -3.021 11.234 128.606 9.896 10196 19.550 31.8900 42173
10172016 4:30:00 PM 7.969 -2.234 11.235 129.986 9.832 10.197 19.564 32500 42195
1012016 5:00000 PM ] -2.201 11.236 128.523 9.838 10197 19.566 32.900 42218
10172016 5:30:00 PM g0 -1.534 11.236 126.545 9.841 10.195 19.551 32700 42238
17012016 6:00:00 PM 7.96 -2.057 11.237 129277 9.863 10.198 19570 32.800 42252
1012016 6:30:00 PM 7.965 -2.3 11.238 127.422 9.802 10199 18.574 32.600 42262




Object Explorer Sl Queryl.sql - ge..energy.co.nz (257)) = x [
#*xk*% Seript for SelectTopNRows command from SSMS  *&ss®®g +
Connect ~ g / P P +
s ¢33 SELECT TOP (1@@8) [Id] -
E= pi.Dispatch_Compliance_Reporting - , [TimeStamp]
£ pi.HLY_CoalAndAshModelling , [TUIe1_Unit_MuW]
[ E== pi.HLY _Fuels ,[TUT@1_Unit_MVA]

® B piHLY_RankineHeatrate , [TUIBL_Unit_MVAr]

@ == piHLY_RankineModelling »[TUT@1 Unit_Current]

. . . . TUI®1l Unit Veltage]
HLY_RiverHeatingModell -[TUT@1 Unit |
— P -rvemEsngliodering ,[TUIel_Unit WinterkKennedyPressure]

= pi.HL‘r’_WEﬁTHER_STA.TION , [TUTel_Unit WinterkKennedyTurbineFlow]

= pi.HLYRankine_Maodelling ,[TUT@1 Unit TurbineFlow]
pi. KTW_Medelling , [TUI®1_Penstock Pressure]
1LPRI_Modellin [ TUIBL WicketGates Position

pi.PRI_Modelling _MWick _Positi
| pi.RIVERTEMPERATUREMODELLIMG ,[TuUIel_TurbineBearing_Temperature]
E= pi.RPO_Brushgeared , [TUIel_GeneratorBearing Temperature]
@ pi.RPO_Modelling ,[TUIel_ThrustBearing_Temperature]

iTEK_MndEIIin ,[TUI@l_Bearings0il_Temperature]

& p.' - . g ,[TUIel_TurbineBearing_XVibration]
= pi.TKA_Modelling ,[TUIel_TurbineBearing_ YVibration]

H #H

[+

pi. TKU_Maodelling

E= pi.TKU_Modelling_Test

pi. TKUD1_Maodes

E=9 pi.TUI_Modelling

= 3 Ceolumns

[Z] Id (bigint, not null)

B TirmeStamp (datetime, null)
[E] TUID1_Unit_MW (float, null)
[E] TUIDT_Unit_MVA (real, null)
[E] TUID1_Unit_MVAr (fleat, null)

100 %

-

,[TUIel_GeneratorBearing XWibration]
, [TUIel_GeneratorBearing_ YWibration]
,[TUIel_Transformer0il H2level]
, [TUIel_Transformer0il_H20Lewvel]
,[TuIel_Transformer0il_TopOilTemperature]
, [TuIel_TransformerWinding Temperature]

, [TUIel_GeneratorStator_Temperaturel]

Results Li'; Messages

= ) Id  TimeStamp TUIDT_Unit_MWY TUIDT _Unit_MVA  TLIO0T_Unit_MVAr TUIDT _Unit_Cumert  TUIOT_Unit_Voltage  TUIDT_Unit_WinterkennedyPressure  TUIL ~
g Iﬂ:gl-ﬁ"f:—\f”;e”t ('Ea:f ”“::J 1 20160101 00:00:00.000 8.006667137146  NULL -8.02396392822266  NULL 10.98629 1247375 9.80
- -Unit_Veltage (real, null) 2 27 2016010100:30:00000 8.01835250854492 NULL 7.93408918380737  NULL 10.9863 126.265 9.85
[E] TUID1_Unit_WinterKennedyPressure (real, null)
. o . 3 3 2016010101:00:00.000 798533091964722 NUILL -8.12808227539063  NULL 10.98631 126.0832 9.82
[E] TUID1_Unit_WinterKennedyTurbineFlow (real, null
] Tulo1_Uni . 4 4 2016010101:30:00000 7.98651266098022 NUILL -8.33005142211914  NULL 10.98631 1286747 9.4
= _Unit_TurbineFlow (real, null)
=] TUIOT_Penstock Pressure (real, null) 5 5 20160101 02:00:00.000 7.99331665039063 NULL -8.53936006164551  NULL 10.98632 127.8968 9.86
=] TUIOT WicketGates Position (real, null 6 6  2016010102:30:00000 7.99444532334409 NULL -87335262298584  NULL 10.98633 125.4995 9.86
=] TUIOT TurbineBearing_Temperature (real, null) 7 7 2016010103:00:00000 7.98563861846524 NULL -8.8478M58709717  NULL 10.98634 126.5487 9.81
=] TUIDT_GeneratorBearing_Temperature (real, null 8 8  2016010103:30:00.000 8.06240653991699 NUILL -8.81133937835693  NULL 10.98635 127.7219 9.88
] TUIDT_ThrustBearing_Temperature (real, null) 9 9 2016010104:00:00000 7.97382164001465 NULL -8.86044216156006  NULL 10.98635 127.1146 9.88
=] TUID1_BearingsQil_Temperature (real, null) 10 10 2016-01-0104:30:00.000 7.98819303512573  NULL -8.88173866271973  NULL 10.98636 127.6265 9.89
=] TUIDI_TurbineBearing_XVibration (real, null) 11 11 20160101 05:00:00.000 7.96359491348267 NULL -8.73585891723633  NULL 10.98637 126.1029 9.90
=] TUIDI_TurbineBearing_YVibration (real, null) 12 12 2016-01-0105:30:00.000 7.33758535385132  NULL -8.63767719268739  NULL 10.98638 129.1888 9.84
[E] TUID1_GeneratorBearing_XVibration (real, null) 13 13 20160101 06:00:00.000 7.93740510940552 NULL -11.9456214904785  NULL 10.88606 128.9955 9.85
[E] TUI01_GeneratorBearing YVibration (real, null) 14 14 20160101 06:30:00.000  8.00050735473633  NULL -10.7779397964478  NULL 10.95437 128.9307 9.82
E] TUI01 TransformerOil_H2Level (real, null) 15 15 20160101 070000000 754243238040161 NULL 1734959602356 NULL 1091854 126.9245 994
[E] TUI0T TransformerQil H20Level (real, null) 16 16 2016010107:30.00.000 8.02752453765869 NULL 11.0102958679199  NULL 1091531 127.8907 9.93
(E] TUI0T TransformerOil_TopQilTemperature (real, 17 17 201601-0108:00:00.000 B8.11966896057129 NULL -10.6327905654907  NULL 10.91198 1288177 9.89
(E] TUI0T TransformerWinding_Temperature (real, nt 18 18 20160107108:30.00.000 B8.01126670837402 NULL 10.2672309875488  NULL 10.90865 129.424 9.86
=] TUID1_GeneratorStator_Temperature] (real, null) - P Tl T oo e P, ———
4 3

=] TUIDT_GeneratorStator_Temperature? (real, null)



Artificial Intelligence, Machine Learning,

Predictive Analytics

« Artificial intelligence (Al) - Ability to make decisions
through interpreting information

* Machine Learning — fancy name for data science.
Learning from data to create a relationship/algorithm.
Think y = mx + c. Is a subset of Al

 Predictive Analytics — Genesis Energy take on machine
learning focused on enhancing our maintenance
management

Requirements

« Data warehouse/historian — key

» Other data possibilities — CMMS, software diagnostics,
market data, weather

« ‘Sandbox’/platform to model data/develop algorithms

% “

Text generation

Question answering <,

Context extraction

Classification

Machine transiation

Deep leaming

Unsupervised <

Expert systems

Speech to text

Text to speech

Image
Mac

recognition <

hine

vision

Machine learning

Supervised

Natural language processing

-

Speech

Vision
Planning

Robotics




Predictive Analytics

— Proactively monitoring asset health to reduce cost and increase plant reliability

& Hard Limit
—Expected
| — A CtU3I
Benefits/Targets
Reduced Preventative Maintenance Reduced Defects Reduced Forced Outages
Moving from Calendar based to Picking up on defects before they Picking up on issues before they
Analytics triggered escalate. escalate to forced outages.

It is not...

Event causing the failure The P-F ] )
(rotage relted) \_ "" Interval

==

—

* Replacing DCS/SCADA alarming

* Real time alerting

(Resistance to Stress)

Performance or Condition

TiME

Figure1: The P-F Curve



Pl Historian example of tracking Stator Temp e

— Can you spot the asset health issue?




Pl Integrator

Select Data » Modify View » Publish

) Source Assets “  (7) Search Shape  Matches

Serves Asset 5h Found 1 Match

' d Pl Integrator makes the
Database 4 [2) WPS : WAIKAREMOANA POWER SCHEME #£ X~ » [D)WPS: WAIKAREMOANA FOWER SCHEME
Genesis Assets ooy
4 () KTW : KAITAWA POWER STATION £ .

Assets
’ P — ,x data accessible for
4 Q) STATIONS # KTW Cooling Water Temperature 24 hour svarage £x

» ) HUNTLY & KTV Cocling Water Temperature 7 day average L an al ti C S i n O u r to O |
4 () REN: RENEWABLE ENERGY 4 [ PRI FIRIPAUA POWER STATION e y

» E RENC: RENEWABLE ENERGY COMMON

# Tuzi Ambiznt Air Temparsture 24 hour moving average X

» () TEK : TEKAPO POWER SCHEME # Tuai Ambient Air Temperature 7 day moving average Fx

» () TPS: TONGARIRO POWER SCHEME # Tuai Rainfall 24 hour average £x

» g WAI- WAIRARAPA GENERATION FACILITIES #F Tuai Rainfall today £ x

4 () WPS : WAIKAREMOANA POWER SCHEME 4 2 TUI: TUAI POWER STATION ,x

» () KTW: KAITAWA POWER STATION 4 [ TUYZFQ - HYDROLOGY £ x

» 51 PRI - PIRIPAUA FOWER STATION # Kaitawa Lake Level ,x

4 () TUI: TUAI POWER STATION # Tuai Surge Chamber Level ,x

) TUYZFQ : HYDROLOGY @ Whakamaring Lake Level ,x

» 2 TUIOT : UNIT 1 4 @ TUIOT :UNIT1 £x

» ©TUI0Z: UNIT2 & Turbine flow £x

» ETUIE : UNIT 3 & Unit VA ,x

» () TUIS: TUAI STATION SERVICES | # Unit MVAR output £x

# Unit MW output Fx

I # Unit total current sx

ATUDUIES | Fcer x # Unit vohage #x

_—  Unit winter kennedy pressure £ x

4P Unit winter kennedy turbine flow S x

# 15 MINUTE WARNING OF FREQUENCY CONTROL o - 4 € TUID1/B: ELECTRICAL SYSTEMS £

# DRAINAGE SUMP PUMP 2 WATER LEVEL HIGH -START ] 4 () TUIO1/BAT - TRANSFORMER £ x

& FLOOD PROTECTION DC P/S o & T1 il 2 level rEs

& Frequency control MW biss L] & T1 oil 20 level %

# FREQUENCY CONTROL ON ° # T1 top il temperature s

# Genco couner #1 o & T1 winding temperzture ’x

# Genco counter #2 = 4 (2 TUIDT/L : WATER STORAGE INTAKE AND PENSTOCKS £ x

# Genca kaitawa FIR = 4 () TUIDY/LPC : PENSTOCK SYSTEM ,x

# Genco kaitawa kv o # Penztock pressurs X

# Genco kafiawa MVAR o 4 () TUIDT/ME : TURBINE PLANT ,x

# Genco kaitawa MW o 4 {3 TUIDT/MEA : TURBINE AND ASSOCIATED EQUIPMENT s

# Genca kaftawa rdn e 4 (2 TUIO1/MEASD : BEARING ASSEMBLIES £x

# Genca kzitzwa rup ° & Bearings il semp £x
# Genco kaiawa SIR L1}

- # Turbine bearing temp £x v



Our In-house Tool

Pl tag:TUI02 GeneratorStator Temperature1 with Train-MAPE:MNA Forecast-MAPE:0.038 Train-RSquare:0.759 and Forecast-RSquare:0.85

Ability to select
input variables,
remove unrelated
data (eg plant in
outage), training
periods and

e fOrecasting check

~ ™ to validate model

201707 201801 201807 201801



Generator Stator Temperature

40

201801

201807

Legend
—— Actusl
—— Alert

—— Forscast

—— Train

% “

This shows an
example of a
training period
(blue), forecasted
period (orange)
with a good
model fit (3.8%
error)



709

Generator Stator Temperature — With Model @

Pl tag:TUI02 GeneratorStator_ Temperature1 with Forecast MAPE = 0.064 and RSquare = 0.622

Feb 15

Legend
—— Actusl
—— Alert

—* Forecast

This is the start of the
divergence of the actual
temperature to the
model.

They both start out in
sync then the actual
temperature starts to
rise.



Generator Stator Temperature — With Model @

Pl tag:TUI02_GeneratorStator_Temperature? with Forecast MAPE = 0.064 and RSquare = 0.622

801

60

401

Apr 23 May 05

Here the issue was
resolved. There was a
particularly blocked
air filter which meant
cooling was limited.

Legend

~ = Post repair you can

—~=gsee the model and
actual match well
again



Lower Guide Bearing Temperature — Actual Data

eeeeee

% “

Actual data
prior to
modelling



Lower Guide Bearing Temperature

Pl tag:KTW06_LowerGuideBearing Temperature with Train-MAPE:0.003 Forecast-MAPE:0.037 Train-RSquare:1 and Forecast-RSquare:0.97

This shows an
example of a training
period (blue),
__ forecasted period
:gmu (orange), actual
:mm sensor data (grey)
" and alerting (red

highlights)

40

201

200707 201801 201807 201801 200507



How to Manage Multiple Models — Power Bl

—— — summarises the Current mo =
o 25/05/2019  20/06/2019 20/06/2019 3:30:00 am.
Active Models
]
Alarm Multiplier Model DESCRIFTION ML Model Error  Online MAPE  Online MAPE  Online MAPE  Online MAPE  Online MAPE A
Method -1D -3D -1W -2W -M
1.7 -
KTW06_BAT TransformerCilTemp_fromMWandambienttemp RF-30 14.5% 12.9% 168.5% 15.2% 19.3% 20.4%
Station O KTWO06_BAT TransformerWindingTemp_FromMWandambientTemp RF-30 14.9% 14.0% 14.3% 13.5% 16.7% 17.4%
KTW KTWO06_ME_TurbineBearing_VibrationCalibration RF-30 8.8% 6.5% 8.0% 8.8% 9.2% 9.5%
PRI KTW06_ME_TurbineBearing_XVibrationfromMW RF-30 7.5% 5.9% 7.0% 8.4% 8.5% 8.7%
RPO Equipment KTWO06_ME_TurbineBearing_YVibrationfromMW RF-30 11.9% 5.5% 7.0% 9.6% 10.7% 11.5%
TKA BAC KTWO06_ME_TurbineBearing_YVibrationfromotherbearings RF-30 9.5% 7.3% 76% 83% 9.0% 10.2%
TKE BAT KTW06_ME_TurbingBearing_XVibrationfromotherbearings RF-30 8.0% T.1% 8.7% 9.7% 9.6% 10.6%
TKU ME KTWO06_MK_GeneratorStator_Temp1from2 Lh-2 0.5% 0.4% 043% 04% 0.5% 0.5%
TUI MK KTW06_MK_GeneratorStator_Temp1fromMWandStatorcoolairtemp RF-20 3.8% 1.1% 24% 3.0% 34% 34%
Unit KTWO06_MK_GeneratorStator_Temp3fromd LM-2 0.4% 0.4% 0.4% 04% 0.5% 0.5%
n KTW06_MK_GeneratorStator_Temp3fromMWandstatorcoolairtemp RF-30 3T7% 1.2% 2.5% 3.3% 3.5% 34%
KTWO06_MK_GeneratorStator_Temp5fromb Lh-2 1.5% 0.6% 0.7% 0.8% 0.9% 1.0%
Plant KTW06_MK_GeneratorStator_Temp5SfromMWandStatorcoolairtemp RF-20 3.6% 1.0% 2.3% 31% 34% 34%
KTWO06 KTWO06_MK_GeneratorStator_WarmairTempfromCoolairtempand MW RF-30 21% 0.7% 1.3% 1.5% 1.5% 14%
KTWO07 KTW06_MK_LowerGuideBearing_Tempfromotherbearings RF-50 2.3% 6.6% 6.4% 6.3% 6.1% 5.5%
PRIO4 KTW06_MK_LowerGuideBearing_VibrationCalibration LM-3 1% | 218%  216%|  21a% 204% 10.4%
PRIOS KTWO0B_MK_LowerGuideBearing_XVibrationfromotherbearings RF-20 79% 26.3% 247% 23.4% 223%
RPOOS KTWOB_MK_ThrustBearing_Temp I fromatherbearings RF-50 172 S sge 00 B0% s 5.1% j
ROANA KTWO06_MK_ThrustBearing_Tempcalibration L-3 1.3% 0.2% 0.5% 0.7% 0.8% 0.7%
Input Tags: | Day | KTW_CoolingWater_Temperature | KTW_CoclingWater_Temperature_24HourAverage | KTW_CoolingWaterTemperature | KTW06_Generator_CoolAirTemperature | KTWO06_GeneratorStator_Temperature2 | KTWOiA
! 1 ! ! ! ! -
< >
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Generator temperature example from before
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Alarm Multiplier Model DESCRIPTICM ML Model Error  Online MAPE  Online MAPE  Online MAPE  Online MAPE  Online MAPE
Methad 1D -3D S1wW 2w -1M
2.0 =
Station O
H u
Equipment
BAT
ME
MK . . _
TUID2_MK_GeneratorStator_TemperatureTfromMW, MVAR AmbientTem perature LM-3 34% 08% 343 8% 120 [
Plant
TUIDT
M Tui2
TUIO3
Input Tags: TUI_PowerStation_Temperature | TUI02_Unit_MVA | TUIDZ_Unit_MW ~ | MW Display
W
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Achievements so far

» Since March built 550+ models

This has been developed with 50% FTE and predominately internal resource costs
28 validated asset health deteriorations/performance monitoring

Good engineering buy in for ones that have been involved with an issue

Have a large backlog of potential models still to create



Going Forward

* Proven in-house platform is viable and working for us

« Aiming for 1000 models in year 1 based on most critical
assets, historical failures and current work stream of
maintenance reviews

 Building the business process on how to manage Model
‘alerts’ and cultural engagement

* Engaging the Engineering and Operations teams

» Confidence that modelling can replace time based
maintenance

« Install more sensors to capture data and fill current
data/modelling gaps
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