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Introduction
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. .
Intro into Operations

8%
= Wants to drive and enable operations

= Deep expertise in engineering
= Wants trusted, purpose built and reliable
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. | Intro to IT

= Deep expertise in info systems
= Focused on digital transformation
- = Early adopter of new technology
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Challenges of Integrating OT & IT Data

OT data is from a variety of
dynamic sources

OT data is variable,
continuous and time based

OT data requires context to
compare fleets of assets

v’ The Pl System standardizes &
normalizes OT data

v Operations data needs to be
prepared for use in IT tools

v' Data Management with AF/EF
& PI Integrator reduces time &
complexity of analysis
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Time-series Data is Not Naturally Aligned or Contextualized
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Extending Your Opportunity
Bring Operations Insights to the Enterprise

Operations IT
..........

rreroerTyYEY
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An ERP is not suited to operate your plant,
a Pl System is not suited to be your ERP

It's a better together story...
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Cloud Strategy
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What Technologies are Needed for Enterprise
Analytics?
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It's a better together story...

OSlsoft has a multi-cloud strategy designed for
repeatable patterns with major cloud vendors

adWws @
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Repeatable Patterns for Extending into Cloud

An Enterprise Data Management & Integration strategy Is
necessary for success
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Advanced Analytics
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Success When Used to Augment Decisions

Greater Operational Enhanced Ability to Better Environmental
Efficiency Prevent Costly Failures Protection

(5 )

W e P
P/ ) ,/Q /’V

8

Henkel (with pmOne) predict Invenergy (with SparkCognition) United Utilities proved an ability

when a transition occurs for | predict catastrophic gearbox to accurately predict
an exothermic reaction, saving | failures at least one month in = combined sewer overflows 6
5% of process time. advance. hours before an incident.
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https://www.osisoft.com/Presentations/Prediction-of-In-Process-Quality/
https://www.osisoft.com/Presentations/Industrial-Intelligence--Artificial-Intelligence-in-Action/
https://www.osisoft.com/Presentations/Prediction-of-Combined-Sewer-Overflow-Chamber-Water-Levels-using-Rainfall-Forecasts/

Five Considerations Before Starting with Advanced Analytics

Gaps in data collection
Poor data quality

Low # of modes
Unknown relationships
Natural skepticism




How does the Pl Integrator help you with these obstacles?

Gaps in data collection
Poor data quality

Low # of modes
Unknown relationships
Natural skepticism




How do you reduce
the uncertainty of
what can be achieved
with advanced analytics ?

Perth Seminar 2019 © Copyright 2019 OSlsoft, LLC




Adopt Iterative Workflows that Include SMEs

... and use technology that support these workflows

Discover Explore Implement
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Discover
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Select Data > Modify View > Publish Next
+ Add Column Y Edit Row Filters Edit Value Mode Start Time End Time
e e = K |
Wind Turbine TimeStamp Day of the Week  Aclive Power ~ Apparent Power  Bearing A Temperature  Capacily  Rotor Speed DperatiEI
GEO1 3/18/2019 10:52:57.477 AM Monday 1,517.787 1,523.764 42523 62831 19.927 90.403
GEO1 3/18/2019 10:53:57.477 AM | Monday 1,518.78 1,517.996 42,515 62877 2039 90.421
GED1 3/18/2019 10:54:57.477 AM Monday 1,528.438 1,527.098 42.507 62924 19.877 90.44 .
GEO1 3/18/2019 10:55:57.477 AM  ; Monday 1,524.599 1,525.12 42.498 62.97 20.002 90.459 D IS Cove r
GEO1 3/18/2019 10:56:57.477 AM Monday 1,521.875 1521751 42.49 63016  19.913 90.478
GEO1 3/18/2019 105757477 AM | Monday 1,525,674 1531629 42.481 63083  19.726 90.497
GEO1 3/18/2019 10:58:57.477 AM | Monday 1,535.935 1,536.558 42.473 63109 20.013 90.515
GEO1 3/18/2019 10:59:57.477 AM Monday 1,517.37 1,519.13 42.465 63155  20.232 90.535 . .
GEO1 3/18/2019 11:00.57.477 AM | Monday 1,528.547 1,529 658 42.456 63202  20.065 90.554 Data pre para“on Capab| I ities th at accele rate
GEO1 3/18/2019 11:01:57.477 AM  Monday 1,529.736 1,524.135 42.448 63.245  19.922 90.573 tra| n | ng a|gO I’I'[h ms or Creatl ng V|eWS fOI‘ Bl
GEO1 3/18/2019 11:02:57.477 AM; Monday 1,517.794 1,525.652 42.439 63.294  19.955 90.592
GEO1 3/18/2019 11:03:57.477 AM | Monday 1,505.852 1512247 42.431 63341 19.708 90.61 Too I S:
GEO1 3/18/2019 11:04.57.477 AM | Monday 1,519.556 1,521.107 42.423 63.387  20.054 90.627
GEO1 3/18/2019 11:05:57.477 AM ; Monday 1,519.952 1,523.781 42.414 63433 20.173 90.644
GEO1 3/18/2019 11:06.57. 477 AM  Monday 1,523,877 1,508 615 42.406 63.48 19.949 90.662
GEO1 3/18/2019 11:07:57.477 AM | Monday 1,533.151 1532751 42.397 63526  19.94 90.68 « Common nomenCIature
GEO1 3/18/2019 11:08:57.477 AM | Monday 1,525.437 1,526.634 42.389 63572  19.999 90.698
GEO1 3/18/2019 11:09:57.477 AM  Monday 1,523.269 1,518.825 42.381 63619 19.862 90.716
GEO1 3/18/2019 11:10.57.477 AM | Monday 1,522 443 1,522 936 42.372 63665  20.009 90.733 . AI |g n ed d ata
GEO1 3/18/2019 11:11:57.477 AM Monday 1,509.033 1,522.19 42.364 63.712  19.83 90.75
GEO1 3/18/2019 11:12:57.477 AM ; Monday 1,524.965 1,525.264 42.355 63.755  20.008 90.767
GEO1 3/18/2019 11:13:57.477 AM | Monday 1.511.918 1,508 629 42.347 63804  19.621 90.784 N Norma“zed measurements across assets
GEO1 3/18/2019 11:14:57.477 AM | Monday 1,519.61 1523 788 42.339 63851  19.749 90.801
GEO1 3/18/2019 11:15:57.477 AM | Monday 1,526.237 1,524.405 42.33 63.397  19.949 90.818
GEO1 3/18/2019 11:16:57.477 AM  Monday 1,532.863 1,525.036 42.322 63.943  19.886 90.835 . .
GED1 3/18/2019 111757477 AM | Monday 1,509 635 1515866 42313 6399 19 921 90.855 J Com pleX f| Ite” ng by
GED1 3/18/2019 11:18:57.477 AM Monday 1,522,636 1,525.022 42.305 64036  19.992 90.876
GEO1 3/18/2019 11:19:57.477 AM ; Monday 1,518.829 1,519.512 42.296 64.082  20.067 90.893 * Asset type
GEO1 3/18/2019 11:20.57. 477 AM | Monday 1,527.32 1,526 332 42.288 64129 20.043 90.91
GEO1 3/18/2019 11:21:57.477 AM | Monday 1,515.018 1,516 249 42.28 64175  19.828 90.926 + Event type
GEO1 3/18/2019 11:22:57.477 AM | Monday 1,506.233 1,506.149 42.271 64221  19.684 90.943
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Select Data > Modify View > Publish

Select Data > Modify View > Publish

Begin from common

E=s DFPIAFSERVERPRD v s
. .
O . © ET S — . nomenclature & hierarchy
() Assets
Database Power Generation oo
4 (@ Generation -

» () Equipment List

Discover

» (D Fossil Generating Station
» (D Matador 1 CCGT
» (D OSlIsoft Power

Pick from measurements
that shape the model or view

» (D PowerCo

-

» (D) Solar Power Generation Fleet

4 (@ wind Power Generation Fleet

Edit Filters x

» (D Big Buffalo Wind Farm

4 (D Black Mesa wind Farm OA N
sset Name .
© ceon = | Filter based on
S similar assets
) GEO3 ¢ Asset Template [ | Search Derived Templates
) GE04 wind Turbine v
| © oeos ("] Asset Category
wind Turbine v
() Add Filter

O Select All #58

L =R

» 4 Active Power (i}
& Apparent Power (i} # Blade3, Set Value
& Apparent Power (calc) (i ] 4 Capacity
BatchWindBinFilter (i) ircul
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Create New Event Frame Row Filter x

Event Tempiste | [ Wind Curtaiiment - x | ShapeTres
» "3 GEO1 20190306 123116 © | Retated Shape Asset is any @ wind Turbine

Drag an element from the Shape Tree ko specify
» “d GEOY 2019-03-06 1231116

» 4 GEO1 2010.03.06 123116

» 4 GEO1 20190306 123116

» " GEO1 2010-0306 12:31:16
» " GEO1 2019-03-06 1231:16

» 4 GEO1 2015-03-06 123116

» "4 GEO1 20190306 123116 H
) Create New Event Frame Row Filter x
» " GEO1 2019-03-06 123116
» “i GEO1 2019-03-06 123116
+ o GEY 2019-03.05 234232 | T | Enter Event name or string match p: \ Event Template ¥ \ | Wind Curtailment A o Shape Tree
*d GEO1 2019-03-06 23:42:32 .
: “ m’: Zo:gmm . » "4 GEO1 2019-03-06 12:31:16 Related Shape Asset is any @ wind Turbine D I S C Ove r
» prerar—— ] Drag an element from the Shape Tree to specify
¥ RO 201303 00 200282 » "4 GEO1 2019-03-06 12:31:16
» "4 GEO1 2019-03-06 23:42.32
b % GEDT 20190306 2842K2 » "4 GEO1 2019-03-06 12:31:16 Add Event Condition
R »_FH BENT 2018-03-06 1223114

» " GEOT 20190306 23.42:32
» " GEO1 2010-03-06 23:42:32

Select all data from a

» "4 GEOZ 2015-03-06 115646

» " GEO2 20190306 11:56:46 . partICl_"ar event type

Event Frame Related Asset Start Time End Time

GEO06 2018-08-15 194321 GEO6 8/15/2018 74321 PM 12/31/9939 11:5959 PM -

GEO6 2018-08-15 19:43:21 GEO6 8/15/2018 T°43:21 PM 12/31/9999 11:59°58 PM

GEO06 2016-08-15 19:43:21 GEO6 81572018 T43:21 PM 12/31/9989 11:55°59 PM

GEO06 2015-08-15 19:43:21 GEO06 8/15/2018 T43:21 PM 12/31/9999 11:59°59 P

GEO6 2018-08-15 19:43.21 GEO6 8152018 T43:21 PM 12/31/9999 11 5688

GEOG 2016-08-15 13:43:21 GEG. 8/15/2018 T:43:21 PM 123150880l S8 58P Event Frame Related Asset Start Time End Time

GO0 Z0IB-08-15 19,4321 ceos B/182015 74321 PM S GEO6 2018-08-15 19:43:21 GE06 8/15/2018 7:43:21 Pl 12/31/9999 11:59:59 PM -
GE06 2018-08-15 19.43.21 GEOB 81572018 T43:21 PM 12/31/9999 11.:59:59 PM

GEO6 20190306 113152 GEs 62019 113152 Al Lo GEDG 2018-08-15 19:43-21 GEDG 8/15/2018 74321 PM 12/31/9999 11:59°59 PM
GEO 207150506 11:31:52 . M1 11 S S GEOG 2018-08-15 19:43:21 GEO6 8/15/2018 74321 PM 12/31/9999 11°59°59 P
GEO06 2019-03-06 11:31:52 GEOB 362030015952 AM 3/6/2019 114137 AM

GE0B 2019-08-06 113152 GE06 612019 113152 Al Seanie 4 GEOG 2018-08-15 19:43:21 GEO6 8/15/2018 7-43:21 PM 12/31/9999 11:59°59 PM
GEOR 2010-03-06 113152 GE0S SO 1:31:52 A S GE062018-08-15 19:43:21 GE0G §/15/2018 7:43:21 PM 12/31/9999 11:59:59 PM
GEOE 2019-03-06 11:31:52 GEO6 362019 11:31.52 AM 3/6/2019 11:41:37 AM

GEOB 2019-03-06 11:31:52 GE0S /62019903152 A S62019 1141 9 A GEO6 2018-08-15 19:43:21 GE06 8/15/2018 7:43:21 PM 12/31/9999 11:59:59 PM
ISE05 207,00 0O/ 152 (€21 RIS 152 O SR GEQG 2018-08-15 19:43:21 GE06 8/15/2018 7:43:21 PM 12/31/9999 11:59:59 PM
GEO0Z2 2019-03-06 11:56:46 GE02 3/6/2019 11°:56°46 AM 3/6/2019 12°:06:46 PM

GEC? 20190306 11:56:46 GE02 612018 1:56:45 Al SRl ek ey GEOB 2018-08-15 19:43:21 GEDG 8/15/2018 7:43:21 PM 12/31/9999 11:59:59 PM
GEOZ 20150506 11:56:45 e VE2019 15546 AM 362019 12055 GEQS 2019-03-06 11:31.52 GEDS 362019 11.31.52 AM 3/6/2019 11:41:37 AM
GEO02 2019-03-06 11:56:46 GE02 /62019 11:56.46 AM 36/2019 120646 PM

GEOZ 2013-03-06 11:56:46 GE02 /672019 11.56:46 AM 62019120646 PM 200200112162 S0 AEANAOALIIEI AL AELAOAOAIAAZT AN
GE02 2019-03-06 11:.56.46 GEO2 3/6/2019 11.56.46 AM 362019 12.06.46 PM - -

cote 115088 5600 cere B a2 120048 Quickly preview events

GEOQ2 2019-03-06 11:56:46 GEO02 3/6/2019 11:56:46 AM 3/6/2019 1206 46 PM

£ on1a s 11-56 a8 e g 11-58-40 ans k110 190645 Bt fter pplylng fl|tel‘
. 3 a a
Save Event Frame Row Filter

@ OSlsoft, Perth Seminar 2019 © Copyright 2019 OSlsoft, LLC
»




Row Filters

Event Row Filter 1

Add New Row Filter

Criteria 1: Match Event Frames where String

Event Template = Wind Curtailment
Related Shape Asset is any

Digital

Add Nimerie Raw Filtar
Row Filters

® Inclu

Incly | Mumeric Filter 1 S -

Include rows where all of these conditions are

Bearin true

Bearing A Temperature >-273.15

+ Ad¢  Event Row Filter 1

Criteria 1: Match Event Frames where
Event Template = Wind Curtailment
Related Shape Asset is any

Include rows based on whether the contents of a column
match a string pattern

Include rows based on whether the contents of a column
contain certain digital values

w | L

Add New Row Filter

String Include rows based on whether the contents of a column
match a string pattern
Digital Include rows based on whether the contents of a column
contain certain digital values
Numeric Include rows based on whether the contents of a column
contain certain numeric values
Include rows where the contents of a column contain a
Null Values
value
Include rows where certain Event Frames are active
Event Frame

Discover

Include multiple
filters to clean
data

Close

Perth Seminar 2019
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Discover

Find all operational data —
associated with all curtailment events

Remove outliers
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Select Data > Modify View > Publish Next
+ Add Column Y Edit Row Filters Edit Value Mode Start Time End Time
e e = K |
Wind Turbine TimeStamp Day of the Week  Active Power  Apparent Power  Bearing A Temperature  Capacity  Rotor Speed DperatiEI
GEO1 3/18/2019 10:52:57.477T AM | Monday 1,517,787 1,523.764 42,523 62.831 19.927 90.403
GED1 3/18/2019 10:53:57.477 AM | Monday 1518.78 1.517.996 42,515 62877 2039 90.421
GEO1 3/18/2019 10:54:57.477 AM Monday 1,528 438 1,527.098 42,507 62924  19.877 90.44 .
GEO1 3/18/2019 10:55:57.477T AM Monday 1,524 599 1,525.12 42.498 62.97 20.002 90.459 D |S Cove r
GEO1 3/18/2019 10:56:57.477 AM | Monday 1521875 1.521.751 42.49 63016 19.913 90.478
GED1 3/18/2019 10:57°57.477 AM | Monday 1,525.674 1,531,629 42.481 63063  19.726 90.497
GEO1 3/18/2019 10:58:57.477T AM _ Monday 1,535.935 1,536.558 42.473 63109 20.013 90,516
GEO1 3/18/2019 10:59:57.477 AM | Monday 1517.37 1,519.13 42.465 63155 20232 90.535 . .
AMBIZ0°9 110057 4T7 AM Monday ises isees 424 o322 20065 s0sse Operational data of an asset that is usable by
GEO1 3/18/2019 11:01:57477 AWM Monday 1,529 736 1,524,135 42.448 63248 19.922 90.573 algorith ms or B I TOOISI |
GEO1 3/18/2019 11:02:57477 AM Monday 1,517 794 1,525.652 42.439 63294  19.955 90,592 .
GEO1 3/18/2019 11:03:57477 AM | Monday 1,505 852 1.512.247 42.431 63.341 19.708 90.61
GEO1 3/18/2019 11:04:57 477 AM | Monday 1,519 656 1,521.107 42.423 63387 20054 90.627
GEO1 3/18/2019 11:05:57.477 AM Monday 1,519.952 1,523.781 42.414 63433 20173 90.644 o Asset ConteXt
GEO1 3/18/2019 11:06:57477 AM | Monday 1,523 877 1,508.615 42 406 63.48 19.949 90.662
GED1 3/18/2019 11:07°57.477 AM | Monday 1,533.151 1,532.751 42.397 63526  19.94 90.68
GEO1 3/18/2019 11:08:57477 AM Monday 1,525 437 1,526.634 42.389 63572 19.999 90,696 . Data AI |g nment
GEO1 3/18/2019 11:09:57.477 AM | Monday 1,523 269 1,518.825 42.381 63619  19.862 90.716
GED1 3/18/2019 11:10:57.477 AM | Monday 1,522 443 1,522,936 42,372 63665 20009 90,733 1
GEO1 3/18/2019 11:11:57.477 AM  Monday 1,509,033 1,522.19 42.364 63712 1963 90.75 . .
GEO1 3/18/2019 111257477 AM Monday 1,524 965 1525264 42,355 63758 20008 90.767 o Asset N Ormal Ization
GEO1 3/18/2019 111357477 AM | Monday 1511.918 1,508.629 42,347 63.804  19.621 90.784
GED1 3/18/2019 111457477 AM | Monday 1,519.61 1,523.788 42.339 63.851 19.749 90.801
GEO 3/18/2019 11:15:57.477 AM  Monday 1,526.237 1,524.405 42.33 3.897 19.949 90.815 ° F | |te red on a C u rtai I me nt Eve nt Type
GEO1 3/18/2019 1M1:16:57.477 AM | Monday 1,532,863 1,525.036 42.322 63943 19.886 90,835
GED1 3/18/2019 111757477 AM | Monday 1,509 635 1,515.866 42.313 63.99 19.921 90.855
GEO1 3/18/2019 111857477 AWM Monday 1,522 636 1,525.022 42.306 64036  19.992 90.876 .
GEO1 3/18/2019 111957477 AM Monday 1,518 829 1,519.512 42.296 64082  20.067 90,323 ° Fllte red for T > '273 . 15 C
GEO1 3/18/2019 11:2057477 AM | Monday 1,527.32 1,526.332 42.288 64129 20.043 90.91
GED1 3/18/2019 11:21°57.477 AM | Monday 1,515.018 1,516.249 42.28 64175  19.828 90.926
GEO1 3/18/2019 11:22:57477 AM Monday 1,506 233 1,506.149 42.271 64221 19.684 90,943
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e LK_WindFarm

= Discover

Select Data » Modify View > Publish

Target Configuration Summary
Westeros v Shape and Matches
» There are 75 Matching Instances Select Where yOU
Run Mode Timeframe and Interval Want to pu bIlSh
Run Once « Your Start Time is *-1d
® Run on a Schedule : :gziﬁ:g:xz:a:gets an interpolated measurement Every 1 H b |k
it R minute One-time bulk or
| incrementally

Publish
Cecur vy 5] it push

Benefit from native integration to
AWS, Azure, Hadoop, and SAP HANA

@ OSlsoft, Perth Seminar 2019 © Copyright 2019 OSlsoft, LLC



SelectData > Modify View > Publish

"4 Source Events

Server

Database

% " Search Shape

DFPIAFSERVERPRD

"8 Event Shape

v

Power Generation

oy

-

»

v

-

-

-

-

v

v

Event Frames A

@ GE012017-01-01 18

15
4 GEO12017-01-01 13:14:15
4 GEO12017-01-01 13:14:15
¥4 GEO12017-01-01 1314115
¥4 GEO12017-01-01 13:14:15
" GEO12017-01-01 13:14:15
" GEO12017-01-01 13:14:15
"4 GEO12017-01-01 13:14:15

"4 GE012017-01-01 13:14:15
Show More

KD Wind Turbine

Attributes | Filter

OSelect All

3

3

3

4 Active Power

@ Apparent Power

4 Apparent Power (calc)
BatchwindBinFilter

4 Bearing A Temperature
& Bearing B Temperature
4 Bearing Shaft Temperature
Blade 1 Error

Blade 2 Error

[=/Blade 3 Eror

Blade Total Error

# Blade, Actual Value
& Blade1, Set Value

4 Blade2, Actual Value
4 Blade2, Set Value

4 Blade3 Actual Value.

2 00 C PO OCROCQOQRCRRQCQ

4 4 windeiifsilment

v

v

 Matches Server
Found 100+ Matches
Database
& x » "4 GEO9 7010
& x » "8 GE09 010
£ x » "4 GED9 010 Y

Attributes

O Select All

» P Active Power

4 Appatent Power

& Apparent Power (e

BatchwindBinFilter

& Bearing B Tempera

& Bearing A Tempera

"4 Source Events v

DFPIAFSERVERPRD v

[#]
-

Power Generation

"4 Search Shape
"4 Event Shape

4 ¥ wind Curtailment
& Active Power
4 Expected Power

Manufacturer

Event.Frames

& Production Delta

Turbine

4 Bearing Shaft Temy

E=lBlade 1 Error
=l Blade 2 Error
=l Blade 3 Error
Blade Total Error

& Blade1, Actual Value

& Blade1, Set Value

4 Blade2, Actual Value

# Blade2, Set Value

_®Rladea actualvale & ||

A wind Turbine

& Production Loss

e QO QO Qe

Assets

+ Matches
Found 100+ Matches

Discover

rE » " GED9 2017-01-01 10:43:39

(3 » "d GED9 2017-01-01 10:43:39

What if you want to
analyze events

a3 » "4 GED9 2017-01-01 10:43:39

L . 4
: - S relative to each other?
S » "H GEQ] 2017-01-01 13;14:15
7 X » "8 GEO12017-01-01 1314115
% # x P "8 GE0T 2017-01-01 131415
» Fd GEO1 2017-01-01 13:14:15
» "d GEO12017-01-01 13:14:15

»_bd oroe an17 01 09 191408

(@ osi-..

Perth Seminar 2019
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Select Data > Modify View > Publish Next
+ Add Column Y Edit Row Filters Edit Value Mode Start Time End Time
e S e 1117 1:14PM | | 2 ] ‘
‘Wind Turbine ‘Wind Curtailment Event Frame Start Time (Local) TimeStamp Eveni Frame Relative Time Second Production Loss Turbine Manufacturer E
Generation\wind Power Generation FleetiWindy Valley Wind Farm\GEQ9 GE09 2017-01-01 10:43:39 1/1/2017 10:43:39 AM 0 0.398 GE09 GE
Generation\wind Power Generation Fleet\Windy Valley Wind Farm\GEQ9 GE09 2017-01-01 10:43:39 1172017 10:43:39 AM 600 0.412 GE09 GE
Generation\Wind Power Generation FleetiWindy Valley Wind Farm\GEQ9 GEO09 2017-01-01 10:43:39 1/1/2017 10:43:39 AM 1200 0.405 GEO09 GE -
Generation\wind Power Generation Fleet\Windy Valley Wind Farm\GEQ9 GE09 2017-01-01 10:43:39 1172017 10:43:39 AM 1800 0.407 GE09 GE D ISCOVe r
Generation\Wind Power Generation FleetiWindy Valley Wind Farm\GEQ9 GEO09 2017-01-01 10:43:39 1/1/2017 10:43:39 AM 2400 0.345 GEO09 GE
Generation\wind Power Generation FleetiWindy Valley Wind Farm\GEQ9 GE09 2017-01-01 10:43:39 1172017 10:43:39 AM 3000 0.391 GE09 GE
Generation\Wind Power Generation FleetiWindy Valley Wind Farm\GEQ9 GEO09 2017-01-01 10:43:39 1/1/2017 10:43:39 AM 3600 0.346 GEO09 GE
Generation\wind Power Generation FleetiWindy Valley Wind Farm\GEQ9 GE09 2017-01-01 10:43:39 1172017 10:43:39 AM 4200 0.377 GE09 GE .
Generation\Wind Power Generation FleetiWindy Valley Wind Farm\GEQ9 GEO09 2017-01-01 10:43:39 1/1/2017 10:43:39 AM 4800 0.407 GEO09 GE I ndex VIeWS
Generation\wind Power Generation FleetiWindy Valley Wind Farm\GEQ9 GE09 2017-01-01 10:43:39 1172017 10:43:39 AM 5400 0.379 GE09 GE Of Operatlonal
Generation\Wind Power Generation FleetiWindy Valley Wind Farm\GEQ9 GEO09 2017-01-01 10:43:39 1/1/2017 10:43:39 AM 6000 0.326 GEO09 GE
Generation\wind Power Generation FleetiWindy Valley Wind Farm\GEQ9 GE09 2017-01-01 10:43:39 1172017 10:43:39 AM 6600 0.31 GE09 GE data by
Generation\Wind Power Generation FleetiWindy Valley Wind Farm\GEQ9 GEO09 2017-01-01 10:43:39 1/1/2017 10:43:39 AM 7200 0333 GEO09 GE
Generation\wind Power Generation FleetiWindy Valley Wind Farm\GEQ9 GE09 2017-01-01 10:43:39 1172017 10:43:39 AM 7800 0.241 GE09 GE events
Generation\Wind Power Generation FleetiWindy Valley Wind Farm\GEQ9 GEO09 2017-01-01 10:43:39 1/1/2017 10:43:39 AM 8400 0.119 GEO09 GE
Generation\wind Power Generation FleetiWindy Valley Wind Farm\GEQ9 GE09 2017-01-01 10:43:39 1172017 10:43:39 AM 9000 0.147 GE09 GE
Generation\Wind Power Generation FleetiWindy Valley Wind Farm\GEQ9 GEO09 2017-01-01 10:43:39 1/1/2017 10:43:39 AM 9600 0219 GEO09 GE Com pare
Generation\Wind Power Generation FleetiWindy Valley Wind Farm\GEQ9 GE09 2017-01-01 10:43:39 1172017 10:43:39 AM 10200 0.322 GEO09 GE
Generation\Wind Power Generation FleetiWindy Valley Wind Farm\GEQ9 GEO09 2017-01-01 10:43:39 1/1/2017 10:43:39 AM 10800 0287 GE09 GE eve nts on a-
Generation\Wind Power Generation FleetiWindy Valley Wind Farm\GEQ9 GE09 2017-01-01 10:43:39 1172017 10:43:39 AM 11400 0.321 GEO09 GE tl mescale
Generation\Wind Power Generation FleetiWindy Valley Wind Farm\GEQ9 GEO09 2017-01-01 10:43:39 1/1/2017 10:43:39 AM 12000 0.353 GE09 GE .
Generation\Wind Power Generation FleetiWindy Valley Wind Farm\GE0S  GEQ9 2017-01-01 10:43:39 | 1/1/2017 10:43:39 AM 12600 0.375 GE09 GE relat|Ve to
Generation\Wind Power Generation FleetiWindy Valley Wind Farm\GEQ9 GEO09 2017-01-01 10:43:39 1/1/2017 10:43:39 AM 13200 0.179 GE09 GE
Generation\Wind Power Generation FleetiWindy Valley Wind Farm\GEQ9 GE09 2017-01-01 10:43:39 1172017 10:43:39 AM 13800 0.057 GEO09 GE Start Of the
Generation\Wind Power Generation FleetiWindy Valley Wind Farm\GEQ9 GEO09 2017-01-01 10:43:39 1/1/2017 10:43:39 AM 14400 0.175 GE09 GE eve nt
Generation\Wind Power Generation FleetiWindy Valley Wind Farm\GEQ9 GE09 2017-01-01 10:43:39 1172017 10:43:39 AM 15000 0.201 GEO09 GE
Generation\Wind Power Generation FleetWindy Valley Wind Farm\GE0Y GE09 2017-01-01 10:43:39 1/1/2017 10:43:39 Al 15600 0075 GE09 GE
Generation\Wind Power Generation Fleet\Black Mesa Wind Farm\GEQS GEO09 2017-01-01 10:43:39 1/1/2017 10:43:39 AM
Generation\Wind Power Generation Fleet\Black Mesa Wind Farm\GEQ9 GE09 2017-01-01 10:43:39 1172017 10:43:39 AM
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Explore

@ OSlsoft, Perth Seminar 2019 © Copyright 2019 OSlsoft, LLC



+ Create Asset View
Build a data vit

Build a streaming view with a

P—

tarting with Build a data vie:

Modify View

# ehana

Edit this View
® Edit a copy of this View

S Asset
LK_windFarm: @ Source Assets

4 Create Event View || + Create Streaming View | & Modify View
ing with

Madify existing data

Select Data > Modify View > Publish

|| X Remove View

Remove selected view

x

v [ Search Shape

S DFPIAFSERVERPRD

v

Database

Power Generation

@) Assets

Ke ‘ @ 6E0S
LK @ GEOe
LK | ) GE07
D GEOs
) GE09
@ GE10

» () Black Wolf wind Farm

» € Deep Valley Wind Farm

» ) Eldorade Wind Farm

» (3 Grand Ridge Wind Farm

» (2 White Bear Wind Farm

» D Wild River Wind Farm

» () windy valley Wind Farm

» @ vellow Creek Wind Farm
» (@ wind Power Maintenance Crews
» D Windtopia

» A Navination Treac

Attributes

O Select All

» & Active Power
& Apparent Power
4 Apparent Power (calc)
BatchwindBinFilter

» 4 Bearing A Temperature

» 4 Bearing B Temperature

4 Bearing Shaft Temperature

=l Blade 1 Error

(- T T - - T -

T Asset Shape

4 @ Wind Turbine
& Active Fower
& Apparent Power
4P Bearing A Temperature
& Capacity
Operating Efficiency
& Rotor Speed

#,x
& x
& x
& x
#Sx
#Sx
#,x

 Matches
Found 75 Matches
» @ cE0T
» @ cEo
» ) cE0
» D cE0
» D GE0T
» I GE0T
» @ cE0T
» @ cEo
» @ cE0
» @ cE0
» D GE02
» IGE02
» QcE02
» ) GE02
» @ cEo2
» @ GE02
» D GE02
» I GE02
» QGE02
» Q) cE02
» ©)cEos
» ) GE03
» D GE03
» I GEO3
» IGE03
» cE03
» @ cEo3
» B cE03
» D GE03
» I GEO3
» ) GED4

Explore

Adjust a new
view starting from
the previous view

ﬂ OSlsoft, Perth Seminar 2019

© Copyright 2019 OSlsoft, LLC



Implement
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+ Create Asset View
Build & data v
your asset hie

ting wit

+ Create Event View

Build a data vie
your ne hiera

4 Create Streaming View

& Modify View

Madify &

® Remove View
Remove selected view

Name

Ef

Run Status
EF_View Example KP_Not Yet Published

Type
Event

|s; SelectData > Modify View > Publish

Isi @
KF

K SelectData > Modify View > Publish

KE @ Source Assets
Lk
Lk

) Isabelle_PowerGen

@ LK Test

Run Mode
once

~ ) Search Shape
T, Asset Shape

Start Time
10/5M16 4:17 Al

LK_WindFarm_Stream

End Time

=

LK_WindFarm_Stream

4 @ wind Turbine

Asset

& Active Power

Asset & Apparent Power

) LK_WindFarm

Asset

() Rory Test Asset
() TestGrubbs

© Wind_Data Ali
*H Dis_EF_TEST1

" EFTESY

d | &

o

KP_EFViewTest2

oF

" bpope_test

) KP_Streamtest
) VerseAl - Stream 1

@ test

EF_View_Example_KP

Isabelle_HRSG_Events

KP_Nonstream_EFView_Test

& Capacity

4 Bearing A Temperature

Asset Operating Efficiency

Asset
Asset
Event
Event
Event
Event
Event
Event
Event
Streaming Out
Streaming Out

Streaming Out

Use this Shape

4 Rotor Speed

Last Run Time

NEVEr

& x
£ x
&%
&£ x
&%
&£ x
S x

 Matches
Found 75 Matches
» QGE0
» @GE0
» @cE0
» @ cE0
» @ GE0
» @ cE0
» ) GEOT
» @ 6GE0
» @GE0
» QGE0
» @ GE02
» ) GE0Z
» @ GE02
» ) GE0Z
» ) GE02
» @ GEOZ
» ) GE02
» @ cE02
» ) GE0Z
» ) GE02
» ) GE02
» Q) GE02
» ) cE0Z
» ) GE02
» ) GE0Z

» ) cE02

=y

=

@ = ™ & OSl\ikhounlavong &

Next

@ ~ L OSi\khounlavong &

Next

Implement

Create a stream
of features for
your algorithm

Begin from the
shape of your
training data

(@ osi

s
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Select Data > Modify View > Publish

T Shapes
T Asset Shape
4 (@ wind Turbine

# Active Power
& Apparent Power
4 Bearing A Temperature
4 Capacity
Operating Efficiency
4 Rotor Speed

Message Designer

Schema Options Message Trigger

Syncing mode (flsttensd) rig

e measage when 1 kay

Backiill Data
Do not backill data

Message Filters
0filters

% -
#x
Trigger a message in regular time intervals: v
& x a I
@® Trigger a new message when the key value(s) selected below have changed
SR
'® Trigger a message when any of the selected key values have changed
SR
’ Trigger a message when all of the selected key values have changed a \./
x
Triggeron () Archive Data (®) Snapshot Data
#x v v IV
R| Message Content
“"Wind Turbine": "[@uina Turbine (Name) v, s
7|  "Active Power": "[@ Active Pouer (Value) v,
o P

4 Apparent Power

“Apparent Pover":

(Value)

Select Data > Modify View > Publish

Target Configuration

Summary

Verseai Stream

v Shape and Matches

Run Mode

First Run

» There are 75 Matching Instances
Timeframe and Interval

» ‘Your Start Time is *

|

Publish

Preview

Preview Start Time

Preview End Time

“ = A 0Shkhounlavong &

*.8h ‘

i "GER1”,

“Active Power”: 1155.8897216796875,

“Apparent Pawer”: §01.489990234375,

“Bearing A Temperature”: 37.51898411376953,
“Capacity”: €.590443134307861,

“Operating Efficiency”: 95.10331493280601,
“Rotor Speed”: 19.7457275390625,
19-03-15T81:26:19. 423095707 : 00"

“Timestamp”

: "Gee1”,
ive Power”: 1118.7607421875,

"Apparent Power”: B889.1935424884688,

"Bearing A Temperature™: 37.61298751831055,
"Capacity”: 6.515348295593262,

“Operating Efficiency”: 95.09685325688397,
"Rotor Speed”: 19.595481872558594,

"Timestamp”: "2019-83-15T81:26:33.1416915-07:08"

» Trigger a new message as values change

Implement

Adjust object if
needed and
determine how it
updates

Pick a messaging
hub to stream to

(@ osi

s
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Summary
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C b [N . Select Data > Modify View > Publish Next
llities That Streamline
ap a =+ Add Column T Edit Row Filters £= Edit Value Mode Start Time End Time
Ad d Analyti = 8 |- A
V an C e n a yt I C S Wind Turbine TimeStamp Day of the Week  Active Power  Apparent Power  Bearing A Temperature  Capacity  Rotor Speed Operalilgl

GEO1 3/18/2019 10:52.57.477 AM Monday 1,517.787 1.523.764 42,523 62.831 19.927 90.403

GEO1 3/18/2019 10-53:57 477 AM Monday 151878 1517 996 42 515 62 877 2039 90 421

([ ] C O n text GEO1 3/18/2019 10:5457.477 AM  Monday 1,528.438 1,527.098 42.507 62.924 19.877 90.44
GEO1 3/18/2019 10:55:57.477 AM  Monday 1,524.599 1,525.12 42.498 62.97 20.002 90.459
GEO1 3/18/2019 10-56-57 477 AM Monday 1521875 1521751 42 49 63.016 19913 90 478
GEO1 3/18/2019 10°-57°57 477 AM  Monday 1525674 1531623 42 481 63 063 19726 90 497
GEO1 3/18/2019 10:58:57.477 AM  Monday 1,535.935 1,536.558 42.473 63.109 20,013 90.516
GEO1 3/18/2019 10:59:57.477 AM Monday 1,517.37 1.519.13 42.465 63.155 20.232 90.535
P N O r m al I Z ati O n GEO1 3/18/2019 11°00°57 477 AM Monday 1,528 547 1529 658 42 456 63 202 20 065 90 554
GEO1 3/18/2019 11:01:57.477 AM  Monday 1,529.736 1,524.135 42.448 63.248 19.922 90.573
GEO1 3/18/2019 11:0257.477T AM  Monday 1,517.794 1,525.652 42.439 63.294 19.955 90.592

GEO1 3/18/2019 110357 477 AM Monday 1505852 1512 247 42 431 63 341 19708 90 61
GEO1 3/18/2019 11.0457.477 AM  Monday 1,519.556 1,521.107 42.423 63.387 20.054 90.627
GEO1 3/18/2019 11:05:57.477 AM  Monday 1,519.952 1,523.781 42414 63.433 20173 90.644
. GEO1 3/18/2019 110657 477 AM Monday 1523877 1,508 615 42 406 63 48 19949 90 662

® Eve nt M arkl n g GEO1 3/18/2019 110757477 AM  Monday 1533151 1,532 751 42 397 63 526 1994 90 68
GEO1 3/18/2019 11:08:57.477 AM  Monday 1,525.437 1,526.634 42.389 63.572 19.999 90.698
GEO1 3/18/2019 11:09.57.477 AM  Monday 1,523.269 1.518.825 42.381 63.619 19.862 90.716
GEO1 3/18/2019 11-10°57 477 AM Monday 1522 443 1522 936 42 372 63 665 20009 90,733

GEO1 3/18/2019 11:11:57.477 AM  Monday 1,509.033 1,522.19 42.364 63.712 1963 90.75
. GEO1 3/18/2019 1111257477 AM  Monday 1,524.965 1,525.264 42.355 63.758 20.008 90.767
) Ite ratlve WO rkfl OWS GEO1 3/18/2019 111357 477 AM Monday 1511918 1,508 629 42 347 63 804 19621 90 784
GEO1 3/18/2019 111457 477 AM  Monday 151961 1523788 42 339 63 851 19749 90 801
GEO1 3/18/2019 1111557477 AM Monday 1,526.237 1,524.405 42.33 63.897 19.949 90.818
GEO1 3/18/2019 11:16:57.477 AM Monday 1,532.863 1.525.036 42,322 63.943 19.886 90.835
GEO1 3/18/201% 111757 477 AM Monday 1509635 1515 866 42313 63.99 19921 90 855
GEO1 3/18/2019 11:118:57.477 AM  Monday 1,522,636 1,525.022 42.305 64.036 19.992 90.876
- - - GEO1 3/18/2019 111957477 AM Monday 1,518.829 1,519.512 42,295 64.082 20.067 90.893

® O p e ratl O n aI I Z atl O n GEO1 3/18/2019 112057 477 AM Monday 152732 1526 332 42288 64129 20043 90 91
GEO1 3/18/2019 112167477 AM  Monday 1515018 1,516 243 1228 64175 19828 90 926
GEO1 3/18/2019 11:2257477 AM  Monday 1,506.233 1,506.149 42.271 64.221 19684 90.943

@ OSlsoft, Perth Seminar 2019 © Copyright 2019 OSlsoft, LLC



Summary

« Advanced Analytics
— Start with a small project that involves SMEs
— Use an iterative approach to your projects

* Pl Integrators

— Support analytics workflows with drag-and-drop data
preparation for SMEs

— Provide native integration to a variety of advanced analytics
platforms and Bl Tools

— Sends curated data via bulk and incremental uploads and
streams
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Pl System Accelerates and Operationalises Advanced Analytics

-:® | business

1
0
1
0
1
0

intelligence tool

data warehouse

;

l. \\\ A‘
3 8 Q

Assets

push trained algorithm

a-Tae-.era.,., ™ @@ & -y TT7=
—
-_—
-_—
1 datalake OR P RREPPRE OFRPORRPRREPOPRR
0
° stream
. processor
0 S . .
1 ; machine learning
0
0
1
0

7
7

- OSl=ofi.

’ ‘) \
[ N SR
i ‘\\) ‘B -

Automation Systems  Edge Devices / Sensors loT solutions

¢

osl
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{O Pl Integrator for Pl Integrator for Pl Integrator for
AL

| Business Analytics SAP HANA Esri ArcGIS
New! Support for Amazon 2018 R2 2017 2017 SP1

Category Destination Standard Advanced

Setore

Hub Azure loT Hub or Event Hubs

R NN NN

SN BRSNS

Amazon Kinesis Data Streams
ArcGIS GeoEvent Server v
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